summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPlaton Ryzhikov2020-08-24 11:10:44 +0300
committerPlaton Ryzhikov2020-08-24 11:10:44 +0300
commitaf7d94e95b9a4c6aa5c9df94f0bb9154cf3ab656 (patch)
tree61a60e32c1af759842f057d53804f69e6a99d35c
parent549bf68034eec06b42b93827337cfec2a2941c0e (diff)
downloadaur-cups-noudev.tar.gz
update to 2.3.3-3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48b8cda683f..7a37e47844b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = cups-noudev
pkgver = 2.3.3
- pkgrel = 1
+ pkgrel = 3
url = https://www.cups.org/
arch = x86_64
+ arch = aarch64
license = Apache
license = custom
makedepends = libtiff
@@ -21,9 +22,9 @@ pkgbase = cups-noudev
makedepends = libusb
makedepends = avahi
makedepends = hicolor-icon-theme
+ makedepends = libxcrypt
makedepends = inetutils
makedepends = libpaper
- makedepends = valgrind
source = https://github.com/apple/cups/releases/download/v2.3.3/cups-2.3.3-source.tar.gz
source = https://github.com/apple/cups/releases/download/v2.3.3/cups-2.3.3-source.tar.gz.sig
source = cups.logrotate
@@ -52,6 +53,7 @@ pkgname = libcups-noudev
depends = krb5
depends = avahi
depends = libusb
+ depends = libxcrypt
provides = libcups=2.3.3
conflicts = libcups
diff --git a/PKGBUILD b/PKGBUILD
index 513e047326d..535a7eb9153 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,13 +11,13 @@ _pkgbase="cups"
pkgbase="cups-noudev"
pkgname=('libcups-noudev' 'cups-noudev')
pkgver=2.3.3
-pkgrel=1
-arch=('x86_64')
+pkgrel=3
+arch=('x86_64' 'aarch64')
license=('Apache' 'custom')
url="https://www.cups.org/"
makedepends=('libtiff' 'libpng' 'acl' 'pam' 'xdg-utils' 'krb5' 'gnutls'
'cups-filters' 'bc' 'colord' 'xinetd' 'gzip' 'autoconf' 'libusb'
- 'avahi' 'hicolor-icon-theme' 'inetutils' 'libpaper' 'valgrind')
+ 'avahi' 'hicolor-icon-theme' 'libxcrypt' 'inetutils' 'libpaper')
source=(https://github.com/apple/cups/releases/download/v${pkgver}/cups-${pkgver}-source.tar.gz{,.sig}
cups.logrotate
cups.pam
@@ -99,7 +99,7 @@ check() {
package_libcups-noudev() {
pkgdesc="The CUPS Printing System - client libraries and headers"
-depends=('gnutls' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi' 'libusb')
+depends=('gnutls' 'libtiff>=4.0.0' 'libpng>=1.5.7' 'krb5' 'avahi' 'libusb' 'libxcrypt')
provides=("libcups=${pkgver}")
conflicts=("libcups")
cd ${_pkgbase}-${pkgver}