summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2015-08-06 10:50:39 +0200
committerGrey Christoforo2015-08-06 10:50:39 +0200
commit127f88301e64f94d60c938e4ed292335c2bddd58 (patch)
treeed2f0f6974b1f9dc698c6546710db5228f100e06
parent3b009de7b7f224f8becc3dc67596dbb95c6865cc (diff)
downloadaur-127f88301e64f94d60c938e4ed292335c2bddd58.tar.gz
updating to build from source...
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD36
-rw-r--r--cura.install (renamed from .install)0
3 files changed, 22 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c866dbb6d622..acc872e62fbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = cura
- pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 15.04
+ pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker (built from source).
+ pkgver = 15.06.02
pkgrel = 1
- url = https://github.com/daid/Cura
- install = .install
+ url = https://ultimaker.com/en/products/cura-software
+ install = cura.install
arch = i686
arch = x86_64
license = AGPLv3
@@ -14,6 +14,8 @@ pkgbase = cura
depends = python2-numpy
depends = python2-power-git
provides = cura
+ source = https://github.com/Ultimaker/Cura/archive/15.06.02.tar.gz
+ sha1sums = 3dd2affd90183a9c9ad5ea95f653b4936cc93657
pkgname = cura
diff --git a/PKGBUILD b/PKGBUILD
index d9d9293811ee..acb38a519fe1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,44 @@
-# Maintainer: balwierz <my user name at the most popular google email service>
-pkgbase=cura
+# Maintainer: Grey Christoforo <my first name at my last name dot net>
+
pkgname=cura
-pkgver=15.04
+pkgver=15.06.02
pkgrel=1
-pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
+pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker (built from source)."
depends=('python2' 'wxpython' 'python2-opengl' 'python2-pyserial' 'python2-numpy' 'python2-power-git')
provides=('cura')
-url="https://github.com/daid/Cura"
+url="https://ultimaker.com/en/products/cura-software"
license=('AGPLv3')
arch=('i686' 'x86_64')
-if [ "$CARCH" == x86_64 ]; then
- source+=(http://software.ultimaker.com/current/cura_${pkgver}-debian_amd64.deb)
- sha1sums+=('16ebec62f0811a2cc1d7562b5d7d5bdd35f9ea54')
-elif [ "$CARCH" == i686 ]; then
- source+=(http://software.ultimaker.com/current/cura_${pkgver}-debian_i386.deb)
- sha1sums+=('e18e5bd4bd72e2af8d97102aea5ecaaf4e93e856')
-fi
+source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz)
+sha1sums=('3dd2affd90183a9c9ad5ea95f653b4936cc93657')
-install=.install
+install=cura.install
build()
{
cd "${srcdir}"
# unpack
- tar --xz -xf data.tar.xz
+ #tar --xz -xf data.tar.xz
}
package()
{
+ msg2 "Packaging"
# remove python-power since we have it in the deps:
- rm -rf "${srcdir}"/usr/share/cura/power/
+ #rm -rf "${srcdir}"/usr/share/cura/power/
# change python to python2 everywhere:
- sed -i 's|\/usr\/bin\/python|\/usr\/bin\/python2|' "${srcdir}"/usr/share/applications/cura.desktop "${srcdir}"/usr/share/cura/cura.py "${srcdir}"/usr/bin/cura
+ #sed -i 's|\/usr\/bin\/python|\/usr\/bin\/python2|' "${srcdir}"/usr/share/applications/cura.desktop "${srcdir}"/usr/share/cura/cura.py "${srcdir}"/usr/bin/cura
# add a new line (pedantic):
- echo >> "${srcdir}/usr/bin/cura"
+ #echo >> "${srcdir}/usr/bin/cura"
# add the path since we need to call slicer exactly from /usr/share/cura
- sed -i '6 i os.chdir("/usr/share/cura")' "${srcdir}"/usr/share/cura/cura.py
- sed -i 's|os.path.dirname(__file__)|"/usr/share/cura"|' "${srcdir}"/usr/share/cura/cura.py
+ #sed -i '6 i os.chdir("/usr/share/cura")' "${srcdir}"/usr/share/cura/cura.py
+ #sed -i 's|os.path.dirname(__file__)|"/usr/share/cura"|' "${srcdir}"/usr/share/cura/cura.py
- cp -r "${srcdir}"/usr "${pkgdir}"/usr
+ #cp -r "${srcdir}"/usr "${pkgdir}"/usr
}
diff --git a/.install b/cura.install
index 3d4ea4a33be3..3d4ea4a33be3 100644
--- a/.install
+++ b/cura.install