summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJelle van der Waa2022-09-01 21:29:53 +0200
committerJelle van der Waa2022-09-01 21:29:53 +0200
commit2ea57786f12661ff9814ee5597e1c7348b022f50 (patch)
treeef176edebb7b00a90775d69c6a637158f23d8687
parent6c62e178dc8f53fdca4a6fabbaf235adcc8b7970 (diff)
downloadaur-2ea57786f12661ff9814ee5597e1c7348b022f50.tar.gz
import from community
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD61
-rw-r--r--cura-4.13.0-no-sentry.patch22
3 files changed, 75 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29ecff798df2..73d9a8d8d78c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,35 @@
-# Generated by mksrcinfo v8
-# Sat Feb 25 19:40:54 UTC 2017
pkgbase = cura
pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 2.4.0
- pkgrel = 2
- url = https://ultimaker.com/en/products/cura-software
- install = cura.install
- arch = i686
- arch = x86_64
- license = AGPLv3
+ pkgver = 4.13.1
+ pkgrel = 1
+ url = https://ultimaker.com/software/ultimaker-cura
+ arch = any
+ license = LGPL
makedepends = qt5-tools
makedepends = cmake
- depends = python-pyqt5-hotfix
+ depends = python-pyqt5
depends = qt5-svg
depends = python-scipy
depends = python-pyserial
depends = python-numpy
depends = uranium
+ depends = python-requests
depends = curaengine
- depends = cura-binary-data
+ depends = libsavitar
+ depends = qt5-graphicaleffects
+ depends = python-certifi
+ depends = python-pynest2d
+ depends = python-keyring
+ depends = python-trimesh
+ depends = cura-resources-materials
+ optdepends = python-zeroconf: network printing support
+ optdepends = python-trimesh: Reading AMF files
+ optdepends = python-libcharon: UFPWriter/UFPReader
+ optdepends = cura-binary-data: Binary data (firmwares and such) for cura
provides = cura
- source = https://github.com/Ultimaker/Cura/archive/2.4.0.tar.gz
- sha1sums = 8f21748b27ef7e6fd7b07c2c6f81695f073a6840
+ source = cura-4.13.1.tar.gz::https://github.com/Ultimaker/Cura/archive/4.13.1.tar.gz
+ source = cura-4.13.1-no-sentry.patch::https://github.com/Ultimaker/Cura/commit/aad41807c365ccef001b787407d7dc756e11de02.patch
+ sha512sums = 6483fd6312bd2181cc812bce78aadc7e8532ecf292f09c75ce5e7870f7efddd63e84315ab40eb73c775b15c2ed2ce7fc804fcbefb73b3d8aaac77d8b22f0cbd0
+ sha512sums = c602c5e585862d9bab280a8d5bd2289fe1b10d79f54cd76171b76fcf48793b190ff5bf6fca22818d8b65a726ee64098750c79cba67f044e0186a83aeb78e8a14
pkgname = cura
-
diff --git a/PKGBUILD b/PKGBUILD
index 8acf0a470b9c..834772b87519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,37 @@
-# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
+# Maintainer: Jelle van der Waa <jelle@archlinux.org>
+# Contributor: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=2.4.0
-pkgrel=2
+pkgver=4.13.1
+pkgrel=1
pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
-depends=('python-pyqt5-hotfix' 'qt5-svg' 'python-scipy' 'python-pyserial' 'python-numpy' 'uranium' 'curaengine' 'cura-binary-data')
+depends=('python-pyqt5' 'qt5-svg' 'python-scipy' 'python-pyserial' 'python-numpy' 'uranium' 'python-requests'
+ 'curaengine' 'libsavitar' 'qt5-graphicaleffects'
+ 'python-certifi' 'python-pynest2d' 'python-keyring' 'python-trimesh'
+ 'cura-resources-materials')
makedepends=('qt5-tools' 'cmake')
+optdepends=('python-zeroconf: network printing support'
+ 'python-trimesh: Reading AMF files'
+ 'python-libcharon: UFPWriter/UFPReader'
+ 'cura-binary-data: Binary data (firmwares and such) for cura')
+
provides=('cura')
-url="https://ultimaker.com/en/products/cura-software"
-license=('AGPLv3')
-arch=('i686' 'x86_64')
-source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz)
-sha1sums=('8f21748b27ef7e6fd7b07c2c6f81695f073a6840')
+url="https://ultimaker.com/software/ultimaker-cura"
+license=('LGPL')
+arch=('any')
+source=($pkgname-$pkgver.tar.gz::https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz
+ cura-${pkgver}-no-sentry.patch::https://github.com/Ultimaker/Cura/commit/aad41807c365ccef001b787407d7dc756e11de02.patch)
+sha512sums=('6483fd6312bd2181cc812bce78aadc7e8532ecf292f09c75ce5e7870f7efddd63e84315ab40eb73c775b15c2ed2ce7fc804fcbefb73b3d8aaac77d8b22f0cbd0'
+ 'c602c5e585862d9bab280a8d5bd2289fe1b10d79f54cd76171b76fcf48793b190ff5bf6fca22818d8b65a726ee64098750c79cba67f044e0186a83aeb78e8a14')
-install=cura.install
+# Build order
+# arcus -> uranium -> curaengine -> libsavitar -> pynest2d ->
prepare(){
cd Cura-${pkgver}
- sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages,DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
- sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/cura),DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/cura),g' CMakeLists.txt
-
- cat > "${srcdir}/${pkgname}.desktop" <<END
-[Desktop Entry]
-Type=Application
-Name=${pkgname^}
-Comment=${pkgdesc}
-Exec=${pkgname}
-Icon=/usr/share/cura/resources/themes/cura/icons/application.svg
-Terminal=false
-END
+ sed -i 's,/dist-packages,.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
+
+ patch -Np1 -i $srcdir/cura-${pkgver}-no-sentry.patch
}
build(){
@@ -37,8 +40,12 @@ build(){
cd build
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts
+ -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts \
+ -DCURA_VERSION=$pkgver \
+ -DCURA_SDK_VERSION=6.0.0 \
+ -DCURA_CLOUD_API_VERSION=1 \
+ -DCURA_CLOUD_API_ROOT:STRING="https://api.ultimaker.com" \
+ -DCURA_CLOUD_ACCOUNT_API_ROOT:STRING="https://account.ultimaker.com"
make
}
@@ -52,10 +59,4 @@ package(){
# don't ever send any user or print info through the internet to Ultimaker
rm -rf "${pkgdir}/usr/lib/cura/plugins/SliceInfoPlugin"
-
- # install .desktop file
- install -D -t "${pkgdir}/usr/share/applications" "${srcdir}/${pkgname}.desktop"
-
}
-
-
diff --git a/cura-4.13.0-no-sentry.patch b/cura-4.13.0-no-sentry.patch
new file mode 100644
index 000000000000..30d22978f4ff
--- /dev/null
+++ b/cura-4.13.0-no-sentry.patch
@@ -0,0 +1,22 @@
+From aad41807c365ccef001b787407d7dc756e11de02 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Gabriel=20F=C3=A9ron?= <g@leirbag.net>
+Date: Tue, 11 Jan 2022 20:28:41 +0100
+Subject: [PATCH] Remove unused import of sentry_sdk
+
+---
+ cura/CrashHandler.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/cura/CrashHandler.py b/cura/CrashHandler.py
+index c911a423504..35e9aa832be 100644
+--- a/cura/CrashHandler.py
++++ b/cura/CrashHandler.py
+@@ -12,8 +12,6 @@
+ import locale
+ from typing import cast, Any
+
+-import sentry_sdk
+-
+ try:
+ from sentry_sdk.hub import Hub
+ from sentry_sdk.utils import event_from_exception