summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-08-08 18:15:46 +0100
committerGrey Christoforo2016-08-08 18:15:46 +0100
commit41f7697f495c42236dbebccb0b830aa99a846cde (patch)
treeb7d5b90c2b6172846d42352d607bc15047e4e10e
parent4a062e478d277f5962b20accece6dbe1dfeab53c (diff)
downloadaur-41f7697f495c42236dbebccb0b830aa99a846cde.tar.gz
version bump to 2.1.3
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 75c99ad7fe62..cd65ef58659d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue May 24 15:38:31 UTC 2016
+# Mon Aug 8 17:14:29 UTC 2016
pkgbase = cura
pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 2.1.0
+ pkgver = 2.1.3
pkgrel = 1
url = https://ultimaker.com/en/products/cura-software
install = cura.install
@@ -17,9 +17,9 @@ pkgbase = cura
depends = uranium
depends = curaengine
provides = cura
- source = https://github.com/Ultimaker/Cura/archive/2.1.0.tar.gz
+ source = https://github.com/Ultimaker/Cura/archive/2.1.3.tar.gz
source = fix-python-dir.patch
- sha1sums = ac5893d13630bc85176c50c49244b6461ccb54f4
+ sha1sums = 6318bea1603bbf3e43202f0894780de433c97410
sha1sums = 439a5efb8371bbfd1266a6b6434c0584f00baaa9
pkgname = cura
diff --git a/PKGBUILD b/PKGBUILD
index 8d49c2f42510..2457c56a5921 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=2.1.0
+pkgver=2.1.3
pkgrel=1
pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
depends=('qt5-svg' 'python-pyserial' 'python-numpy' 'uranium' 'curaengine')
@@ -11,7 +11,7 @@ url="https://ultimaker.com/en/products/cura-software"
license=('AGPLv3')
arch=('i686' 'x86_64')
source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz fix-python-dir.patch)
-sha1sums=('ac5893d13630bc85176c50c49244b6461ccb54f4'
+sha1sums=('6318bea1603bbf3e43202f0894780de433c97410'
'439a5efb8371bbfd1266a6b6434c0584f00baaa9')
install=cura.install
@@ -20,7 +20,7 @@ prepare(){
cd Cura-${pkgver}
patch -Np1 -i ../fix-python-dir.patch
- cat > ${pkgname}.desktop <<END
+ cat > "${srcdir}/${pkgname}.desktop" <<END
[Desktop Entry]
Type=Application
Name=${pkgname^}
@@ -33,12 +33,18 @@ END
build(){
cd Cura-${pkgver}
- cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts
+ mkdir -p build
+ cd build
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts
+
make
}
package(){
- cd Cura-${pkgver}
+ cd Cura-${pkgver}/build
make DESTDIR="${pkgdir}" install
# make sure cura can find uranium plugins:
@@ -48,10 +54,8 @@ package(){
rm -rf "${pkgdir}/usr/lib/cura/plugins/SliceInfoPlugin"
# install .desktop file
- install -D -t ${pkgdir}/usr/share/applications ${pkgname}.desktop
+ install -D -t "${pkgdir}/usr/share/applications" "${srcdir}/${pkgname}.desktop"
- # rename executable
- #mv ${pkgdir}/usr/bin/cura_app.py ${pkgdir}/usr/bin/cura
}