summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-05-24 16:38:35 +0100
committerGrey Christoforo2016-05-24 16:38:35 +0100
commit4a062e478d277f5962b20accece6dbe1dfeab53c (patch)
treeaaf27818667997c7ea9878c584f3c9786d41182a
parent1d094274ac4a5d5b46041bc3edfa73dc58da77b5 (diff)
downloadaur-4a062e478d277f5962b20accece6dbe1dfeab53c.tar.gz
version bump
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
-rw-r--r--fix-python-dir.patch15
-rw-r--r--site-packages-dir.patch14
4 files changed, 35 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b50f0db2e283..75c99ad7fe62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Mar 27 18:23:17 UTC 2016
+# Tue May 24 15:38:31 UTC 2016
pkgbase = cura
pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 15.06.03
- pkgrel = 4
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://ultimaker.com/en/products/cura-software
install = cura.install
arch = i686
@@ -17,10 +17,10 @@ pkgbase = cura
depends = uranium
depends = curaengine
provides = cura
- source = https://github.com/Ultimaker/Cura/archive/15.06.03.tar.gz
- source = site-packages-dir.patch
- sha1sums = d03d3e86fd40de6e791301b696c8c53ae288faa7
- sha1sums = a1a21f761ababccf366ce100c536b21e83c69fb9
+ source = https://github.com/Ultimaker/Cura/archive/2.1.0.tar.gz
+ source = fix-python-dir.patch
+ sha1sums = ac5893d13630bc85176c50c49244b6461ccb54f4
+ sha1sums = 439a5efb8371bbfd1266a6b6434c0584f00baaa9
pkgname = cura
diff --git a/PKGBUILD b/PKGBUILD
index dc9f882f7e64..8d49c2f42510 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=15.06.03
-pkgrel=4
+pkgver=2.1.0
+pkgrel=1
pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
depends=('qt5-svg' 'python-pyserial' 'python-numpy' 'uranium' 'curaengine')
makedepends=('qt5-tools' 'cmake')
@@ -10,15 +10,15 @@ provides=('cura')
url="https://ultimaker.com/en/products/cura-software"
license=('AGPLv3')
arch=('i686' 'x86_64')
-source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz site-packages-dir.patch)
-sha1sums=('d03d3e86fd40de6e791301b696c8c53ae288faa7'
- 'a1a21f761ababccf366ce100c536b21e83c69fb9')
+source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz fix-python-dir.patch)
+sha1sums=('ac5893d13630bc85176c50c49244b6461ccb54f4'
+ '439a5efb8371bbfd1266a6b6434c0584f00baaa9')
install=cura.install
prepare(){
cd Cura-${pkgver}
- patch -Np1 -i ../site-packages-dir.patch
+ patch -Np1 -i ../fix-python-dir.patch
cat > ${pkgname}.desktop <<END
[Desktop Entry]
@@ -40,12 +40,18 @@ build(){
package(){
cd Cura-${pkgver}
make DESTDIR="${pkgdir}" install
+
+ # make sure cura can find uranium plugins:
+ ln -s /usr/lib/uranium/plugins/* "${pkgdir}/usr/lib/cura/plugins/."
+
+ # don't ever send any user or print info through the internet to Ultimaker
+ rm -rf "${pkgdir}/usr/lib/cura/plugins/SliceInfoPlugin"
# install .desktop file
install -D -t ${pkgdir}/usr/share/applications ${pkgname}.desktop
# rename executable
- mv ${pkgdir}/usr/bin/cura_app.py ${pkgdir}/usr/bin/cura
+ #mv ${pkgdir}/usr/bin/cura_app.py ${pkgdir}/usr/bin/cura
}
diff --git a/fix-python-dir.patch b/fix-python-dir.patch
new file mode 100644
index 000000000000..103e0872ce27
--- /dev/null
+++ b/fix-python-dir.patch
@@ -0,0 +1,15 @@
+--- a/CMakeLists.txt 2016-04-12 16:39:03.000000000 +0100
++++ b/CMakeLists.txt 2016-05-24 16:04:27.614499586 +0100
+@@ -65,10 +65,10 @@
+ PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ RENAME cura)
+ install(DIRECTORY cura
+- DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages
++ DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
+ FILES_MATCHING PATTERN *.py)
+ install(FILES ${CMAKE_BINARY_DIR}/CuraVersion.py
+- DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/cura)
++ DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/cura)
+ install(FILES cura.desktop
+ DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
+ install(FILES cura.sharedmimeinfo
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
deleted file mode 100644
index 9bdb56a796e2..000000000000
--- a/site-packages-dir.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/CMakeLists.txt 2015-07-27 17:50:10.000000000 +0100
-+++ b/CMakeLists.txt 2015-08-23 19:03:35.627848083 +0100
-@@ -61,10 +61,5 @@
- install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/cura)
- install(DIRECTORY plugins DESTINATION lib/cura)
- install(FILES cura_app.py DESTINATION ${CMAKE_INSTALL_BINDIR} PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
--if(NOT APPLE AND NOT WIN32)
-- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
-- install(FILES cura.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
--else()
-- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
--endif()
-+install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
-