summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo:wq2015-08-24 08:40:05 +0100
committerGrey Christoforo:wq2015-08-24 08:40:05 +0100
commitfb3a7de17f3b410baca40f624664e9b1e4dea47f (patch)
treeaef27f02d09f5d4918fbf420e584b2c24d497995
parent127f88301e64f94d60c938e4ed292335c2bddd58 (diff)
downloadaur-fb3a7de17f3b410baca40f624664e9b1e4dea47f.tar.gz
attempt to build from scratch (not working yet)
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--site-packages-dir.patch14
4 files changed, 52 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acc872e62fbf..c36b339708e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = cura
- pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker (built from source).
- pkgver = 15.06.02
+ pkgdesc = A software solution for 3D printing aimed at RepRaps and the Ultimaker.
+ pkgver = 15.06.03
pkgrel = 1
url = https://ultimaker.com/en/products/cura-software
- install = cura.install
arch = i686
arch = x86_64
license = AGPLv3
- depends = python2
- depends = wxpython
- depends = python2-opengl
- depends = python2-pyserial
- depends = python2-numpy
- depends = python2-power-git
+ makedepends = qt5-tools
+ depends = qt5-svg
+ depends = python-pyserial
+ depends = python-numpy
+ depends = uranium
+ depends = curaengine
provides = cura
- source = https://github.com/Ultimaker/Cura/archive/15.06.02.tar.gz
- sha1sums = 3dd2affd90183a9c9ad5ea95f653b4936cc93657
+ source = https://github.com/Ultimaker/Cura/archive/15.06.03.tar.gz
+ source = site-packages-dir.patch
+ sha1sums = d03d3e86fd40de6e791301b696c8c53ae288faa7
+ sha1sums = a1a21f761ababccf366ce100c536b21e83c69fb9
pkgname = cura
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4552cbc6889a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar*
+pkg
+src
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index acb38a519fe1..ca9c8da48cfb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,36 @@
-# Maintainer: Grey Christoforo <my first name at my last name dot net>
+# Maintainer: Grey Christoforo <my first name [at] my last name [dot] net>
pkgname=cura
-pkgver=15.06.02
+pkgver=15.06.03
pkgrel=1
-pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker (built from source)."
-depends=('python2' 'wxpython' 'python2-opengl' 'python2-pyserial' 'python2-numpy' 'python2-power-git')
+pkgdesc="A software solution for 3D printing aimed at RepRaps and the Ultimaker."
+depends=('qt5-svg' 'python-pyserial' 'python-numpy' 'uranium' 'curaengine')
+makedepends=('qt5-tools')
provides=('cura')
url="https://ultimaker.com/en/products/cura-software"
license=('AGPLv3')
arch=('i686' 'x86_64')
-source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz)
-sha1sums=('3dd2affd90183a9c9ad5ea95f653b4936cc93657')
+source=(https://github.com/Ultimaker/Cura/archive/${pkgver}.tar.gz site-packages-dir.patch)
+sha1sums=('d03d3e86fd40de6e791301b696c8c53ae288faa7'
+ 'a1a21f761ababccf366ce100c536b21e83c69fb9')
-install=cura.install
+#install=cura.install
-build()
-{
- cd "${srcdir}"
-
- # unpack
- #tar --xz -xf data.tar.xz
+prepare(){
+ cd Cura-${pkgver}
+ patch -Np1 -i ../site-packages-dir.patch
+}
+
+build(){
+ cd Cura-${pkgver}
+ cmake ./ -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts
+ make
}
-package()
-{
- msg2 "Packaging"
+package(){
+ cd Cura-${pkgver}
+ #python setup.py install --root="$pkgdir/" --optimize=1
+ make DESTDIR="${pkgdir}" install
# remove python-power since we have it in the deps:
#rm -rf "${srcdir}"/usr/share/cura/power/
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
new file mode 100644
index 000000000000..9bdb56a796e2
--- /dev/null
+++ b/site-packages-dir.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt 2015-07-27 17:50:10.000000000 +0100
++++ b/CMakeLists.txt 2015-08-23 19:03:35.627848083 +0100
+@@ -61,10 +61,5 @@
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/cura)
+ install(DIRECTORY plugins DESTINATION lib/cura)
+ install(FILES cura_app.py DESTINATION ${CMAKE_INSTALL_BINDIR} PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+-if(NOT APPLE AND NOT WIN32)
+- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
+- install(FILES cura.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
+-else()
+- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+-endif()
++install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+