summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-06-08 08:44:58 -0400
committerAdam Goldsmith2015-06-08 08:44:58 -0400
commit41661b035be41e6c6d05ff3bd736701e3b482d85 (patch)
tree8dae9cc234ccadc4bbedb880c6474f0864923cf7
downloadaur-41661b035be41e6c6d05ff3bd736701e3b482d85.tar.gz
migrating to AUR4
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD58
2 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b5823a58187
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = cura-git
+ pkgdesc = A full software solution for 3D printing aimed at RepRaps and the Ultimaker.
+ pkgver = 15.05.90.44.g98befd6
+ pkgrel = 1
+ url = https://github.com/daid/Cura
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = cmake
+ depends = python
+ depends = python-pyqt5
+ depends = python-opengl
+ depends = python-pyserial
+ depends = python-numpy
+ depends = python-power-git
+ depends = python-protobuf3
+ depends = libarcus-git
+ depends = qt5-quickcontrols
+ provides = cura
+ conflicts = cura
+ source = git+https://github.com/Ultimaker/Cura.git
+ source = git+https://github.com/Ultimaker/CuraEngine.git
+ source = git+https://github.com/Ultimaker/Uranium.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+
+pkgname = cura-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..573047f0a304
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=cura-git
+pkgver=15.05.90.44.g98befd6
+pkgrel=1
+pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker."
+arch=('i686' 'x86_64')
+license=('GPL2')
+url="https://github.com/daid/Cura"
+provides=('cura')
+conflicts=('cura')
+depends=('python' 'python-pyqt5' 'python-opengl' 'python-pyserial' 'python-numpy' 'python-power-git' 'python-protobuf3' 'libarcus-git' 'qt5-quickcontrols')
+makedepends=('git' 'cmake')
+source=('git+https://github.com/Ultimaker/Cura.git'
+ 'git+https://github.com/Ultimaker/CuraEngine.git'
+ 'git+https://github.com/Ultimaker/Uranium.git')
+md5sums=('SKIP' 'SKIP' 'SKIP')
+
+_gitname="Cura"
+_gitbranch="master"
+
+pkgver() {
+ cd "$_gitname"
+ git describe --tags | sed 's/-/./g'
+}
+
+build() {
+ mkdir -p CuraEngine/build
+ cd CuraEngine/build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+
+ mkdir -p ../../Uranium/build
+ cd ../../Uranium/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+
+ mkdir -p ../../Cura/build
+ cd ../../Cura/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ make
+}
+
+package() {
+ cd "$srcdir/Uranium/build"
+ make DESTDIR="$pkgdir/" install
+
+ cd "$srcdir/Cura/build"
+ make DESTDIR="$pkgdir/" install
+
+ cd "$srcdir/CuraEngine/build"
+ make DESTDIR="$pkgdir/" install
+
+ chmod +x "$pkgdir/usr/bin/cura_app.py"
+
+ mv "$pkgdir/usr/lib64/" "$pkgdir/usr/lib/"
+}
+