summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-10-16 17:23:39 -0400
committerAdam Goldsmith2015-10-16 17:24:42 -0400
commit605561793c489320e955919d4abeaafb5ca9225a (patch)
treebe77a7ac5ed9105a995ad20df290b052ce69d249
parent7ca4179dd61ef9edfa8dfe52aaf62bda891314b9 (diff)
downloadaur-605561793c489320e955919d4abeaafb5ca9225a.tar.gz
Switch to multiple packages, fix install dir
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
-rw-r--r--site-packages-dir.patch14
3 files changed, 37 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d0d8ac5c140..d8f92c6adf24 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,11 @@
pkgbase = cura-git
pkgdesc = A full software solution for 3D printing aimed at RepRaps and the Ultimaker.
- pkgver = 15.06.03.277.g3cb3cce
+ pkgver = 15.06.03.687.ge7f2c9d
pkgrel = 1
url = https://github.com/daid/Cura
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL3
makedepends = git
makedepends = cmake
depends = python
@@ -13,16 +13,16 @@ pkgbase = cura-git
depends = python-pyserial
depends = python-numpy
depends = python-protobuf3
- depends = libarcus-git
depends = qt5-quickcontrols
+ depends = libarcus-git
+ depends = uranium-git
+ depends = curaengine-git
provides = cura
conflicts = cura
source = git+https://github.com/Ultimaker/Cura.git
- source = git+https://github.com/Ultimaker/CuraEngine.git
- source = git+https://github.com/Ultimaker/Uranium.git
- md5sums = SKIP
- md5sums = SKIP
+ source = site-packages-dir.patch
md5sums = SKIP
+ md5sums = c8e529ea3c817b5ae7ca4f73a2be0335
pkgname = cura-git
diff --git a/PKGBUILD b/PKGBUILD
index 5593cab7656b..118cdff9f880 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,59 +1,42 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
pkgname=cura-git
-pkgver=15.06.03.277.g3cb3cce
+pkgver=15.06.03.687.ge7f2c9d
pkgrel=1
pkgdesc="A full software solution for 3D printing aimed at RepRaps and the Ultimaker."
arch=('i686' 'x86_64')
-license=('GPL2')
+license=('GPL3')
url="https://github.com/daid/Cura"
provides=('cura')
conflicts=('cura')
-depends=('python' 'python-pyqt5' 'python-pyserial' 'python-numpy' 'python-protobuf3' 'libarcus-git' 'qt5-quickcontrols')
+depends=('python' 'python-pyqt5' 'python-pyserial' 'python-numpy' 'python-protobuf3' 'qt5-quickcontrols' 'libarcus-git' 'uranium-git' 'curaengine-git')
makedepends=('git' 'cmake')
-source=('git+https://github.com/Ultimaker/Cura.git'
- 'git+https://github.com/Ultimaker/CuraEngine.git'
- 'git+https://github.com/Ultimaker/Uranium.git')
-md5sums=('SKIP' 'SKIP' 'SKIP')
-
-_gitname="Cura"
-_gitbranch="master"
+source=('git+https://github.com/Ultimaker/Cura.git' 'site-packages-dir.patch')
+md5sums=('SKIP' 'c8e529ea3c817b5ae7ca4f73a2be0335')
pkgver() {
- cd "$_gitname"
+ cd Cura
git describe --tags | sed 's/-/./g'
}
-build() {
- mkdir -p CuraEngine/build
- cd CuraEngine/build
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
- make
-
- mkdir -p ../../Uranium/build
- cd ../../Uranium/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+prepare(){
+ cd Cura
+ patch -Np1 -i ../site-packages-dir.patch
+}
- mkdir -p ../../Cura/build
- cd ../../Cura/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DURANIUM_SCRIPTS_DIR="$srcdir/Uranium/scripts" ..
+build() {
+ mkdir -p Cura/build
+ cd Cura/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DURANIUM_SCRIPTS_DIR=/usr/share/uranium/scripts ..
make
}
package() {
- cd "$srcdir/Uranium/build"
- make DESTDIR="$pkgdir/" install
-
cd "$srcdir/Cura/build"
make DESTDIR="$pkgdir/" install
- cd "$srcdir/CuraEngine/build"
- make DESTDIR="$pkgdir/" install
-
chmod +x "$pkgdir/usr/bin/cura_app.py"
-
- mv "$pkgdir/usr/lib/python3/" "$pkgdir/usr/lib/python3.4/"
- mv "$pkgdir/usr/lib/python3.4/dist-packages/" "$pkgdir/usr/lib/python3.4/site-packages/"
+ ln -s "$pkgdir/usr/bin/cura_app.py" "$pkgdir/usr/bin/cura"
}
+# vim:set ts=2 sw=2 et:
diff --git a/site-packages-dir.patch b/site-packages-dir.patch
new file mode 100644
index 000000000000..9bdb56a796e2
--- /dev/null
+++ b/site-packages-dir.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt 2015-07-27 17:50:10.000000000 +0100
++++ b/CMakeLists.txt 2015-08-23 19:03:35.627848083 +0100
+@@ -61,10 +61,5 @@
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/cura)
+ install(DIRECTORY plugins DESTINATION lib/cura)
+ install(FILES cura_app.py DESTINATION ${CMAKE_INSTALL_BINDIR} PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE)
+-if(NOT APPLE AND NOT WIN32)
+- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages)
+- install(FILES cura.desktop DESTINATION ${CMAKE_INSTALL_DATADIR}/applications)
+-else()
+- install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+-endif()
++install(DIRECTORY cura DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
+