summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2015-08-23 23:31:56 -0400
committerAdam Goldsmith2015-08-23 23:31:56 -0400
commit7bdb8e6b61c692901f2427409d4d117b59de1256 (patch)
tree66d515a62fd8b72ee0ef3c79571059f674ef932c
parent71ed67e8b243de91a86654c02e3c631deab45b83 (diff)
downloadaur-7bdb8e6b61c692901f2427409d4d117b59de1256.tar.gz
replace CMakeLists patch with better fix
-rw-r--r--Cura-CMakeLists.patch11
-rw-r--r--PKGBUILD7
2 files changed, 1 insertions, 17 deletions
diff --git a/Cura-CMakeLists.patch b/Cura-CMakeLists.patch
deleted file mode 100644
index c5ad2afebd1a..000000000000
--- a/Cura-CMakeLists.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- Cura/CMakeLists.txt 2015-06-22 09:16:37.262735692 -0400
-+++ Cura/CmakeLists.txt.new 2015-06-22 09:25:31.044757891 -0400
-@@ -2,7 +2,7 @@
- project(cura)
- cmake_minimum_required(VERSION 2.8.12)
-
--set(URANIUM_SCRIPTS_DIR "${CMAKE_SOURCE_DIR}/../uranium/scripts" CACHE DIRECTORY "The location of the scripts directory of the Uranium repository")
-+set(URANIUM_SCRIPTS_DIR "${CMAKE_SOURCE_DIR}/../Uranium/scripts" CACHE DIRECTORY "The location of the scripts directory of the Uranium repository")
-
- if(NOT ${URANIUM_SCRIPTS_DIR} STREQUAL "")
- # Extract Strings
diff --git a/PKGBUILD b/PKGBUILD
index 5cc789f05358..9d512114dcca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,11 +25,6 @@ pkgver() {
git describe --tags | sed 's/-/./g'
}
-prepare() {
- cd "$srcdir"
- patch -p0 <Cura-CMakeLists.patch
-}
-
build() {
mkdir -p CuraEngine/build
cd CuraEngine/build
@@ -43,7 +38,7 @@ build() {
mkdir -p ../../Cura/build
cd ../../Cura/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DURANIUM_SCRIPTS_DIR="$srcdir/Uranium/scripts" ..
make
}