summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVlad Glagolev2023-02-11 14:06:06 -0800
committerVlad Glagolev2023-02-11 14:06:06 -0800
commitd3c7194c0a3f6b7e63a720165ffe0a661c0d6c85 (patch)
treebcbdfa9b7ba7abea227a5521fbd9dbe7aedea6b4
downloadaur-curie-font.tar.gz
curie-font: initial version of the package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00b6a259fbdb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = curie-font
+ pkgdesc = upscaled version of scientifica font
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/NerdyPepper/curie
+ arch = any
+ license = OFL
+ provides = otb-curie
+ conflicts = curie-otb
+ conflicts = otb-curie
+ source = https://github.com/nerdypepper/curie/releases/download/v1.0/curie-v1.0.tar.gz
+ sha256sums = 07cf4635b3a69b7958fdc456409105bbfe66a2b08cfd6ad141bfe6e9ca2f6edf
+
+pkgname = curie-font
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28b453cc5707
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Vlad Glagolev <scm(at)vaygr(dot)net>
+
+_pkgname='curie'
+pkgname="${_pkgname}-font"
+pkgver='1.0'
+pkgrel=1
+pkgdesc="upscaled version of scientifica font"
+url="https://github.com/NerdyPepper/${_pkgname}"
+license=('OFL')
+source=(
+ "https://github.com/nerdypepper/${_pkgname}/releases/download/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz"
+)
+sha256sums=('07cf4635b3a69b7958fdc456409105bbfe66a2b08cfd6ad141bfe6e9ca2f6edf')
+arch=('any')
+conflicts=(
+ "${_pkgname}-otb"
+ "otb-${_pkgname}"
+)
+provides=(
+ "otb-${_pkgname}"
+)
+package() {
+ # Install the OpenType bitmap fonts
+ install -D --mode=644 "${srcdir}"/*.otb \
+ --target-directory "${pkgdir}/usr/share/fonts/misc"
+ # Install the license
+ install -D --mode=644 "${srcdir}/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}