summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWainer Vandelli2018-11-27 09:31:24 +0100
committerWainer Vandelli2018-11-27 09:31:24 +0100
commit6f6cbb041b6385616164b4ae20f7238de9b3bf9a (patch)
tree1831bca6ad389dc686daee2842f1db1b321da685
parentf49ef3503c087c3339aef0fc14a4d70005256ea0 (diff)
downloadaur-6f6cbb041b6385616164b4ae20f7238de9b3bf9a.tar.gz
Add patch for cURL error code aliases
cURL redefined on error code to alias a second one. This breaks a switch statement due to repeated cases.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
-rw-r--r--curl.patch16
3 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb42a9c62a68..25a97f080f75 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -24,10 +24,12 @@ pkgbase = cvmfs
source = settings.cmake
source = externals.patch
source = sqlite-scratch.patch
+ source = curl.patch
md5sums = 0c240a990d94d8fb1bade350f07de96f
md5sums = 20dc60c61077f4a3711463e8686d260d
md5sums = 3054d07ba4d5f96159a6c2c36244bda8
md5sums = 0ef4c858aa9648dcd46768991748eb06
+ md5sums = 2ec8fe3ee233d0934f288927c7a88e46
pkgname = cvmfs
diff --git a/PKGBUILD b/PKGBUILD
index fce2568fc04b..c85991dfa16c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,13 @@ options=('!emptydirs')
source=("https://ecsft.cern.ch/dist/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
'settings.cmake'
'externals.patch'
- 'sqlite-scratch.patch')
+ 'sqlite-scratch.patch'
+ 'curl.patch')
md5sums=('0c240a990d94d8fb1bade350f07de96f'
'20dc60c61077f4a3711463e8686d260d'
'3054d07ba4d5f96159a6c2c36244bda8'
- '0ef4c858aa9648dcd46768991748eb06')
+ '0ef4c858aa9648dcd46768991748eb06'
+ '2ec8fe3ee233d0934f288927c7a88e46')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -33,6 +35,9 @@ prepare() {
# Sqlite deprecated the SCRATCH configuration option
patch -Np1 -i "$srcdir/sqlite-scratch.patch"
+
+ # Error code aliases in cURL
+ patch -Np1 -i "$srcdir/curl.patch"
}
build() {
diff --git a/curl.patch b/curl.patch
new file mode 100644
index 000000000000..ea7fb3657a16
--- /dev/null
+++ b/curl.patch
@@ -0,0 +1,16 @@
+--- cvmfs-2.5.1.orig/cvmfs/download.cc 2018-11-27 09:18:43.686991595 +0100
++++ cvmfs-2.5.1/cvmfs/download.cc 2018-11-27 09:19:46.637552552 +0100
+@@ -1266,13 +1266,6 @@
+ "X509_CERT_BUNDLE might point to the wrong location.");
+ info->error_code = kFailHostConnection;
+ break;
+- case CURLE_SSL_CACERT:
+- LogCvmfs(kLogDownload, kLogDebug | kLogSyslogErr, "SSL certificate cannot"
+- " be authenticated with known CA certificates. "
+- "X509_CERT_DIR and/or X509_CERT_BUNDLE might point to the wrong "
+- "location.");
+- info->error_code = kFailHostConnection;
+- break;
+ case CURLE_PEER_FAILED_VERIFICATION:
+ LogCvmfs(kLogDownload, kLogDebug | kLogSyslogErr,
+ "invalid SSL certificate of remote host. "