summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWainer Vandelli2018-08-21 14:51:20 +0200
committerWainer Vandelli2018-08-21 14:51:20 +0200
commitf49ef3503c087c3339aef0fc14a4d70005256ea0 (patch)
tree1176a94ab74fbf00a740a01b2b4a8477f0dce627
parent119b66d53d874a0648ca494b61811c9e00f028f9 (diff)
downloadaur-f49ef3503c087c3339aef0fc14a4d70005256ea0.tar.gz
Update to 2.5.1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
-rw-r--r--externals.patch2
-rw-r--r--xattr.patch36
4 files changed, 12 insertions, 55 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48ed1f3751bb..cb42a9c62a68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cvmfs
pkgdesc = A client-server file system implemented in FUSE and developed to deliver software distributions onto virtual machines in a fast, scalable, and reliable way.
- pkgver = 2.5.0
- pkgrel = 2
+ pkgver = 2.5.1
+ pkgrel = 1
url = http://cernvm.cern.ch/portal/filesystem
install = cvmfs.install
arch = x86_64
@@ -20,16 +20,14 @@ pkgbase = cvmfs
depends = protobuf
options = !emptydirs
backup = etc/cvmfs/default.local
- source = https://ecsft.cern.ch/dist/cvmfs/cvmfs-2.5.0/cvmfs-2.5.0.tar.gz
+ source = https://ecsft.cern.ch/dist/cvmfs/cvmfs-2.5.1/cvmfs-2.5.1.tar.gz
source = settings.cmake
source = externals.patch
source = sqlite-scratch.patch
- source = xattr.patch
- md5sums = d46705e06267278fd3a65b277a6d9e16
+ md5sums = 0c240a990d94d8fb1bade350f07de96f
md5sums = 20dc60c61077f4a3711463e8686d260d
- md5sums = 109a95cab95276c1c19bc46b66f0906f
+ md5sums = 3054d07ba4d5f96159a6c2c36244bda8
md5sums = 0ef4c858aa9648dcd46768991748eb06
- md5sums = 08a46f14c08fe50b8d7cd33ec95ddda8
pkgname = cvmfs
diff --git a/PKGBUILD b/PKGBUILD
index 21fc6b48b164..fce2568fc04b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Maintainer: Wainer Vandelli <wainer dot vandelli at gmail dot com>
# Contributor: Konstantin Gizdov < arch at kge dot pw >
pkgname=cvmfs
-pkgver=2.5.0
-pkgrel=2
+pkgver=2.5.1
+pkgrel=1
pkgdesc="A client-server file system implemented in FUSE and developed to deliver software distributions onto virtual machines in a fast, scalable, and reliable way."
arch=('x86_64')
url="http://cernvm.cern.ch/portal/filesystem"
@@ -17,13 +17,11 @@ options=('!emptydirs')
source=("https://ecsft.cern.ch/dist/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
'settings.cmake'
'externals.patch'
- 'sqlite-scratch.patch'
- 'xattr.patch')
-md5sums=('d46705e06267278fd3a65b277a6d9e16'
+ 'sqlite-scratch.patch')
+md5sums=('0c240a990d94d8fb1bade350f07de96f'
'20dc60c61077f4a3711463e8686d260d'
- '109a95cab95276c1c19bc46b66f0906f'
- '0ef4c858aa9648dcd46768991748eb06'
- '08a46f14c08fe50b8d7cd33ec95ddda8')
+ '3054d07ba4d5f96159a6c2c36244bda8'
+ '0ef4c858aa9648dcd46768991748eb06')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
@@ -35,9 +33,6 @@ prepare() {
# Sqlite deprecated the SCRATCH configuration option
patch -Np1 -i "$srcdir/sqlite-scratch.patch"
-
- # Do not use attr/xattr.h as it is not installed in Arch
- patch -Np1 -i "$srcdir/xattr.patch"
}
build() {
diff --git a/externals.patch b/externals.patch
index 0b92b7ae1a7e..cf0b1fe2fe5c 100644
--- a/externals.patch
+++ b/externals.patch
@@ -4,7 +4,7 @@
# # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # # #
# Build a list of libs that need to be built
--missing_libs="libcurl pacparser zlib sparsehash leveldb googletest libgeoip protobuf googlebench sqlite3 vjson sha2 sha3 mongoose libarchive"
+-missing_libs="libcurl pacparser zlib sparsehash leveldb googletest ipaddress maxminddb protobuf googlebench sqlite3 vjson sha2 sha3 mongoose libarchive"
+missing_libs="vjson sha2 sha3"
if [ x"$BUILD_QC_TESTS" != x"" ]; then
missing_libs="$missing_libs rapidcheck"
diff --git a/xattr.patch b/xattr.patch
deleted file mode 100644
index 7d2416072cce..000000000000
--- a/xattr.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Naur cvmfs-2.5.0.orig/CMakeLists.txt cvmfs-2.5.0/CMakeLists.txt
---- cvmfs-2.5.0.orig/CMakeLists.txt 2018-06-27 17:53:00.709949213 +0200
-+++ cvmfs-2.5.0/CMakeLists.txt 2018-06-27 17:53:45.610111417 +0200
-@@ -247,21 +247,6 @@
- sys/wait.h sys/select.h pthread.h termios.h utime.h
- signal.h errno.h dirent.h unistd.h fcntl.h netdb.h
- syslog.h sys/resource.h execinfo.h poll.h pwd.h grp.h)
--if (NOT MACOSX)
-- # Unfortunately, attr/xattr.h fails to compile without including sys/types.h
-- # before including attr/xattr.h (it uses size_t and ssize_t).
-- # CMake searches for include files by compiling a minimal *.c file like:
-- # #include <${SEARCHED_HEADER_FILE}>
-- # int main(int argc, char **argv) { return 0; }
-- #
-- # We pre-define the include guard of attr/xattr.h and thus still check, if the
-- # file is found by the compiler but mitigating the compiler errors caused by
-- # a standalone inclusion of attr/xattr.h
-- set (CMAKE_REQUIRED_DEFINITIONS "-D__XATTR_H__")
-- set (REQUIRED_HEADERS ${REQUIRED_HEADERS}
-- sys/statfs.h
-- attr/xattr.h)
--endif (NOT MACOSX)
-
- look_for_include_files (${REQUIRED_HEADERS})
-
-diff -Naur cvmfs-2.5.0.orig/cvmfs/platform_linux.h cvmfs-2.5.0/cvmfs/platform_linux.h
---- cvmfs-2.5.0.orig/cvmfs/platform_linux.h 2018-06-27 17:53:00.719949251 +0200
-+++ cvmfs-2.5.0/cvmfs/platform_linux.h 2018-06-27 17:53:03.899960637 +0200
-@@ -9,7 +9,6 @@
-
- #include <sys/types.h> // contains ssize_t needed inside <attr/xattr.h>
- #include <sys/xattr.h>
--#include <attr/xattr.h> // NOLINT(build/include_alpha)
- #include <dirent.h>
- #include <errno.h>
- #include <fcntl.h>