summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Rooyakkers2020-05-04 20:08:59 -0400
committerLucas Rooyakkers2020-05-04 20:08:59 -0400
commit0e56dcfee5312409cf5d680c88b3e2677c9fd17e (patch)
treea2e33e12bbdbefd4cbd39de9e151ee8b31c2e9ea
downloadaur-cvodes.tar.gz
Initial Commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36d758bd866f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = cvodes
+ pkgdesc = CVODES is a solver for stiff and nonstiff ODE systems given in explicit form y’ = f(t,y,p) with sensitivity analysis capabilities (both forward and adjoint modes).
+ pkgver = 2.7.0
+ pkgrel = 1
+ url = https://www.gnu.org/software/mcsim/#installation
+ arch = any
+ license = BSD
+ makedepends = gcc
+ provides = cvodes
+ conflicts = sundials
+ source = https://www.gnu.org/software/mcsim/cvodes-2.7.0.tar.gz
+ md5sums = 73d924b697c1b13ec1b5172057bdf6ab
+
+pkgname = cvodes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1c40e16de9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Lucas Rooyakkers <lucas dot rooyakkers at pm dot me>
+
+pkgname='cvodes'
+provides=('cvodes')
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="CVODES is a solver for stiff and nonstiff ODE systems given in explicit form y’ = f(t,y,p) with sensitivity analysis capabilities (both forward and adjoint modes)."
+arch=('any')
+url="https://www.gnu.org/software/mcsim/#installation"
+license=("BSD")
+conflicts=('sundials')
+optdepends=()
+makedepends=('gcc')
+source=("https://www.gnu.org/software/mcsim/${pkgname}-${pkgver}.tar.gz")
+md5sums=('73d924b697c1b13ec1b5172057bdf6ab')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ ./configure --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ make prefix="$pkgdir/usr/" install
+}