summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyechou2023-06-25 14:40:02 -0500
committerkyechou2023-06-25 14:40:02 -0500
commita864446c31dda6a338039406a66a73c40d538994 (patch)
tree1dda60d4f5054e89c281ceeba5abee4c6e34dfc2
parent1fef41b60085c4188b06e5776a8edf94f5fe5065 (diff)
downloadaur-cxx-common.tar.gz
Update to 0.4.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4168048bb9e2..7338f2572eea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cxx-common
pkgdesc = Common dependency management for various Trail of Bits C++ codebases
- pkgver = 0.1.8
- pkgrel = 3
+ pkgver = 0.4.1
+ pkgrel = 1
url = https://github.com/lifting-bits/cxx-common
arch = x86_64
license = Apache
@@ -13,8 +13,7 @@ pkgbase = cxx-common
makedepends = python
makedepends = python-setuptools
options = staticlibs
- options = !strip
- source = https://github.com/lifting-bits/cxx-common/archive/refs/tags/v0.1.8.tar.gz
- sha256sums = c3b7825739ea353460b969ed6fc5502eaf882bf11a9a9d881c8b7bbd49e4f1de
+ source = https://github.com/lifting-bits/cxx-common/archive/refs/tags/v0.4.1.tar.gz
+ sha256sums = 922b92b1fc99e16e4828b2e2463dec5605d131b152de138b5f1990e21bdeee0b
pkgname = cxx-common
diff --git a/PKGBUILD b/PKGBUILD
index f464da1d0f4a..8ae1b64228be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Kuan-Yen Chou <kuanyenchou at gmail dot com>
pkgname=cxx-common
-pkgver=0.1.8
-pkgrel=3
+pkgver=0.4.1
+pkgrel=1
pkgdesc="Common dependency management for various Trail of Bits C++ codebases"
arch=('x86_64')
url="https://github.com/lifting-bits/cxx-common"
@@ -10,18 +10,18 @@ license=('Apache')
depends=()
makedepends=('clang' 'lld' 'cmake' 'ninja' 'git' 'python' 'python-setuptools')
checkdepends=()
-options=('staticlibs' '!strip')
+options=('staticlibs')
source=("https://github.com/lifting-bits/cxx-common/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('c3b7825739ea353460b969ed6fc5502eaf882bf11a9a9d881c8b7bbd49e4f1de')
+sha256sums=('922b92b1fc99e16e4828b2e2463dec5605d131b152de138b5f1990e21bdeee0b')
package() {
- export LLVM_VER=12
+ export LLVM_VER=15
export TRIPLET=x64-linux-rel
export VCPKG_DEFAULT_HOST_TRIPLET=$TRIPLET # https://github.com/lifting-bits/cxx-common/pull/876
cd "$srcdir/$pkgname-$pkgver"
mkdir -p "$pkgdir/opt/$pkgname"
- ./build_dependencies.sh --release --clean \
+ ./build_dependencies.sh --release \
--export-dir "$pkgdir/opt/$pkgname" \
llvm-$LLVM_VER