summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2022-01-29 00:30:49 +0100
committerAlphaJack2022-01-29 00:30:49 +0100
commit891ce12a19df173af6f0491c98c33eabd00e99b3 (patch)
tree44ccd5326163d2844814fc4ba2692397692e8f6b
downloadaur-891ce12a19df173af6f0491c98c33eabd00e99b3.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d47c5b078d86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = cyberchef-web
+ pkgdesc = The Cyber Swiss Army Knife - a web app for encryption, encoding, compression and data analysis
+ pkgver = 9.32.3
+ pkgrel = 1
+ url = https://gchq.github.io/CyberChef/
+ arch = any
+ license = Apache 2.0
+ makedepends = unzip
+ conflicts = cyberchef-html
+ replaces = cyberchef-html
+ noextract = cyberchef-web-9.32.3.zip
+ options = !strip
+ source = cyberchef-web-9.32.3.zip::https://github.com/gchq/CyberChef/releases/download/v9.32.3/CyberChef_v9.32.3.zip
+ sha256sums = 465cf64bdd80cf99be72bedc9dccf7fcebaeace58d77ec62d71733c3e2ba404f
+
+pkgname = cyberchef-web
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7311c8ecb619
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+
+pkgname="cyberchef-web"
+pkgver=9.32.3
+pkgrel=1
+pkgdesc="The Cyber Swiss Army Knife - a web app for encryption, encoding, compression and data analysis"
+url="https://gchq.github.io/CyberChef/"
+license=("Apache 2.0")
+arch=("any")
+conflicts=("cyberchef-html")
+replaces=("cyberchef-html")
+makedepends=("unzip")
+source=("$pkgname-$pkgver.zip::https://github.com/gchq/CyberChef/releases/download/v$pkgver/CyberChef_v$pkgver.zip")
+noextract=("$pkgname-$pkgver.zip")
+sha256sums=('465cf64bdd80cf99be72bedc9dccf7fcebaeace58d77ec62d71733c3e2ba404f')
+options=("!strip")
+
+package(){
+ install -d "$pkgdir/usr/share/webapps"
+ unzip -q -o "$pkgname-$pkgver.zip" -d "$pkgdir/usr/share/webapps/cyberchef"
+ mv "$pkgdir/usr/share/webapps/cyberchef/CyberChef_v$pkgver.html" "$pkgdir/usr/share/webapps/cyberchef/index.html"
+}
+