summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbgh2024-02-23 20:30:19 +1100
committerbgh2024-02-23 20:30:19 +1100
commit91d8857139ae446622a2dff27fc13dd9d1a1e8be (patch)
tree75aedf0e0dc2f91acdbee14c6be0b869fded6149
parent82f6ca49864df1ff6312de2001bf5181cbafc4cc (diff)
downloadaur-91d8857139ae446622a2dff27fc13dd9d1a1e8be.tar.gz
Add bsdtar option to have archive subfolders extract (in fakeroot) as 755 permissions per previous unzip behaviour
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae7357ef68d5..9fe6a8691e2a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cyberchef-web
pkgdesc = The Cyber Swiss Army Knife - a web app for encryption, encoding, compression and data analysis
pkgver = 10.8.2
- pkgrel = 1
+ pkgrel = 2
url = https://gchq.github.io/CyberChef/
arch = any
license = Apache-2.0
diff --git a/PKGBUILD b/PKGBUILD
index 22f82de923b7..8ee5800f08cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="cyberchef-web"
pkgver=10.8.2
-pkgrel=1
+pkgrel=2
pkgdesc="The Cyber Swiss Army Knife - a web app for encryption, encoding, compression and data analysis"
url="https://gchq.github.io/CyberChef/"
license=("Apache-2.0")
@@ -19,7 +19,7 @@ options=("!strip")
package(){
install -d "$pkgdir/usr/share/webapps/cyberchef"
install -d "$pkgdir/usr/share/licenses/cyberchef"
- bsdtar --extract --file "$pkgname-$pkgver.zip" --directory "$pkgdir/usr/share/webapps/cyberchef"
+ bsdtar --extract --file "$pkgname-$pkgver.zip" --directory "$pkgdir/usr/share/webapps/cyberchef" --no-same-permissions
mv "$pkgdir/usr/share/webapps/cyberchef/CyberChef_v$pkgver.html" "$pkgdir/usr/share/webapps/cyberchef/index.html"
find "$pkgdir/usr/share/webapps/cyberchef/" -type f -name "*LICENSE*" -exec mv {} "$pkgdir/usr/share/licenses/cyberchef" \;
}