summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Pompili2024-04-07 19:38:43 +0200
committerMarco Pompili2024-04-07 19:38:43 +0200
commit0a6562c21ea6a6e44fa1ebf29727fc5c8cc01694 (patch)
tree0254ef0894f9eeaacf7be36e35cac0fc36dcc1c6
parent6db8a1e1d98cfb07e0fa0ed608fb938f0cc4b860 (diff)
downloadaur-daphne-git.tar.gz
fixed repo url
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
-rwxr-xr-xdaphne.sh3
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd65a154eee4..e0f6cce6dac3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Feb 16 00:39:49 UTC 2019
pkgbase = daphne-git
pkgdesc = A command-line multiple arcade laserdisc emulator. GIT fork
- pkgver = 100.0e76a0d
+ pkgver = 134.3675284
pkgrel = 1
url = http://www.daphne-emu.com/
arch = i686
@@ -16,7 +14,7 @@ pkgbase = daphne-git
depends = libxmu
provides = daphne
conflicts = daphne
- source = git://github.com/DavidGriffith/daphne.git
+ source = git+http://github.com/DavidGriffith/daphne.git
source = daphne.sh
source = singe.sh
sha256sums = SKIP
@@ -24,4 +22,3 @@ pkgbase = daphne-git
sha256sums = SKIP
pkgname = daphne-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3a834be5a45e..71c84756b04b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
-# Contributor: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
-# Maintainer: Marco Pompili (emarcs) <marcs.pompili@gmail.com>
+# Maintainer: Marco Pompili [marcs (dot) pompili (at) gmail (dot) com]
pkgname=daphne-git
_pkgname=daphne
-pkgver=100.0e76a0d
+pkgver=134.3675284
pkgrel=1
pkgdesc="A command-line multiple arcade laserdisc emulator. GIT fork"
url="http://www.daphne-emu.com/"
@@ -13,7 +12,7 @@ depends=('glew' 'sdl_mixer' 'zlib' 'gcc-libs' 'libxmu')
makedepends=('git')
provides=('daphne')
conflicts=('daphne')
-source=('git://github.com/DavidGriffith/daphne.git' 'daphne.sh' 'singe.sh')
+source=('git+http://github.com/DavidGriffith/daphne.git' 'daphne.sh' 'singe.sh')
sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver()
@@ -36,14 +35,18 @@ build()
package()
{
- # Install everything in /usr/share
cd ${srcdir}/${_pkgname}
+
+ # Install everything in /usr/share
install -Dm755 ${srcdir}/daphne.sh ${pkgdir}/usr/bin/daphne
install -Dm755 ${srcdir}/singe.sh ${pkgdir}/usr/bin/singe
+
install -Dm755 ${_pkgname}.bin ${pkgdir}/usr/share/${_pkgname}/${_pkgname}
install -d ${pkgdir}/usr/share/${_pkgname}/{pics,pics/obsolete,roms/cputest,sound}
+
install -m644 pics/*.* ${pkgdir}/usr/share/${_pkgname}/pics/
install -m644 pics/obsolete/*.* ${pkgdir}/usr/share/${_pkgname}/pics/obsolete/
+
install -m644 roms/cputest/* ${pkgdir}/usr/share/${_pkgname}/roms/cputest/
install -m644 sound/* ${pkgdir}/usr/share/${_pkgname}/sound/
}
diff --git a/daphne.sh b/daphne.sh
index dd8eb24aba82..b87ebaae37c4 100755
--- a/daphne.sh
+++ b/daphne.sh
@@ -13,8 +13,7 @@ cd "$SCRIPT_DIR"
export LD_LIBRARY_PATH=$SCRIPT_DIR:$DAPHNE_SHARE:$LD_LIBRARY_PATH
if [ -z $1 ] ; then
- echo "Specify a game to try: ace astron badlands bega cliff cobra esh"
- echo "\tgalaxyr gpworld interstellar lair lair2 mach3 rb sdq tq uvt"
+ echo "Specify a game to try: ace astron badlands bega cliff cobra esh tgalaxyr gpworld interstellar lair lair2 mach3 rb sdq tq uvt"
exit
fi