summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Abreu2022-07-04 20:55:45 -0400
committerAriel Abreu2022-07-04 20:55:45 -0400
commit8053157d5c2a30a73c802000097c9e347a4c9a1c (patch)
tree2b0e0218d547339f8e121abbd8a678ac0a54f5f5
parentb9b5097520977f6a114b7da8639772e51909741d (diff)
downloadaur-8053157d5c2a30a73c802000097c9e347a4c9a1c.tar.gz
Update for darlingserver
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD61
-rw-r--r--dkms.conf9
3 files changed, 25 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a9e96f7694e..0de2ce213e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = darling-git
pkgdesc = Darwin/macOS emulation layer for Linux
- pkgver = r3717.26e55e111
+ pkgver = r3848.b75c25e2c
pkgrel = 1
- url = http://www.darlinghq.org
+ url = https://www.darlinghq.org
arch = x86_64
groups = darling-git
license = GPL3
@@ -19,7 +19,6 @@ pkgbase = darling-git
makedepends = glu
makedepends = libbsd
makedepends = python2
- makedepends = linux-headers
makedepends = ffmpeg
makedepends = git-lfs
depends = xz
@@ -41,8 +40,9 @@ pkgbase = darling-git
depends = gawk
depends = libunwind
depends = ffmpeg
+ provides = darling
+ conflicts = darling
options = !buildflags
- source = dkms.conf
source = darling-libressl-2.2.9::git+https://github.com/darlinghq/darling-libressl.git#branch=v2.2.9
source = darling-libressl-2.5.5::git+https://github.com/darlinghq/darling-libressl.git#branch=v2.5.5
source = darling-libressl-2.6.5::git+https://github.com/darlinghq/darling-libressl.git#branch=v2.6.5
@@ -112,6 +112,7 @@ pkgbase = darling-git
source = git+https://github.com/darlinghq/darling-libcxx.git
source = git+https://github.com/darlinghq/darling-libdispatch.git
source = git+https://github.com/darlinghq/darling-libffi.git
+ source = git+https://github.com/darlinghq/darling-libkqueue.git
source = git+https://github.com/darlinghq/darling-liblzma.git
source = git+https://github.com/darlinghq/darling-libmalloc.git
source = git+https://github.com/darlinghq/darling-libnetwork.git
@@ -156,6 +157,7 @@ pkgbase = darling-git
source = git+https://github.com/darlinghq/darling-screen.git
source = git+https://github.com/darlinghq/darling-security.git
source = git+https://github.com/darlinghq/darling-SecurityTokend.git
+ source = git+https://github.com/darlinghq/darlingserver.git
source = git+https://github.com/darlinghq/darling-shell_cmds.git
source = git+https://github.com/darlinghq/darling-SmartCardServices.git
source = git+https://github.com/darlinghq/darling-sqlite.git
@@ -176,7 +178,8 @@ pkgbase = darling-git
source = git+https://github.com/darlinghq/fmdb.git
source = git+https://github.com/darlinghq/lzfse.git
source = git+https://github.com/darlinghq/xcbuild.git
- md5sums = d6d3b392245a45c6fb5f82037bfdbd19
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
@@ -312,15 +315,3 @@ pkgbase = darling-git
md5sums = SKIP
pkgname = darling-git
- depends = darling-mach-dkms-git
- provides = darling
- conflicts = darling
-
-pkgname = darling-mach-dkms-git
- depends = dkms
- optdepends = linux-headers: build modules against the Arch kernel
- optdepends = linux-lts-headers: build modules against the LTS kernel
- optdepends = linux-zen-headers: build modules against the ZEN kernel
- optdepends = linux-grsec-headers: build modules against the GRSEC kernel
- provides = darling-mach-dkms
- conflicts = darling-mach-dkms
diff --git a/PKGBUILD b/PKGBUILD
index 55cac9d34f8f..404a29b901b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,24 @@
_gitname=darling
pkgbase=$_gitname-git
-pkgname=('darling-git' 'darling-mach-dkms-git')
-pkgver=r3717.26e55e111
+pkgname='darling-git'
+pkgver=r3848.b75c25e2c
pkgrel=1
pkgdesc="Darwin/macOS emulation layer for Linux"
arch=('x86_64')
-url="http://www.darlinghq.org"
+url="https://www.darlinghq.org"
license=('GPL3')
groups=('darling-git')
depends=('xz' 'fuse' 'libxml2' 'icu' 'openssl' 'bzip2' 'zlib' 'libsystemd'
'wget' 'curl' 'sqlite' 'ruby' 'sed' 'libarchive' 'file' 'python' 'gawk' 'libunwind' 'ffmpeg')
_depends_x86_64=('lib32-clang' 'lib32-bzip2' 'lib32-systemd' 'lib32-libxslt' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2')
-makedepends=('git' 'cmake' 'clang' 'dkms' 'bison' 'flex' 'binutils>=2.28' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2' 'linux-headers' 'ffmpeg' 'git-lfs')
+makedepends=('git' 'cmake' 'clang' 'dkms' 'bison' 'flex' 'binutils>=2.28' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2' 'ffmpeg' 'git-lfs')
_make_depends_x86_64=('gcc-multilib')
+conflicts=('darling')
+provides=('darling')
# Darling git repo and all submodules.
-source=('dkms.conf'
- 'darling-libressl-2.2.9'::'git+https://github.com/darlinghq/darling-libressl.git#branch=v2.2.9'
+source=('darling-libressl-2.2.9'::'git+https://github.com/darlinghq/darling-libressl.git#branch=v2.2.9'
'darling-libressl-2.5.5'::'git+https://github.com/darlinghq/darling-libressl.git#branch=v2.5.5'
'darling-libressl-2.6.5'::'git+https://github.com/darlinghq/darling-libressl.git#branch=v2.6.5'
'darling-libressl-2.8.3'::'git+https://github.com/darlinghq/darling-libressl.git#branch=v2.8.3'
@@ -89,6 +90,7 @@ source=('dkms.conf'
'git+https://github.com/darlinghq/darling-libcxx.git'
'git+https://github.com/darlinghq/darling-libdispatch.git'
'git+https://github.com/darlinghq/darling-libffi.git'
+ 'git+https://github.com/darlinghq/darling-libkqueue.git'
'git+https://github.com/darlinghq/darling-liblzma.git'
'git+https://github.com/darlinghq/darling-libmalloc.git'
'git+https://github.com/darlinghq/darling-libnetwork.git'
@@ -133,6 +135,7 @@ source=('dkms.conf'
'git+https://github.com/darlinghq/darling-screen.git'
'git+https://github.com/darlinghq/darling-security.git'
'git+https://github.com/darlinghq/darling-SecurityTokend.git'
+ 'git+https://github.com/darlinghq/darlingserver.git'
'git+https://github.com/darlinghq/darling-shell_cmds.git'
'git+https://github.com/darlinghq/darling-SmartCardServices.git'
'git+https://github.com/darlinghq/darling-sqlite.git'
@@ -155,7 +158,7 @@ source=('dkms.conf'
'git+https://github.com/darlinghq/xcbuild.git')
# We skip md5 on all git repos
-md5sums=('d6d3b392245a45c6fb5f82037bfdbd19'
+md5sums=( 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
@@ -168,8 +171,7 @@ md5sums=('d6d3b392245a45c6fb5f82037bfdbd19'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP')
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
options=('!buildflags')
pkgver() {
@@ -211,6 +213,7 @@ prepare() {
git config submodule.src/external/cups.url "$srcdir/darling-cups"
git config submodule.src/external/curl.url "$srcdir/darling-curl"
git config submodule.src/external/darling-dmg.url "$srcdir/darling-dmg"
+ git config submodule.src/external/darlingserver.url "$srcdir/darlingserver"
git config submodule.src/external/dbuskit.url "$srcdir/darling-dbuskit"
git config submodule.src/external/DirectoryService.url "$srcdir/darling-DirectoryService"
git config submodule.src/external/doc_cmds.url "$srcdir/darling-doc_cmds"
@@ -242,12 +245,13 @@ prepare() {
git config submodule.src/external/less.url "$srcdir/darling-less"
git config submodule.src/external/libarchive.url "$srcdir/darling-libarchive"
git config submodule.src/external/libauto.url "$srcdir/darling-libauto"
- git config submodule.src/external/libc.url "$srcdir/darling-Libc"
git config submodule.src/external/libclosure.url "$srcdir/darling-libclosure"
+ git config submodule.src/external/libc.url "$srcdir/darling-Libc"
git config submodule.src/external/libcxxabi.url "$srcdir/darling-libcxxabi"
git config submodule.src/external/libcxx.url "$srcdir/darling-libcxx"
git config submodule.src/external/libdispatch.url "$srcdir/darling-libdispatch"
git config submodule.src/external/libffi.url "$srcdir/darling-libffi"
+ git config submodule.src/external/libkqueue.url "$srcdir/darling-libkqueue"
git config submodule.src/external/liblzma.url "$srcdir/darling-liblzma"
git config submodule.src/external/libmalloc.url "$srcdir/darling-libmalloc"
git config submodule.src/external/libnetwork.url "$srcdir/darling-libnetwork"
@@ -319,6 +323,7 @@ prepare() {
git submodule update
echo "Updating recursive submodules"
+
cd "$srcdir/$_gitname/src/external/openpam/"
git submodule init
git config submodule.pam_modules.url "$srcdir/darling-pam_modules"
@@ -342,42 +347,10 @@ build() {
cmake .. -DCMAKE_INSTALL_PREFIX=/usr
echo "Running make."
- make
-
- echo "Run 'make lkm_generate'..."
- make lkm_generate
+ make
}
-package_darling-git() {
- depends=('darling-mach-dkms-git')
- conflicts=('darling')
- provides=('darling')
-
+package() {
cd "$srcdir/$_gitname/build"
make DESTDIR="$pkgdir" install
}
-
-package_darling-mach-dkms-git() {
- depends=('dkms')
- conflicts=('darling-mach-dkms')
- provides=('darling-mach-dkms')
- optdepends=('linux-headers: build modules against the Arch kernel'
- 'linux-lts-headers: build modules against the LTS kernel'
- 'linux-zen-headers: build modules against the ZEN kernel'
- 'linux-grsec-headers: build modules against the GRSEC kernel')
- _srcdest="$pkgdir/usr/src/darling-mach-$pkgver"
- _srcinstalldest="/usr/src/darling-mach-$pkgver"
-
- echo "Install module sources for DKMS."
- install -dm755 $(dirname "$_srcdest")
- cp -r "$srcdir/$_gitname/src/external/lkm" "$_srcdest"
- cp -r "$srcdir/$_gitname/build/src/external/lkm" "$_srcdest/migdir"
-
- # Copy missing header rtsig.h
- cp "$srcdir/$_gitname/build/src/startup/rtsig.h" "$_srcdest/include"
-
- echo "Set configuration for DKMS..."
- install -Dm644 "$srcdir/dkms.conf" "$_srcdest"
- sed -i "s|@PKGVER@|$pkgver|g" "$_srcdest/dkms.conf"
- sed -i "s|@SRCDEST@|$_srcinstalldest|g" "$_srcdest/dkms.conf"
-}
diff --git a/dkms.conf b/dkms.conf
deleted file mode 100644
index e1c442d84e31..000000000000
--- a/dkms.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-## @file
-PACKAGE_NAME="darling-mach-dkms-git"
-PACKAGE_VERSION="@PKGVER@"
-AUTOINSTALL="yes"
-MAKE="CPATH=@SRCDEST@/include MIGDIR=@SRCDEST@/migdir MIGDIR_REL=migdir make"
-CLEAN="CPATH=@SRCDEST@/include MIGDIR=@SRCDEST@/migdir MIGDIR_REL=migdir make clean"
-
-BUILT_MODULE_NAME[0]="darling-mach"
-DEST_MODULE_LOCATION[0]="/kernel/misc"