summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAriel Abreu2023-04-15 15:04:02 -0400
committerAriel Abreu2023-04-15 15:04:02 -0400
commit9950d59b4dce0f843f3cd74bc47573e94a5eadbd (patch)
tree74816011eccba087dbf5b4ecc818aaad1e21f583
parent1a356d5a12adc88a258614d63b60725c41812270 (diff)
downloadaur-9950d59b4dce0f843f3cd74bc47573e94a5eadbd.tar.gz
Update with new dependencies
Also, add a missing recursive submodule (Indium)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd73037e3309..eb7948bb7296 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = darling-git
pkgdesc = Darwin/macOS emulation layer for Linux
- pkgver = r4005.84a6ae50d
+ pkgver = r4007.39b0f38c2
pkgrel = 1
url = https://www.darlinghq.org
arch = x86_64
@@ -20,6 +20,11 @@ pkgbase = darling-git
makedepends = python2
makedepends = ffmpeg
makedepends = git-lfs
+ makedepends = llvm
+ makedepends = vulkan-headers
+ makedepends = libxrandr
+ makedepends = libxkbcommon
+ makedepends = libxkbfile
depends = xz
depends = fuse
depends = libxml2
@@ -39,6 +44,15 @@ pkgbase = darling-git
depends = gawk
depends = libunwind
depends = ffmpeg
+ depends = libpng
+ depends = cairo
+ depends = libtiff
+ depends = glu
+ depends = libbsd
+ depends = libxrandr
+ depends = libxkbcommon
+ depends = lib32-gcc-libs
+ depends = libxkbfile
provides = darling
conflicts = darling
options = !buildflags
@@ -193,6 +207,7 @@ pkgbase = darling-git
source = git+https://github.com/darlinghq/darling.git
source = git+https://github.com/darlinghq/darlingserver.git
source = git+https://github.com/darlinghq/fmdb.git
+ source = git+https://github.com/darlinghq/indium.git
source = git+https://github.com/darlinghq/lzfse.git
source = git+https://github.com/darlinghq/xcbuild.git
md5sums = SKIP
@@ -348,5 +363,6 @@ pkgbase = darling-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
+ md5sums = SKIP
pkgname = darling-git
diff --git a/PKGBUILD b/PKGBUILD
index b9075d1b115d..5d7af17a4302 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_gitname=darling
pkgbase=$_gitname-git
pkgname='darling-git'
-pkgver=r4005.84a6ae50d
+pkgver=r4007.39b0f38c2
pkgrel=1
pkgdesc="Darwin/macOS emulation layer for Linux"
arch=('x86_64')
@@ -13,10 +13,12 @@ url="https://www.darlinghq.org"
license=('GPL3')
groups=('darling-git')
depends=('xz' 'fuse' 'libxml2' 'icu' 'openssl' 'bzip2' 'zlib' 'libsystemd'
- 'wget' 'curl' 'sqlite' 'ruby' 'sed' 'libarchive' 'file' 'python' 'gawk' 'libunwind' 'ffmpeg')
-_depends_x86_64=('lib32-clang' 'lib32-bzip2' 'lib32-systemd' 'lib32-libxslt' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2')
-makedepends=('git' 'cmake' 'clang' 'bison' 'flex' 'binutils>=2.28' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2' 'ffmpeg' 'git-lfs')
-_make_depends_x86_64=('gcc-multilib')
+ 'wget' 'curl' 'sqlite' 'ruby' 'sed' 'libarchive' 'file' 'python' 'gawk' 'libunwind' 'ffmpeg'
+ 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'libxrandr' 'libxkbcommon' 'lib32-gcc-libs' 'libxkbfile')
+_depends_x86_64=('lib32-clang' 'lib32-bzip2' 'lib32-systemd' 'lib32-libxslt')
+makedepends=('git' 'cmake' 'clang' 'bison' 'flex' 'binutils>=2.28' 'libpng' 'cairo' 'libtiff' 'glu' 'libbsd' 'python2' 'ffmpeg' 'git-lfs' 'llvm' 'vulkan-headers'
+ 'libxrandr' 'libxkbcommon' 'libxkbfile')
+_make_depends_x86_64=('gcc-multilib' 'lib32-gcc-libs')
conflicts=('darling')
provides=('darling')
@@ -172,6 +174,7 @@ source=('darling-libressl-2.2.9'::'git+https://github.com/darlinghq/darling-libr
'git+https://github.com/darlinghq/darling.git'
'git+https://github.com/darlinghq/darlingserver.git'
'git+https://github.com/darlinghq/fmdb.git'
+ 'git+https://github.com/darlinghq/indium.git'
'git+https://github.com/darlinghq/lzfse.git'
'git+https://github.com/darlinghq/xcbuild.git')
@@ -191,7 +194,7 @@ md5sums=( 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
- 'SKIP' 'SKIP' 'SKIP')
+ 'SKIP' 'SKIP' 'SKIP' 'SKIP')
options=('!buildflags')
pkgver() {
@@ -373,6 +376,11 @@ prepare() {
git config submodule.IOHIDFamily.url "$srcdir/darling-IOHIDFamily"
git -c protocol.file.allow=always submodule update
+ cd "$srcdir/$_gitname/src/external/metal"
+ git submodule init
+ git config submodule.deps/indium.url "$srcdir/indium"
+ git -c protocol.file.allow=always submodule update
+
echo "Updating LFS files"
cd "$srcdir/$_gitname/src/external/swift"
git lfs pull