summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Brink2019-06-02 13:03:33 -0700
committerJames Brink2019-06-02 13:03:33 -0700
commitec0b3cd906960863a8f298b47b06daca8e031228 (patch)
treec707e72f12dd934dfbf0e630749770745e0669b9
parent32d5c711952638cf77094fe074ef3ef163694029 (diff)
downloadaur-ec0b3cd906960863a8f298b47b06daca8e031228.tar.gz
Remove un-needed patch file
Upstream has been patched for Linux >= 5.1, there is no need for the linux-5.1.patch file anymore. See https://github.com/darlinghq/darling-newlkm/pull/6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
-rw-r--r--linux-5.1.patch27
3 files changed, 5 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bf429edd194..436e5f673051 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = darling-git
pkgdesc = Darwin/macOS emulation layer for Linux
- pkgver = r2543.567a5a27
- pkgrel = 2
+ pkgver = r2545.8df457b0
+ pkgrel = 1
url = http://www.darlinghq.org
arch = x86_64
groups = darling-git
@@ -40,7 +40,6 @@ pkgbase = darling-git
depends = libunwind
options = !buildflags
source = dkms.conf
- source = linux-5.1.patch
source = git+https://github.com/darlinghq/darling.git
source = git+https://github.com/darlinghq/darling-DSTools.git
source = git+https://github.com/darlinghq/darling-DirectoryService.git
@@ -139,7 +138,6 @@ pkgbase = darling-git
source = git+https://github.com/darlinghq/darling-zsh.git
source = git+https://github.com/darlinghq/darling-newlkm.git
md5sums = d6d3b392245a45c6fb5f82037bfdbd19
- md5sums = 44d85fe17105c7ede4d334f05cf3e77e
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 10af0e52b588..1ca643675d9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
_gitname=darling
pkgbase=$_gitname-git
pkgname=('darling-git' 'darling-mach-dkms-git')
-pkgver=r2543.567a5a27
-pkgrel=2
+pkgver=r2545.8df457b0
+pkgrel=1
pkgdesc="Darwin/macOS emulation layer for Linux"
arch=('x86_64')
url="http://www.darlinghq.org"
@@ -19,7 +19,6 @@ _make_depends_x86_64=('gcc-multilib')
# Darling git repo and all submodules.
source=('dkms.conf'
- 'linux-5.1.patch'
'git+https://github.com/darlinghq/darling.git'
'git+https://github.com/darlinghq/darling-DSTools.git'
'git+https://github.com/darlinghq/darling-DirectoryService.git'
@@ -119,7 +118,7 @@ source=('dkms.conf'
'git+https://github.com/darlinghq/darling-newlkm.git')
# We skip md5 on all git repos
-md5sums=('d6d3b392245a45c6fb5f82037bfdbd19' '44d85fe17105c7ede4d334f05cf3e77e'
+md5sums=('d6d3b392245a45c6fb5f82037bfdbd19'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP'
@@ -247,10 +246,6 @@ prepare() {
echo "Creating build directory."
mkdir -pv "build"
-
- echo "Patching LKM for linux 5.1"
- cd "$srcdir/darling/src/lkm"
- patch -p1 < "$srcdir"/linux-5.1.patch
}
build() {
diff --git a/linux-5.1.patch b/linux-5.1.patch
deleted file mode 100644
index a6c9ffb33140..000000000000
--- a/linux-5.1.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff --git a/darling/binfmt.c b/darling/binfmt.c
-index 4945e87..7b0b886 100644
---- a/darling/binfmt.c
-+++ b/darling/binfmt.c
-@@ -31,6 +31,7 @@
- #endif
-
- #include <linux/mm.h>
-+#include <linux/mman.h>
- #include <linux/slab.h>
- #include <linux/fs.h>
- #include <linux/file.h>
-diff --git a/darling/traps.c b/darling/traps.c
-index be0aecb..732211f 100644
---- a/darling/traps.c
-+++ b/darling/traps.c
-@@ -384,7 +384,9 @@ static void darling_ipc_inherit(task_t old_task, task_t new_task)
- }
-
- // No vma from 4.11
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(5, 1, 0)
-+static vm_fault_t mach_mmap_fault(struct vm_fault *vmf)
-+#elif LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
- static int mach_mmap_fault(struct vm_fault *vmf)
- #else
- static int mach_mmap_fault(struct vm_area_struct *vma, struct vm_fault *vmf)