summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorL.G. Sarmiento2018-10-11 16:59:22 +0200
committerL.G. Sarmiento2018-10-11 16:59:22 +0200
commit340626731e508f2bfd7b3b91f28631e6e720cee9 (patch)
tree7affffb5440c6592213ebcd735ea7080bb97d848
parent56d9e0822ebe949b2dd049f422d77779b8d24303 (diff)
downloadaur-david.tar.gz
fixed ISO C++ forbids comparison between pointer and integer
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD51
2 files changed, 35 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 93f77a6936e3..2ae1b7ae6268 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Oct 8 15:15:44 UTC 2018
+# Thu Oct 11 14:58:35 UTC 2018
pkgbase = david
pkgdesc = DAwn's Visual Intersection Debugger
pkgver = 1.36a
diff --git a/PKGBUILD b/PKGBUILD
index 2a2349d721aa..706dd6dc1c84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,27 +16,44 @@ source=("http://geant4.kek.jp/~tanaka/src/${pkgname}_${_pkgver}.taz"
sha256sums=('61c77a7290a602e97f6664fbc613e3fb834cb87c525b0bc6dc5b1ea060f733ab'
'93ef37f00e7a6a4b43a377e48b69bb600ac26e667ab3c8af3d8eaf7a2afc284e')
+prepare() {
+ cd "${srcdir}/${pkgname}_${_pkgver}"
+ patch -Np2 < ${srcdir}/make_DESTDIR.patch
+
+ msg "Fixing: 'error: ISO C++ forbids comparison between pointer and integer'"
+ sed -i "s/'\\\0'/NULL/g" FRString.h
+}
+
build() {
cd "${srcdir}/${pkgname}_${_pkgver}"
make
}
package() {
- cd "${srcdir}/${pkgname}_${_pkgver}"
- patch -Np2 < ${srcdir}/make_DESTDIR.patch
- [ -d $pkgdir/usr/bin/ ] || install -d $pkgdir/usr/bin/
- make DESTDIR="${pkgdir}" install
-
- echo "
- [Desktop Entry]
- Name=${_PKGNAME}
- Comment=${pkgdesc}
- Exec=${pkgname}
- Icon=xchm-32
- Terminal=false
- Type=Application
- Categories=Utility;Science;
- StartupNotify=false
- " > $srcdir/$pkgname.desktop
- install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ cd "${srcdir}/${pkgname}_${_pkgver}"
+ [ -d $pkgdir/usr/bin/ ] || install -d $pkgdir/usr/bin/
+ make DESTDIR="${pkgdir}" install
+
+ echo "
+ [Desktop Entry]
+ Name=${_PKGNAME}
+ Comment=${pkgdesc}
+ Exec=${pkgname}
+ Icon=xchm-32
+ Terminal=false
+ Type=Application
+ Categories=Utility;Science;
+ StartupNotify=false
+ " > $srcdir/$pkgname.desktop
+ install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
}
+
+#FRString.h:140:30: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
+# while( isspace(*p) && p != '\0' ) {p++;}
+# ^~~~
+#FRString.h:143:30: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
+# while( !isspace(*p) && p != '\0' ) {p++;}
+# ^~~~
+#FRString.h:146:30: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
+# while( isspace(*p) && p != '\0' ) {p++;}
+