summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris Severance2015-09-18 12:12:57 -0400
committerChris Severance2015-09-18 12:12:57 -0400
commita2fd4c3f7c584392d4f2953e470fe5fad3ecc93a (patch)
tree53ce8ba688baf74f245d8ca19a309e2a5bfd4c16
downloadaur-dbview.tar.gz
Initial Import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..722d80098c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dbview
+ pkgdesc = A small utility that will display dBase III and IV files and can convert your old .dbf files.
+ pkgver = 1.0.4
+ pkgrel = 2
+ url = http://www.infodrom.org/projects/dbview/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = glibc
+ source = http://www.infodrom.org/projects/dbview/download/dbview-1.0.4.tar.gz
+ sha256sums = bca41716e1ec0ce8833bcacfa17063f338b25f249f92ddb954c7d935e008cee7
+
+pkgname = dbview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..402c5cd17a06
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: fila pruda.com
+
+set -u
+pkgname='dbview'
+pkgver='1.0.4'
+pkgrel='2'
+pkgdesc='A small utility that will display dBase III and IV files and can convert your old .dbf files.'
+arch=('i686' 'x86_64')
+url='http://www.infodrom.org/projects/dbview/'
+license=('GPL')
+depends=('glibc')
+source=("http://www.infodrom.org/projects/dbview/download/dbview-${pkgver}.tar.gz")
+sha256sums=('bca41716e1ec0ce8833bcacfa17063f338b25f249f92ddb954c7d935e008cee7')
+
+build() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ make
+ set +u
+}
+
+package() {
+ set -u
+ cd "${pkgname}-${pkgver}"
+ install -Dpm755 'dbview' -t "${pkgdir}/usr/bin/"
+ install -Dpm644 'dbview.1' -t "${pkgdir}/usr/share/man/man1/"
+ set +u
+}
+set +u