summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjorn Neergaard2016-10-03 00:46:40 -0500
committerBjorn Neergaard2016-10-03 00:46:40 -0500
commit0d468fdca607b19851587672eed2b83aa2704339 (patch)
tree1e4d074a6c54f8666bb8c370f55d5bd291f33aee
downloadaur-0d468fdca607b19851587672eed2b83aa2704339.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD45
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..025057d0465a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon Oct 3 05:46:02 UTC 2016
+pkgbase = ddcutil-git
+ pkgdesc = Query and change Linux monitor settings using DDC/CI and USB (development version).
+ pkgver = v0.6.0.r0.g917e7a8
+ pkgrel = 1
+ url = http://ddcutil.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = git+https://github.com/rockowitz/ddcutil
+ sha256sums = SKIP
+
+pkgname = ddcutil-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2f272d2b7f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Bjorn Neergaard (neersighted) <bjorn@neersighted.com>
+# Contributor: boyska <piuttosto@logorroici.org>
+
+_pkgname=ddcutil
+pkgname=ddcutil-git
+pkgver=v0.6.0.r0.g917e7a8
+pkgrel=1
+pkgdesc='Query and change Linux monitor settings using DDC/CI and USB (development version).'
+url='http://ddcutil.com/'
+license=('GPL')
+source=('git+https://github.com/rockowitz/ddcutil')
+sha256sums=('SKIP')
+arch=('i686' 'x86_64')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Get the version number.
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Generate the build configuration.
+ ./autogen.sh
+ # Configure the build.
+ ./configure
+
+ # Build it!
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Install the program.
+ make DESTDIR="${pkgdir}" install
+
+ # Keep man files in the standard location.
+ mkdir -p "${pkgdir}/usr/share"
+ mv "${pkgdir}/usr/local/share/man" "${pkgdir}/usr/share/man"
+}
+
+# vim: ft=sh ts=2 sw=2 et