summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2020-04-07 03:39:11 -0300
committerRafael Fontenelle2020-04-07 03:39:11 -0300
commit16adc16fa4fc2de1e1cb7faf5bc058ad5d62c8ec (patch)
tree4d17075be7066e639042e92ad755c1ec51315cee
parent3269921203efa992fba5a24a6983b47ebe072ce0 (diff)
downloadaur-16adc16fa4fc2de1e1cb7faf5bc058ad5d62c8ec.tar.gz
Update to 13.0
Enable antibot and recording features.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 399a5926e149..d4dfb837b01d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddnet
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 12.9.2
+ pkgver = 13.0
pkgrel = 1
url = https://ddnet.tw
arch = x86_64
@@ -17,13 +17,14 @@ pkgbase = ddnet
depends = glew
depends = wavpack
depends = pnglite
+ depends = ffmpeg
optdepends = ddnet-skins: A collection with more than 700 custom tee skins.
optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
- source = https://ddnet.tw/downloads/DDNet-12.9.2.tar.xz
+ source = https://ddnet.tw/downloads/DDNet-13.0.tar.xz
source = ddnet-server.service
source = ddnet-sysusers.conf
source = ddnet-tmpfiles.conf
- sha256sums = f8111da322bd70e87463e9769a40d4f3520c34d67109c10d39e8f8913d24f394
+ sha256sums = c8c9123246c6d431120f42637a3c5865f70ffc9de0f6c1361b52fb3a0c269507
sha256sums = 9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965
sha256sums = 70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738
sha256sums = 043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369
diff --git a/PKGBUILD b/PKGBUILD
index 794d102b5dfa..b5f1f038e69a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,20 @@
# Maintainer: Ryozuki <ryo@ryozuki.xyz>
pkgname=ddnet
-pkgver=12.9.2
+pkgver=13.0
pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite')
+depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg')
makedepends=('cmake' 'ninja' 'python')
checkdepends=('gtest')
optdepends=('ddnet-skins: A collection with more than 700 custom tee skins.'
'ddnet-maps-git: All the maps used on the official DDNet Servers.')
source=("https://ddnet.tw/downloads/DDNet-$pkgver.tar.xz"
"ddnet-server.service" "ddnet-sysusers.conf" "ddnet-tmpfiles.conf")
-sha256sums=('f8111da322bd70e87463e9769a40d4f3520c34d67109c10d39e8f8913d24f394'
+sha256sums=('c8c9123246c6d431120f42637a3c5865f70ffc9de0f6c1361b52fb3a0c269507'
'9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965'
'70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738'
'043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369')
@@ -36,6 +36,8 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DAUTOUPDATE=OFF \
+ -DANTIBOT=ON \
+ -DVIDEORECORDER=ON \
-GNinja \
$_mysql_opt
ninja