summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Fontenelle2021-06-12 14:35:44 -0300
committerRafael Fontenelle2021-06-12 14:39:35 -0300
commite14dc42799d27e584debff4b7f8715070323ba9a (patch)
treecca613784ce05f850f39e448cff894991cc8b4b8
parentd54ecd58ac279cce4ea11a54b06ce5d9c528f82d (diff)
downloadaur-e14dc42799d27e584debff4b7f8715070323ba9a.tar.gz
Update to 15.5.1
Also in this commit: - Enable MySQL/MariaDB support by default, since we don't require building mysql-connector-c++ from AUR - Change dependency from mariadb to mariadb-libs (only libs are required to run/build. No need to have mariadb itself installed, if not used. - Remove sdl2 from depends array, as ffmpeg satisfies already
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 11 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9dcb3a989b42..a84954e4ad4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ddnet
pkgdesc = A Teeworlds modification with a unique cooperative gameplay.
- pkgver = 15.5
- pkgrel = 3
+ pkgver = 15.5.1
+ pkgrel = 1
url = https://ddnet.tw
arch = x86_64
license = custom:BSD
@@ -10,7 +10,6 @@ pkgbase = ddnet
makedepends = cmake
makedepends = ninja
makedepends = python
- depends = sdl2
depends = freetype2
depends = opusfile
depends = curl
@@ -21,14 +20,15 @@ pkgbase = ddnet
depends = libnotify
depends = miniupnpc
depends = sqlite
+ depends = mariadb-libs
optdepends = ddnet-skins: A collection with more than 500 custom tee skins.
optdepends = ddnet-maps-git: All the maps used on the official DDNet Servers.
backup = usr/share/ddnet/data/autoexec_server.cfg
- source = https://ddnet.tw/downloads/DDNet-15.5.tar.xz
+ source = https://ddnet.tw/downloads/DDNet-15.5.1.tar.xz
source = ddnet-server.service
source = ddnet-sysusers.conf
source = ddnet-tmpfiles.conf
- sha256sums = a2e8c6e9780700c3c2967c19758ff8418f088eaab60a9e5d2bd8e4b323167ff3
+ sha256sums = 455ffe30b05a497e552e5d0de05a45e503d185b90d808431e4f53a1c1bb280e7
sha256sums = 9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965
sha256sums = 70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738
sha256sums = 043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369
diff --git a/PKGBUILD b/PKGBUILD
index 7a2a71a1606b..e5d808ead360 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Maintainer: Edgar Luque <git@edgarluque.com>
pkgname=ddnet
-pkgver=15.5
-pkgrel=3
+pkgver=15.5.1
+pkgrel=1
pkgdesc="A Teeworlds modification with a unique cooperative gameplay."
arch=('x86_64')
url="https://ddnet.tw"
license=('custom:BSD' 'CCPL:by-nc-sa')
-depends=('sdl2' 'freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc' 'sqlite')
+depends=('freetype2' 'opusfile' 'curl' 'glew' 'wavpack' 'pnglite' 'ffmpeg' 'libnotify' 'miniupnpc' 'sqlite' 'mariadb-libs')
makedepends=('cmake' 'ninja' 'python')
checkdepends=('gmock')
optdepends=('ddnet-skins: A collection with more than 500 custom tee skins.'
@@ -16,19 +16,11 @@ optdepends=('ddnet-skins: A collection with more than 500 custom tee skins.'
backup=('usr/share/ddnet/data/autoexec_server.cfg')
source=("https://ddnet.tw/downloads/DDNet-$pkgver.tar.xz"
"ddnet-server.service" "ddnet-sysusers.conf" "ddnet-tmpfiles.conf")
-sha256sums=('a2e8c6e9780700c3c2967c19758ff8418f088eaab60a9e5d2bd8e4b323167ff3'
+sha256sums=('455ffe30b05a497e552e5d0de05a45e503d185b90d808431e4f53a1c1bb280e7'
'9377a9d7c87abae166c8fa98cd79a61c74482f80f80bc930ae043349e9a84965'
'70034f237270b38bf312238a26cfd322e212ca5714bfea4ae91e80c639ce8738'
'043452f4de3c86d903973009bb3e59b3492a6669b86d0b1410e59a1476a87369')
-# Set 1 to enable MySQL support and add dependencies
-_enable_mysql=0
-
-if [ $_enable_mysql -eq 1 ]; then
- depends+=('mariadb')
- _mysql_opt="-DMYSQL=ON"
-fi
-
build() {
mkdir -p build
cd build
@@ -39,8 +31,8 @@ build() {
-DANTIBOT=ON \
-DVIDEORECORDER=ON \
-DUPNP=ON \
- -GNinja \
- $_mysql_opt
+ -DMYSQL=ON \
+ -GNinja
ninja
}