summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabrizio Pelosi2022-04-13 18:02:34 +0200
committerFabrizio Pelosi2022-04-13 18:04:07 +0200
commitca45f12f02728a4f6c6eb5eda06268f769176c62 (patch)
treeebe154144994a3d53032ebcf346f8ab16fb021f8
parent4ba1b3fdc0226aee42da0f33540a27413040b598 (diff)
downloadaur-ddrescueview-bin.tar.gz
Updated to 0.4.5
Also, use split source and checksum arrays to generate correct .SRCINFO
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 22 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 61828177f232..3420829c890e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ddrescueview-bin
pkgdesc = Graphical viewer for GNU ddrescue log files
- pkgver = 0.4~alpha4
+ pkgver = 0.4.5
pkgrel = 1
url = http://sourceforge.net/projects/ddrescueview
arch = i686
@@ -10,8 +10,9 @@ pkgbase = ddrescueview-bin
depends = gtk2
provides = ddrescueview
conflicts = ddrescueview
- source = https://downloads.sourceforge.net/project/ddrescueview/Test%20builds/v0.4%20alpha%204/Linux-x86_64/ddrescueview-linux-x86_64-0.4~alpha4.tar.xz
- sha512sums = 68ad638105eeecb241f9d4345d2048f0d459908c70967f47ebdbc2441e3ec946b8f181de3f7006a02106a5b991e64d3d23116d8a71f579bd99cfcca2910b0dde
+ source_i686 = https://downloads.sourceforge.net/project/ddrescueview/Test%20builds/v0.4.5/Linux-i386/ddrescueview-linux-i386-0.4.5.tar.xz
+ sha512sums_i686 = 314288d7b693a4bc4dd63a197fbbe9b735d28a2fe68139770ec1389c02f6c1a4eea4e8bbb0d4d6811ab211edc9b0ab779d00dec0a330c23b0bc40d3e44fd5506
+ source_x86_64 = https://downloads.sourceforge.net/project/ddrescueview/Test%20builds/v0.4.5/Linux-x86_64/ddrescueview-linux-x86_64-0.4.5.tar.xz
+ sha512sums_x86_64 = 2a56488f1369a720ef1f119f941f456e121212a70ca52daa1e6ffa1d47898caf6a21218e41ec5ad02152b03ccc96ba6e050113d4d2ef4a2635ac5d5b467fd1dd
pkgname = ddrescueview-bin
-
diff --git a/PKGBUILD b/PKGBUILD
index a4a70a37511d..3f2d2cc928ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=ddrescueview-bin
_pkgname=ddrescueview
-pkgver=0.4~alpha4
-_pkgverurl=0.4%20alpha%204
+pkgver=0.4.5
+_pkgverurl=0.4.5
pkgrel=1
pkgdesc="Graphical viewer for GNU ddrescue log files"
arch=('i686' 'x86_64')
@@ -14,21 +14,24 @@ conflicts=(ddrescueview)
depends=('gtk2')
makedepends=('unzip')
-case ${CARCH} in
- i686)
- _bldarch='i386'
- sha512sums=('f09a460bcbc7dfc424d962d6d7e7d133c01c531b14a272c9113243fc6aab0e5a5107440ec4826269f5e02ebbfefc391ae49c5a76735b6a72296b59af26ea535f')
- ;;
- x86_64)
- _bldarch='x86_64'
- sha512sums=('68ad638105eeecb241f9d4345d2048f0d459908c70967f47ebdbc2441e3ec946b8f181de3f7006a02106a5b991e64d3d23116d8a71f579bd99cfcca2910b0dde')
- ;;
-esac
+sha512sums_x86_64=('2a56488f1369a720ef1f119f941f456e121212a70ca52daa1e6ffa1d47898caf6a21218e41ec5ad02152b03ccc96ba6e050113d4d2ef4a2635ac5d5b467fd1dd')
+sha512sums_i686=('314288d7b693a4bc4dd63a197fbbe9b735d28a2fe68139770ec1389c02f6c1a4eea4e8bbb0d4d6811ab211edc9b0ab779d00dec0a330c23b0bc40d3e44fd5506')
-base_file_name="${_pkgname}-linux-${_bldarch}-${pkgver}"
-source=(https://downloads.sourceforge.net/project/${_pkgname}/Test%20builds/v${_pkgverurl}/Linux-${_bldarch}/${base_file_name}.tar.xz)
+source_x86_64=(https://downloads.sourceforge.net/project/${_pkgname}/Test%20builds/v${_pkgverurl}/Linux-x86_64/${_pkgname}-linux-x86_64-${pkgver}.tar.xz)
+source_i686=(https://downloads.sourceforge.net/project/${_pkgname}/Test%20builds/v${_pkgverurl}/Linux-i386/${_pkgname}-linux-i386-${pkgver}.tar.xz)
package() {
+ case ${CARCH} in
+ i686)
+ _bldarch='i386'
+ ;;
+ x86_64)
+ _bldarch='x86_64'
+ ;;
+ esac
+
+ base_file_name="${_pkgname}-linux-${_bldarch}-${pkgver}"
+
cd "$base_file_name"
install -D -m 755 "${_pkgname}" "${pkgdir}"/usr/bin/"${_pkgname}"
}