summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2023-09-23 13:00:18 +0200
committerFabioLolix2023-09-23 13:00:18 +0200
commit69b54332c04f743b43e6877ec2c0c25ad75a8e68 (patch)
treee1f0ceabb9ce53f2fa804f1f96b70251d3d65c99
downloadaur-deadbeef-plugin-bs2b-git.tar.gz
upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fcec7874c33
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = deadbeef-plugin-bs2b-git
+ pkgdesc = bs2b (Bauer stereophonic-to-binaural) plugin for the DeaDBeeF music player
+ pkgver = r11.5200eae
+ pkgrel = 1
+ url = https://github.com/DeaDBeeF-Player/bs2b
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = glibc
+ depends = deadbeef
+ provides = deadbeef-plugin-bs2b
+ conflicts = deadbeef-plugin-bs2b
+ conflicts = deadbeef-bs2b
+ replaces = deadbeef-bs2b
+ source = deadbeef-plugin-bs2b::git+https://github.com/DeaDBeeF-Player/bs2b.git
+ sha256sums = SKIP
+
+pkgname = deadbeef-plugin-bs2b-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..560e37385ff4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Peter Lamby <peterlamby@web.de>
+
+pkgname=deadbeef-plugin-bs2b-git
+pkgver=r11.5200eae
+pkgrel=1
+pkgdesc="bs2b (Bauer stereophonic-to-binaural) plugin for the DeaDBeeF music player"
+arch=(x86_64)
+url="https://github.com/DeaDBeeF-Player/bs2b"
+license=(MIT)
+depends=(glibc deadbeef)
+makedepends=(git)
+provides=(deadbeef-plugin-bs2b)
+conflicts=(deadbeef-plugin-bs2b deadbeef-bs2b)
+replaces=(deadbeef-bs2b)
+source=("deadbeef-plugin-bs2b::git+https://github.com/DeaDBeeF-Player/bs2b.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd deadbeef-plugin-bs2b
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd deadbeef-plugin-bs2b
+ make
+}
+
+package() {
+ cd deadbeef-plugin-bs2b
+ install -Dm 755 ddb_bs2b.so -t "${pkgdir}/usr/lib/deadbeef/"
+ install -D COPYING -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}