summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2018-05-14 10:49:55 -0400
committerDavid Wells2018-05-14 10:49:55 -0400
commit6915afea0512745dace6b3c10377c144823002ce (patch)
treeef99f26fe262dad8fa78754b67bc62e651a2f118
parent8d7c9489256041adfa0d60a18ecd5e1957937bfc (diff)
downloadaur-6915afea0512745dace6b3c10377c144823002ce.tar.gz
Second 9.0.0 fix.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--scalapack-quick-test.patch44
3 files changed, 7 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 67f7db9fb2d4..cab13c44332e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
pkgver = 9.0.0
- pkgrel = 2
+ pkgrel = 3
url = http://www.dealii.org/
install = deal-ii.install
arch = i686
@@ -32,9 +32,7 @@ pkgbase = deal-ii
optdepends = suitesparse: A collection of sparse matrix libraries
optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
source = https://github.com/dealii/dealii/releases/download/v9.0.0/dealii-9.0.0.tar.gz
- source = scalapack-quick-test.patch
- sha1sums = ac9816053217610d622bb4f056200a46d27fcf32
- sha1sums = 9526ebad9098a9e9140b033cd919d73901215d6f
+ sha1sums = 820bf3961a6d840ee27cf0456d38d6dbd05e1565
pkgname = deal-ii
diff --git a/PKGBUILD b/PKGBUILD
index 6521293bb9f5..9979a89de756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=deal-ii
_realname=dealii
pkgver=9.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -36,10 +36,8 @@ optdepends=(
)
makedepends=('cmake')
install=deal-ii.install
-source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz
- scalapack-quick-test.patch)
-sha1sums=('ac9816053217610d622bb4f056200a46d27fcf32'
- '9526ebad9098a9e9140b033cd919d73901215d6f')
+source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
+sha1sums=('820bf3961a6d840ee27cf0456d38d6dbd05e1565')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
@@ -67,12 +65,8 @@ build() {
fi
done
- # the 9.0.0 quicktest for scalapack relies on an unincluded header:
- cd ${srcdir}
- patch -p0 < ${srcdir}/scalapack-quick-test.patch
-
- # rm -rf "${srcdir}/build"
- # mkdir "${srcdir}/build"
+ rm -rf "${srcdir}/build"
+ mkdir "${srcdir}/build"
cd "${srcdir}/build"
# explicitly disallow bundled packages: this disables bundled copies of boost,
diff --git a/scalapack-quick-test.patch b/scalapack-quick-test.patch
deleted file mode 100644
index e3b5733a3621..000000000000
--- a/scalapack-quick-test.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- dealii-9.0.0/tests/quick_tests/scalapack.cc
-+++ dealii-9.0.0/tests/quick_tests/scalapack.cc
-@@ -14,7 +14,6 @@
- // ---------------------------------------------------------------------
-
- #include "../tests.h"
--#include "../lapack/create_matrix.h"
-
- // adaptation of /scalapack/scalapack_02.cc to a quick test
-
-@@ -32,6 +31,33 @@
- #include <iostream>
-
-
-+
-+template <typename FullMatrix>
-+void create_spd (FullMatrix &A)
-+{
-+ const unsigned int size = A.n();
-+ Assert (size == A.m(), ExcDimensionMismatch(size,A.m()));
-+
-+ for (unsigned int i = 0; i < size; ++i)
-+ for (unsigned int j = i; j < size; ++j)
-+ {
-+ const double val = random_value<typename FullMatrix::value_type>();
-+ Assert (val >= 0. && val <= 1.,
-+ ExcInternalError());
-+ if (i==j)
-+ // since A(i,j) < 1 and
-+ // a symmetric diagonally dominant matrix is SPD
-+ A(i,j) = val + size;
-+ else
-+ {
-+ A(i,j) = val;
-+ A(j,i) = val;
-+ }
-+ }
-+}
-+
-+
-+
- template <typename NumberType>
- void test(const unsigned int size, const unsigned int block_size)
- {