summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Dang2015-08-05 14:35:35 +0200
committerFlorian Dang2015-08-05 14:35:35 +0200
commit6dc709d78ab51a1ea47e0efc37a35bb3e3a9e936 (patch)
tree26742520c8aebcc4a700665b8a0b6c10b3acf5f3
downloadaur-6dc709d78ab51a1ea47e0efc37a35bb3e3a9e936.tar.gz
initial deal-ii 8.3.0 pkgbuild
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD53
-rw-r--r--deal-ii.install4
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..768f4f66a01a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = deal-ii
+ pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
+ pkgver = 8.3.0
+ pkgrel = 1
+ url = http://www.dealii.org/
+ install = deal-ii.install
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = cmake
+ depends = boost
+ depends = lapack
+ depends = openmpi
+ optdepends = petsc: Portable, extensible toolkit for scientific computation
+ optdepends = slepc: Scalable library for Eigenvalue problem computations
+ optdepends = mumps: Sparse solver library using Gaussian elimination
+ optdepends = intel-tbb: High level abstract threading library
+ optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
+ optdepends = metis: partitioning graphs, finite element meshes, fill reducing orderings for sparse matrices.
+ source = https://github.com/dealii/dealii/releases/download/v8.3.0/dealii-8.3.0.tar.gz
+ sha1sums = 274288b09c053b461239040816129a9eb9d45914
+
+pkgname = deal-ii
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f8b235a1a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Florian Dang <florian dot coin at gmail dot com>
+
+pkgname=deal-ii
+_realname=dealii
+pkgver=8.3.0
+pkgrel=1
+pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
+arch=("i686" "x86_64")
+url="http://www.dealii.org/"
+license=('LGPL')
+depends=('boost' 'lapack' 'openmpi')
+optdepends=('petsc: Portable, extensible toolkit for scientific computation'
+ 'slepc: Scalable library for Eigenvalue problem computations'
+ 'mumps: Sparse solver library using Gaussian elimination'
+ 'intel-tbb: High level abstract threading library'
+ 'trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems'
+ 'metis: partitioning graphs, finite element meshes, fill reducing orderings for sparse matrices.'
+ )
+makedepends=('cmake')
+install=deal-ii.install
+source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
+# source=(https://dealii.googlecode.com/files/${_realname}-$pkgver.tar.gz)
+sha1sums=('274288b09c053b461239040816129a9eb9d45914')
+
+build() {
+ # cd "${srcdir}/${_realname}-$pkgver"
+ rm -rf "${srcdir}/build"
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr/ ../${_realname}-$pkgver
+
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}" install
+
+ # doc
+ #install -d "${pkgdir}/usr/share/doc/"
+ #mv "${srcdir}/${_realname}/doc/" "${pkgdir}/usr/share/doc/${_realname}"
+
+ # examples and README
+ #mv "${pkgdir}/usr/${_realname}/examples/" "${pkgdir}/usr/share/doc/${_realname}"
+ #mv "${pkgdir}/usr/${_realname}/README" "${pkgdir}/usr/share/doc/${_realname}"
+
+ # remove unnecessary stuffs in pkgbuild
+ #rm -rf "${pkgdir}/usr/${_realname}/cmake" "${pkgdir}/usr/${_realname}/common/"
+
+ install -D -m644 "${srcdir}/${_realname}-$pkgver/LICENSE" "${pkgdir}/usr/share/licenses/${_realname}-$pkgver/LICENSE"
+}
+
diff --git a/deal-ii.install b/deal-ii.install
new file mode 100644
index 000000000000..9d72fcb67f83
--- /dev/null
+++ b/deal-ii.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo 'deal.II 8.3.0 has an online documentation available at http://www.dealii.org/8.3.0/'
+ echo 'deal.II examples are provided in /usr/examples/deal.II'
+}