summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2017-10-08 23:00:47 -0400
committerDavid Wells2017-10-08 23:00:47 -0400
commitadc21ccd1a5c1307002b2b1723a33d6070c2b8ed (patch)
tree3c2ecb7e8035b2d9d4b335a684d3dcf0b2e2e8e3
parenta60761542a1644d1ff31cc16c27e27dce64d319c (diff)
downloadaur-adc21ccd1a5c1307002b2b1723a33d6070c2b8ed.tar.gz
Update to 8.5.1.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--fix-compilation-with-BOOST-1.64.patch99
3 files changed, 8 insertions, 113 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59bf878e82af..392c21217639 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deal-ii
pkgdesc = An Open Source Finite Element Differential Equations Analysis Library
- pkgver = 8.5.0
- pkgrel = 4
+ pkgver = 8.5.1
+ pkgrel = 0
url = http://www.dealii.org/
install = deal-ii.install
arch = i686
@@ -27,10 +27,8 @@ pkgbase = deal-ii
optdepends = trilinos: object-oriented software framework for the solution of large-scale, complex multi-physics engineering and scientific problems
optdepends = suitesparse: A collection of sparse matrix libraries
optdepends = zlib: Compression library implementing the deflate compression method found in gzip and PKZIP
- source = https://github.com/dealii/dealii/releases/download/v8.5.0/dealii-8.5.0.tar.gz
- source = fix-compilation-with-BOOST-1.64.patch
- sha1sums = 75076beddfd4a1b590cba9fbc78eea901c7f3ddb
- sha1sums = 183c71c04acf715c1e2ceceb685c34d497db075c
+ source = https://github.com/dealii/dealii/releases/download/v8.5.1/dealii-8.5.1.tar.gz
+ sha1sums = fe8e4748c1d9650487fb5145429a58e8509de276
pkgname = deal-ii
diff --git a/PKGBUILD b/PKGBUILD
index be3794075311..e7ae74232746 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=deal-ii
_realname=dealii
-pkgver=8.5.0
-pkgrel=4
+pkgver=8.5.1
+pkgrel=0
pkgdesc="An Open Source Finite Element Differential Equations Analysis Library"
arch=("i686" "x86_64")
url="http://www.dealii.org/"
@@ -32,10 +32,8 @@ optdepends=(
)
makedepends=('cmake')
install=deal-ii.install
-source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz
- fix-compilation-with-BOOST-1.64.patch)
-sha1sums=('75076beddfd4a1b590cba9fbc78eea901c7f3ddb'
- '183c71c04acf715c1e2ceceb685c34d497db075c')
+source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
+sha1sums=('fe8e4748c1d9650487fb5145429a58e8509de276')
# where to install deal.II: change to something else (e.g., /opt/deal.II/)
# if desired.
@@ -43,8 +41,6 @@ installation_prefix=/usr
prepare() {
cd "${srcdir}/${_realname}-${pkgver}/"
-
- patch -Np1 -i ${srcdir}/fix-compilation-with-BOOST-1.64.patch
}
build() {
diff --git a/fix-compilation-with-BOOST-1.64.patch b/fix-compilation-with-BOOST-1.64.patch
deleted file mode 100644
index 403f702f1aa0..000000000000
--- a/fix-compilation-with-BOOST-1.64.patch
+++ /dev/null
@@ -1,99 +0,0 @@
-
----
- include/deal.II/base/aligned_vector.h | 10 +++++++++-
- include/deal.II/lac/la_vector.h | 10 +++++++++-
- include/deal.II/lac/sparsity_pattern.h | 11 ++++++++++-
- include/deal.II/lac/vector.h | 10 +++++++++-
- 4 files changed, 37 insertions(+), 4 deletions(-)
-
-diff --git a/include/deal.II/base/aligned_vector.h b/include/deal.II/base/aligned_vector.h
-index b8c52c0699..9ba473de83 100644
---- a/include/deal.II/base/aligned_vector.h
-+++ b/include/deal.II/base/aligned_vector.h
-@@ -23,7 +23,15 @@
- #include <deal.II/base/memory_consumption.h>
- #include <deal.II/base/utilities.h>
- #include <deal.II/base/parallel.h>
--#include <boost/serialization/array.hpp>
-+
-+// boost::serialization::make_array used to be in array.hpp, but was
-+// moved to a different file in BOOST 1.64
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106400
-+# include <boost/serialization/array_wrapper.hpp>
-+#else
-+# include <boost/serialization/array.hpp>
-+#endif
- #include <boost/serialization/split_member.hpp>
-
- #include <cstring>
-diff --git a/include/deal.II/lac/la_vector.h b/include/deal.II/lac/la_vector.h
-index 18dbcf5d02..10927eb0a5 100644
---- a/include/deal.II/lac/la_vector.h
-+++ b/include/deal.II/lac/la_vector.h
-@@ -24,7 +24,15 @@
- #include <deal.II/lac/read_write_vector.h>
- #include <deal.II/lac/vector_space_vector.h>
- #include <deal.II/lac/vector_type_traits.h>
--#include <boost/serialization/array.hpp>
-+
-+// boost::serialization::make_array used to be in array.hpp, but was
-+// moved to a different file in BOOST 1.64
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106400
-+# include <boost/serialization/array_wrapper.hpp>
-+#else
-+# include <boost/serialization/array.hpp>
-+#endif
- #include <boost/serialization/split_member.hpp>
-
- #include <cstdio>
-diff --git a/include/deal.II/lac/sparsity_pattern.h b/include/deal.II/lac/sparsity_pattern.h
-index 2db0dd3009..8a77764ed2 100644
---- a/include/deal.II/lac/sparsity_pattern.h
-+++ b/include/deal.II/lac/sparsity_pattern.h
-@@ -20,11 +20,20 @@
- #include <deal.II/base/config.h>
- #include <deal.II/base/exceptions.h>
- #include <deal.II/base/subscriptor.h>
--#include <boost/serialization/array.hpp>
-+
-+// boost::serialization::make_array used to be in array.hpp, but was
-+// moved to a different file in BOOST 1.64
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106400
-+# include <boost/serialization/array_wrapper.hpp>
-+#else
-+# include <boost/serialization/array.hpp>
-+#endif
- #include <boost/serialization/split_member.hpp>
-
- #include <vector>
- #include <iostream>
-+#include <algorithm>
-
- DEAL_II_NAMESPACE_OPEN
-
-diff --git a/include/deal.II/lac/vector.h b/include/deal.II/lac/vector.h
-index 4c63d2aa68..79e56bb7a2 100644
---- a/include/deal.II/lac/vector.h
-+++ b/include/deal.II/lac/vector.h
-@@ -23,7 +23,15 @@
- #include <deal.II/base/subscriptor.h>
- #include <deal.II/base/index_set.h>
- #include <deal.II/lac/vector_type_traits.h>
--#include <boost/serialization/array.hpp>
-+
-+// boost::serialization::make_array used to be in array.hpp, but was
-+// moved to a different file in BOOST 1.64
-+#include <boost/version.hpp>
-+#if BOOST_VERSION >= 106400
-+# include <boost/serialization/array_wrapper.hpp>
-+#else
-+# include <boost/serialization/array.hpp>
-+#endif
- #include <boost/serialization/split_member.hpp>
-
- #include <cstdio>
---
-2.13.1