summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2017-05-02 09:03:59 -0400
committerDavid Wells2017-05-02 09:05:37 -0400
commitc735e1ec492aeda8c53857dd76495d69edfa58bc (patch)
tree71741b3e81355ee3377e7aed6fe0a8bb22dcf17e
parentf08120b0fa394921effdb7f228fc4d8d4a739f48 (diff)
downloadaur-c735e1ec492aeda8c53857dd76495d69edfa58bc.tar.gz
Unconditionally ignore unknown pragmas.
This avoids complex Trilinos detection logic, and there is no reason to show these warnings under any circumstances anyway.
-rw-r--r--PKGBUILD15
1 files changed, 2 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e59477b818e..25443ae4d6f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -82,19 +82,8 @@ build() {
fi
fi
- # deal.II does not compile with OpenMP: if we use Trilinos and some Epetra
- # headers have OpenMP pragmas enabled then skip unknown pragma warnings.
- extra_warning_flags=""
- if pacman -Qs trilinos >/dev/null
- then
- if [ -f $TRILINOS_DIR/include/Epetra_config.h ]
- then
- if grep '^#define EPETRA_HAVE_OMP$' $TRILINOS_DIR/include/Epetra_config.h >/dev/null
- then
- extra_warning_flags+=" -Wno-unknown-pragmas"
- fi
- fi
- fi
+ # Skip some warnings that appear if Trilinos uses OpenMP pragmas in headers:
+ extra_warning_flags=" -Wno-unknown-pragmas"
# the deal.II GCC flags are already well-chosen for speed (and O3 is known to
# be slightly slower than O2), so do not use flags in /etc/makepkg.conf by