summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Wells2017-04-15 17:30:33 -0400
committerDavid Wells2017-04-15 17:30:33 -0400
commitdb6fcd11e36fb58ff3ac919b0de590894896e82c (patch)
treedad65fc358d17a1c2e745f5bb381a8d640dc9ecd
parentd1ce17382cb6601ace4a24b00ef754061caadd0e (diff)
downloadaur-db6fcd11e36fb58ff3ac919b0de590894896e82c.tar.gz
Remove some duplicate files.
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 875b6715ab77..f52805ae1443 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,10 +37,11 @@ install=deal-ii.install
source=(https://github.com/dealii/dealii/releases/download/v$pkgver/${_realname}-$pkgver.tar.gz)
sha1sums=('75076beddfd4a1b590cba9fbc78eea901c7f3ddb')
+# where to install deal.II: change to something else (e.g., /opt/deal.II/)
+# if desired.
+installation_prefix=/usr
+
build() {
- # where to install deal.II: change to something else (e.g., /opt/deal.II/)
- # if desired.
- installation_prefix=/usr
# Since deal.II relies on a relatively large number of packages that are
# installed in nonstandard places (i.e., the Trilinos AUR package is installed
@@ -149,6 +150,10 @@ package() {
cd "${srcdir}/build"
make DESTDIR="${pkgdir}" install
+ # delete extra files that deal.II installs into the top level directory
+ rm "${pkgdir}/${installation_prefix}/LICENSE"
+ rm "${pkgdir}/${installation_prefix}/README.md"
+
install -D -m755 "${srcdir}/build/deal-ii.sh" "${pkgdir}/etc/profile.d/deal-ii.sh"
install -D -m644 "${srcdir}/${_realname}-$pkgver/LICENSE" "${pkgdir}/usr/share/licenses/${_realname}-$pkgver/LICENSE"
}