summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbrent s2015-08-24 21:21:29 -0400
committerbrent s2015-08-24 21:21:29 -0400
commit9b9cf956addd7d841f586bda1f304a1cf7c0eff1 (patch)
tree21074e11f864aee89140c5875b42ef399bc9c155
downloadaur-9b9cf956addd7d841f586bda1f304a1cf7c0eff1.tar.gz
initial import from AUR3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08843ba95b69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = debianutils
+ pkgdesc = Miscellaneous utilities specific to Debian
+ pkgver = 4.4
+ pkgrel = 1
+ url = http://packages.qa.debian.org/d/debianutils.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = run-parts
+ depends = which
+ source = http://ftp.debian.org/debian/pool/main/d/debianutils/debianutils_4.4.tar.gz
+ md5sums = c0cb076754d7f4eb1e3397d00916647f
+
+pkgname = debianutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..148ae1555a88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Jochen Schalanda <jochen+aur (at) schalanda.name>
+pkgname=debianutils
+pkgver=4.4
+pkgrel=1
+pkgdesc="Miscellaneous utilities specific to Debian"
+arch=('i686' 'x86_64')
+url="http://packages.qa.debian.org/d/debianutils.html"
+license=('GPL')
+depends=('run-parts' 'which')
+source=(http://ftp.debian.org/debian/pool/main/d/${pkgname}/${pkgname}_${pkgver}.tar.gz)
+md5sums=('c0cb076754d7f4eb1e3397d00916647f')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+
+ msg 'Remove files of "which" and "run-parts" package...'
+ cd
+ find "${pkgdir}" -name which* -delete
+ find "${pkgdir}" -name run-parts* -delete
+}