summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2021-10-26 09:09:00 +0200
committerThéo Le Calvar2021-10-26 09:09:00 +0200
commit009eb079e763006bb6c190d7f07fdb62079f095a (patch)
tree0c1381f85f43930d1b99649d207a25f59c91941a
parentd5330392bf5f35794a4247661d2e457b64e40dff (diff)
downloadaur-009eb079e763006bb6c190d7f07fdb62079f095a.tar.gz
bump version to 12.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD26
-rw-r--r--bm_util.c_5.13.4-200.fc34.x86_64.patch18
3 files changed, 14 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 248722c53393..af9de1932e6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
- pkgver = 12.1
- pkgrel = 2
+ pkgver = 12.2
+ pkgrel = 0
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -9,10 +9,8 @@ pkgbase = decklink
makedepends = curl
options = !strip
options = staticlibs
- source = decklink-12.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/114f976c4d3642168d24344d5f5b2afc
- source = bm_util.c_5.13.4-200.fc34.x86_64.patch
- sha256sums = 51febf247d22412beea2d637fcc34cc19b1a46df9a5bf0e157d95705bf7c7b73
- sha256sums = 66e4bd6a55fcabb1c774c326318daba7fbeb6febcf8867f55c54bf00fc113504
+ source = decklink-12.2.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/f3106b481e2b4cd5934a650c869be25f
+ sha256sums = 62954a18b60d9040aa4a959dff30ac9c260218ef78d6a63cbb243788f7abc05f
pkgname = decklink
install = decklink.install
diff --git a/PKGBUILD b/PKGBUILD
index f0e85e4de3d1..699fd7937488 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
-pkgver=12.1
-pkgrel=2
+pkgver=12.2
+pkgrel=0
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
@@ -14,7 +14,7 @@ options=('!strip' 'staticlibs')
[ "$CARCH" = "i686" ] && _arch='i386'
[ "$CARCH" = "x86_64" ] && _arch='x86_64'
-_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/114f976c4d3642168d24344d5f5b2afc"
+_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/f3106b481e2b4cd5934a650c869be25f"
_pkgsrc_file=${_pkgname}-${pkgver}.tar.gz
DLAGENTS=("https::/usr/bin/curl \
@@ -29,10 +29,8 @@ DLAGENTS=("https::/usr/bin/curl \
)"
)
-source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
- "bm_util.c_5.13.4-200.fc34.x86_64.patch")
-sha256sums=('51febf247d22412beea2d637fcc34cc19b1a46df9a5bf0e157d95705bf7c7b73'
- '66e4bd6a55fcabb1c774c326318daba7fbeb6febcf8867f55c54bf00fc113504')
+source=("${_pkgsrc_file}"::"${_pkgsrc_url}")
+sha256sums=('62954a18b60d9040aa4a959dff30ac9c260218ef78d6a63cbb243788f7abc05f')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}
@@ -41,16 +39,12 @@ prepare() {
cd desktopvideo-*/usr/src
- for p in ${srcdir}/*.patch;
- do
- echo "Applying ${p}"
- patch --forward --strip=1 --input="${p}"
- done
+ # for p in ${srcdir}/*.patch;
+ # do
+ # echo "Applying ${p}"
+ # patch --forward --strip=1 --input="${p}"
+ # done
-
- # fix error related to "initialization of « unsigned int (*)(struct tty_struct *) » from pointer type « int (*)(struct tty_struct *) »"
- sed "s:^EXTRA_CFLAGS +=:EXTRA_CFLAGS += -Wno-error=incompatible-pointer-types:" -i blackmagic-io-*/Makefile
- sed "s:^EXTRA_CFLAGS +=:EXTRA_CFLAGS += -Wno-error=incompatible-pointer-types:" -i blackmagic-[0-9]*/Makefile
}
package_decklink() {
diff --git a/bm_util.c_5.13.4-200.fc34.x86_64.patch b/bm_util.c_5.13.4-200.fc34.x86_64.patch
deleted file mode 100644
index 7ef1c0a4573f..000000000000
--- a/bm_util.c_5.13.4-200.fc34.x86_64.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/blackmagic-io-12.1a9/bm_util.old.c 2021-05-17 15:44:36.000000000 +1000
-+++ b/blackmagic-io-12.1a9/bm_util.c 2021-07-26 14:46:37.088542000 +1000
-@@ -24,7 +24,6 @@
- ** DEALINGS IN THE SOFTWARE.
- ** -LICENSE-END-
- */
--#include <asm/io.h>
- #include <linux/delay.h>
- #include <linux/hash.h>
- #include <linux/interrupt.h>
-@@ -41,6 +40,7 @@
- #include <linux/uaccess.h>
- #include <linux/vmalloc.h>
- #include <linux/wait.h>
-+#include <asm/io.h>
- #include "bm_version.h"
- #if KERNEL_VERSION_OR_LATER(2, 6, 20)
- #include <linux/freezer.h>