summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2023-06-30 08:46:54 +0200
committerThéo Le Calvar2023-06-30 08:46:54 +0200
commit13a4e40e30556916d502fa69d7a8e0a6540ac2d4 (patch)
tree8274687e4ebc4a6660e494856163613099c3d806
parent83546c2fb26fee115ef81fac375686ebfaa8479e (diff)
downloadaur-13a4e40e30556916d502fa69d7a8e0a6540ac2d4.tar.gz
bump version to 12.5
-rw-r--r--.SRCINFO12
-rw-r--r--01-remove_prandom.patch13
-rw-r--r--02-remove_snd_dma.patch14
-rw-r--r--PKGBUILD22
4 files changed, 13 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8feee2a44b3a..fce841d39423 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
- pkgver = 12.4.1
- pkgrel = 2
+ pkgver = 12.5
+ pkgrel = 1
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -9,12 +9,8 @@ pkgbase = decklink
makedepends = curl
options = !strip
options = staticlibs
- source = decklink-12.4.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/14db0fdb95d54778928cec6711ec543e
- source = 01-remove_prandom.patch
- source = 02-remove_snd_dma.patch
- sha256sums = d5363b15d305e5484fa62af16b1bd11a296746442dc82c4481d5b193bbbabf3e
- sha256sums = 5f5d649a5fe4a794d12683635b6e4dcbae47d2d109eeb913e10ce4aa823b3dd9
- sha256sums = b51ea17289a7eb127443fbb28e79f9fd4a6be249980b7efc0a63a18545f20e02
+ source = decklink-12.5.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/fecacc0f9b2f4c2e8bf2863e9e26c8e1
+ sha256sums = f6e688123efd0deefaa01ecde6b4f630306a4ddcc9f33537433ea613c2a33dd1
pkgname = decklink
install = decklink.install
diff --git a/01-remove_prandom.patch b/01-remove_prandom.patch
deleted file mode 100644
index b30d165d9000..000000000000
--- a/01-remove_prandom.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/blackmagic-io-12.4.1a15/bm_util.c 2023-01-01 13:26:47.100202432 +0100
-+++ b/blackmagic-io-12.4.1a15/bm_util.c 2023-01-01 13:09:53.705229108 +0100
-@@ -902,7 +902,9 @@
- // Random
- uint32_t bm_random32(void)
- {
--#if KERNEL_VERSION_OR_LATER(3, 8, 0)
-+#if KERNEL_VERSION_OR_LATER(6, 1, 0)
-+ return get_random_u32();
-+#elif KERNEL_VERSION_OR_LATER(3, 8, 0)
- return prandom_u32();
- #elif KERNEL_VERSION_OR_LATER(2, 6, 19)
- return random32(); \ No newline at end of file
diff --git a/02-remove_snd_dma.patch b/02-remove_snd_dma.patch
deleted file mode 100644
index c012f874e0fd..000000000000
--- a/02-remove_snd_dma.patch
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/blackmagic-io-12.4.1a15/bmio_audio.c 2023-01-01 13:28:20.699872928 +0100
-+++ b/blackmagic-io-12.4.1a15/bmio_audio.c 2023-01-01 13:09:47.085284412 +0100
-@@ -432,7 +432,11 @@
-
- snd_pcm_lib_preallocate_pages_for_all(pcm,
- SNDRV_DMA_TYPE_CONTINUOUS,
-- snd_dma_continuous_data(GFP_KERNEL),
-+ #if KERNEL_VERSION_OR_LATER(6, 1, 0)
-+ NULL,
-+ #else
-+ snd_dma_continuous_data(GFP_KERNEL),
-+ #endif
- bmio_audio_hardware.buffer_size,
- bmio_audio_hardware.buffer_size); \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 8f5012280e54..cfaa2b56db07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
-pkgver=12.4.1
-pkgrel=2
+pkgver=12.5
+pkgrel=1
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
@@ -14,7 +14,7 @@ options=('!strip' 'staticlibs')
[ "$CARCH" = "i686" ] && _arch='i386'
[ "$CARCH" = "x86_64" ] && _arch='x86_64'
-_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/14db0fdb95d54778928cec6711ec543e"
+_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/fecacc0f9b2f4c2e8bf2863e9e26c8e1"
_pkgsrc_file=${_pkgname}-${pkgver}.tar.gz
DLAGENTS=("https::/usr/bin/curl \
@@ -30,12 +30,8 @@ DLAGENTS=("https::/usr/bin/curl \
)
source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
- "01-remove_prandom.patch"
- "02-remove_snd_dma.patch"
)
-sha256sums=('d5363b15d305e5484fa62af16b1bd11a296746442dc82c4481d5b193bbbabf3e'
- '5f5d649a5fe4a794d12683635b6e4dcbae47d2d109eeb913e10ce4aa823b3dd9'
- '85c1d58bd49c6f06f077c77ac26cbe8bc58e68f761b8a01d9f01e843fbc6fa9d')
+sha256sums=('f6e688123efd0deefaa01ecde6b4f630306a4ddcc9f33537433ea613c2a33dd1')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}
@@ -44,11 +40,11 @@ prepare() {
cd desktopvideo-*/usr/src
- for p in ${srcdir}/*.patch;
- do
- echo "Applying ${p}"
- patch --forward --strip=1 --input="${p}"
- done
+ # for p in ${srcdir}/*.patch;
+ # do
+ # echo "Applying ${p}"
+ # patch --forward --strip=1 --input="${p}"
+ # done
}