summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2020-11-13 11:02:57 +0100
committerThéo Le Calvar2020-11-13 11:02:57 +0100
commit68d2cef9ebe8de38b8506e4529fb69214603b4d1 (patch)
tree022a4911386de7c57b55cd6d7421bb1d1b5d4d4e
parent8f19ef584c0603105415160d2ba4e8dfa47495ce (diff)
downloadaur-68d2cef9ebe8de38b8506e4529fb69214603b4d1.tar.gz
vump version to 11.7
-rw-r--r--.SRCINFO18
-rw-r--r--01-fix-get_user_pages.patch18
-rw-r--r--01-fix-makefile.patch24
-rw-r--r--02-fix-get_user_pages-and-mmap_lock.patch37
-rw-r--r--02-fix-have_unlocked_ioctl.patch (renamed from 03-fix-have_unlocked_ioctl.patch)6
-rw-r--r--PKGBUILD18
6 files changed, 37 insertions, 84 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe107f1d5002..020bae3e2dd5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
- pkgver = 11.6
- pkgrel = 3
+ pkgver = 11.7
+ pkgrel = 1
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -9,14 +9,12 @@ pkgbase = decklink
makedepends = curl
options = !strip
options = staticlibs
- source = decklink-11.6.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/6b9e675965fc4c3b9ece9e040dff5358
- source = 01-fix-makefile.patch
- source = 02-fix-get_user_pages-and-mmap_lock.patch
- source = 03-fix-have_unlocked_ioctl.patch
- sha256sums = 008dcbaa019efd69c802e9caa497d719a2774ee6bccf1a57906702ffc60a9563
- sha256sums = c5590e0d80a01cf1b232145f43ac7993e924d7552375f747d31169dd934265fd
- sha256sums = 036b1adddc00d217c6a251c829551065cd20bb1f7f7437e378555fd4aa547457
- sha256sums = 15956507d4bb6b59b6b6cff3c7d9771cd7e653789ea6b3ce686d26bd563d5c0f
+ source = decklink-11.7.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/a129758034e44f678b1fd630d40e0770
+ source = 01-fix-get_user_pages.patch
+ source = 02-fix-have_unlocked_ioctl.patch
+ sha256sums = 140262b37ac1e066dab4b34a463e209eeb776620497bf23b87c8250c51d01ae0
+ sha256sums = eb0af209b45be73778022ba868e7c894eeb90e684f449315beb45696d19caf16
+ sha256sums = b4ec68b2e05c0d76f857d231c03cc3c8403c5bbdc172a79da2f00eba039a6bb3
pkgname = decklink
install = decklink.install
diff --git a/01-fix-get_user_pages.patch b/01-fix-get_user_pages.patch
new file mode 100644
index 000000000000..ef7a4e1663bb
--- /dev/null
+++ b/01-fix-get_user_pages.patch
@@ -0,0 +1,18 @@
+diff --git a/blackmagic-11.7a12/blackmagic_lib.c b/blackmagic-11.7a12/blackmagic_lib.c.orig
+index 5494372..d1685e2 100644
+--- a/blackmagic-11.7a12/blackmagic_lib.c
++++ b/blackmagic-11.7a12/blackmagic_lib.c.orig
+@@ -676,7 +676,12 @@ dl_get_user_pages(void *task_ptr, void *ptr, unsigned long size, unsigned long *
+ #else
+ down_read(&current_task->mm->mmap_sem);
+ #endif
+-#if KERNEL_VERSION_OR_LATER(4, 10, 0)
++#if KERNEL_VERSION_OR_LATER(5, 9, 0)
++ if (current_task == current)
++ ret = get_user_pages((unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL);
++ else
++ ret = get_user_pages_remote(current_task->mm, (unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL, NULL);
++#elif KERNEL_VERSION_OR_LATER(4, 10, 0)
+ if (current_task == current)
+ ret = get_user_pages((unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL);
+ else
diff --git a/01-fix-makefile.patch b/01-fix-makefile.patch
deleted file mode 100644
index 8e5f7a8fb4a7..000000000000
--- a/01-fix-makefile.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/blackmagic-11.6a26/Makefile b/blackmagic-11.6a26/Makefile
-index a157ae9..91a9ee0 100644
---- a/blackmagic-11.6a26/Makefile
-+++ b/blackmagic-11.6a26/Makefile
-@@ -40,6 +40,7 @@ KERNELDIR ?= /lib/modules/$(KERNELRELEASE)/build
- PWD := $(shell pwd)
-
- all:
-+ touch .bmd-support.o.cmd
- $(MAKE) -C $(KERNELDIR) M=$(PWD)
-
- clean:
-diff --git a/blackmagic-io-11.6a26/Makefile b/blackmagic-io-11.6a26/Makefile
-index 7e4699a..9dc379c 100644
---- a/blackmagic-io-11.6a26/Makefile
-+++ b/blackmagic-io-11.6a26/Makefile
-@@ -43,6 +43,7 @@ KERNELDIR ?= /lib/modules/$(KERNELRELEASE)/build
- PWD := $(shell pwd)
-
- all:
-+ touch .blackmagic.o.cmd
- $(MAKE) -C $(KERNELDIR) M=$(PWD)
-
- clean:
diff --git a/02-fix-get_user_pages-and-mmap_lock.patch b/02-fix-get_user_pages-and-mmap_lock.patch
deleted file mode 100644
index 68b378bef3d2..000000000000
--- a/02-fix-get_user_pages-and-mmap_lock.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/blackmagic-11.6a26/blackmagic_lib.c.orig b/blackmagic-11.6a26/blackmagic_lib.c
-index 83fab89..35b54b5 100644
---- a/blackmagic-11.6a26/blackmagic_lib.c.orig
-+++ b/blackmagic-11.6a26/blackmagic_lib.c
-@@ -670,9 +670,17 @@ dl_get_user_pages(void *task_ptr, void *ptr, unsigned long size, unsigned long *
- write = 1;
- else
- write = 0;
--
-+#if KERNEL_VERSION_OR_LATER(5, 8, 0)
-+ down_read(&current_task->mm->mmap_lock);
-+#else
- down_read(&current_task->mm->mmap_sem);
--#if KERNEL_VERSION_OR_LATER(4, 10, 0)
-+#endif
-+#if KERNEL_VERSION_OR_LATER(5, 9, 0)
-+ if (current_task == current)
-+ ret = get_user_pages((unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL);
-+ else
-+ ret = get_user_pages_remote(current_task->mm, (unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL, NULL);
-+#elif KERNEL_VERSION_OR_LATER(4, 10, 0)
- if (current_task == current)
- ret = get_user_pages((unsigned long)ptr & PAGE_MASK, *nr_pages, write ? FOLL_WRITE : 0, pages, NULL);
- else
-@@ -692,7 +700,12 @@ dl_get_user_pages(void *task_ptr, void *ptr, unsigned long size, unsigned long *
- #else
- ret = get_user_pages(current_task, current_task->mm, (unsigned long)ptr & PAGE_MASK, *nr_pages, write, 0, pages, NULL);
- #endif
-+
-+#if KERNEL_VERSION_OR_LATER(5, 8, 0)
-+ up_read(&current_task->mm->mmap_lock);
-+#else
- up_read(&current_task->mm->mmap_sem);
-+#endif
-
- if (ret < (long)*nr_pages)
- {
diff --git a/03-fix-have_unlocked_ioctl.patch b/02-fix-have_unlocked_ioctl.patch
index edd6b578c009..7699c2a189e8 100644
--- a/03-fix-have_unlocked_ioctl.patch
+++ b/02-fix-have_unlocked_ioctl.patch
@@ -1,7 +1,7 @@
-diff --git a/blackmagic-11.6a26/blackmagic_core.c b/blackmagic-11.6a26/blackmagic_core.c
+diff --git a/blackmagic-11.7a12/blackmagic_core.c b/blackmagic-11.7a12/blackmagic_core.c
index 2acbdd6..8d4f332 100644
---- a/blackmagic-11.6a26/blackmagic_core.c
-+++ b/blackmagic-11.6a26/blackmagic_core.c
+--- a/blackmagic-11.7a12/blackmagic_core.c
++++ b/blackmagic-11.7a12/blackmagic_core.c
@@ -41,6 +41,12 @@
#include "blackmagic_core.h"
diff --git a/PKGBUILD b/PKGBUILD
index 469f9d8059b7..e979f0e08756 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
-pkgver=11.6
-pkgrel=3
+pkgver=11.7
+pkgrel=1
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
@@ -14,7 +14,7 @@ options=('!strip' 'staticlibs')
[ "$CARCH" = "i686" ] && _arch='i386'
[ "$CARCH" = "x86_64" ] && _arch='x86_64'
-_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/6b9e675965fc4c3b9ece9e040dff5358"
+_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/a129758034e44f678b1fd630d40e0770"
_pkgsrc_file=${_pkgname}-${pkgver}.tar.gz
DLAGENTS=("https::/usr/bin/curl \
@@ -30,13 +30,11 @@ DLAGENTS=("https::/usr/bin/curl \
)
source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
- "01-fix-makefile.patch"
- "02-fix-get_user_pages-and-mmap_lock.patch"
- "03-fix-have_unlocked_ioctl.patch")
-sha256sums=('008dcbaa019efd69c802e9caa497d719a2774ee6bccf1a57906702ffc60a9563'
- 'c5590e0d80a01cf1b232145f43ac7993e924d7552375f747d31169dd934265fd'
- '036b1adddc00d217c6a251c829551065cd20bb1f7f7437e378555fd4aa547457'
- '15956507d4bb6b59b6b6cff3c7d9771cd7e653789ea6b3ce686d26bd563d5c0f')
+ "01-fix-get_user_pages.patch"
+ "02-fix-have_unlocked_ioctl.patch")
+sha256sums=('140262b37ac1e066dab4b34a463e209eeb776620497bf23b87c8250c51d01ae0'
+ 'eb0af209b45be73778022ba868e7c894eeb90e684f449315beb45696d19caf16'
+ 'b4ec68b2e05c0d76f857d231c03cc3c8403c5bbdc172a79da2f00eba039a6bb3')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}