summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2024-03-11 22:19:34 +0100
committerThéo Le Calvar2024-03-11 22:19:34 +0100
commit7857290820580fd192afa5d8100bd5d40e58f31a (patch)
treed7bf631967f67b562d2de1e33a55bca5551fd687
parent3e4b6d67831ffb4a98f4835e94b6263f98bc8e8c (diff)
downloadaur-7857290820580fd192afa5d8100bd5d40e58f31a.tar.gz
bump to version 12.8.1 and add patches for kernel 6.8.0
-rw-r--r--.SRCINFO10
-rw-r--r--01-addMutex.patch10
-rw-r--r--02-changeMaxOrder.patch14
-rw-r--r--PKGBUILD20
4 files changed, 43 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca2423800bf2..8edc63ef1ff4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
- pkgver = 12.7
+ pkgver = 12.8.1
pkgrel = 1
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
@@ -9,8 +9,12 @@ pkgbase = decklink
makedepends = curl
options = !strip
options = staticlibs
- source = decklink-12.7.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/b94e51eb5c6c45c48a04b09b72989448
- sha256sums = 71c8b827e80f2c42e742acf0239fca173261eb7afe31c34944ffe30176226a14
+ source = decklink-12.8.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/0636d85539fd4446a24f5952223cc1ec
+ source = 01-addMutex.patch
+ source = 02-changeMaxOrder.patch
+ sha256sums = aff42d039fe1d1fbe5c5df61f0b2434a75067a4e3c861a705dff5f4083e60c02
+ sha256sums = ccbe3ede7302553e00cab2fc11e4c2f974a22b8b7be602f2d4f479f13b45506b
+ sha256sums = eebbccb9d8165e1a048650975b1bddd29569c35e5bbd79fb5dc6ea9688261f49
pkgname = decklink
install = decklink.install
diff --git a/01-addMutex.patch b/01-addMutex.patch
new file mode 100644
index 000000000000..4152fa67b4bd
--- /dev/null
+++ b/01-addMutex.patch
@@ -0,0 +1,10 @@
+--- a/blackmagic-io-12.8.1a1/bm_locks.c 2024-02-09 02:02:38.000000000 +0100
++++ b/blackmagic-io-12.8.1a1/bm_locks.c 2024-03-11 22:08:00.559132781 +0100
+@@ -25,6 +25,7 @@
+ ** -LICENSE-END-
+ */
+ #include <linux/list.h>
++#include <linux/mutex.h>
+ #include <linux/sched.h>
+ #include <linux/spinlock.h>
+ #include "bm_version.h"
diff --git a/02-changeMaxOrder.patch b/02-changeMaxOrder.patch
new file mode 100644
index 000000000000..69d23e1a5233
--- /dev/null
+++ b/02-changeMaxOrder.patch
@@ -0,0 +1,14 @@
+--- a/blackmagic-io-12.8.1a1/bm_util.c 2024-02-09 02:02:38.000000000 +0100
++++ b/blackmagic-io-12.8.1a1/bm_util.c 2024-03-11 22:10:20.051722843 +0100
+@@ -137,7 +137,11 @@
+ alloc_size += align - 1;
+ }
+
++#if KERNEL_VERSION_OR_LATER(6, 8, 0)
++ if (get_order(alloc_size) < MAX_PAGE_ORDER)
++#else
+ if (get_order(alloc_size) < MAX_ORDER)
++#endif
+ mem = (vm_address_t)kmalloc(alloc_size, GFP_KERNEL);
+
+ if (mem == 0 && (flags & BM_ALLOC_CONTIGUOUS) == 0)
diff --git a/PKGBUILD b/PKGBUILD
index df5908ef4212..f16477197ec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
-pkgver=12.7
+pkgver=12.8.1
pkgrel=1
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
@@ -14,7 +14,7 @@ options=('!strip' 'staticlibs')
[ "$CARCH" = "i686" ] && _arch='i386'
[ "$CARCH" = "x86_64" ] && _arch='x86_64'
-_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/b94e51eb5c6c45c48a04b09b72989448"
+_pkgsrc_url="https://www.blackmagicdesign.com/api/register/us/download/0636d85539fd4446a24f5952223cc1ec"
_pkgsrc_file=${_pkgname}-${pkgver}.tar.gz
DLAGENTS=("https::/usr/bin/curl \
@@ -30,8 +30,12 @@ DLAGENTS=("https::/usr/bin/curl \
)
source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
+ "01-addMutex.patch"
+ "02-changeMaxOrder.patch"
)
-sha256sums=('71c8b827e80f2c42e742acf0239fca173261eb7afe31c34944ffe30176226a14')
+sha256sums=('aff42d039fe1d1fbe5c5df61f0b2434a75067a4e3c861a705dff5f4083e60c02'
+ 'ccbe3ede7302553e00cab2fc11e4c2f974a22b8b7be602f2d4f479f13b45506b'
+ 'eebbccb9d8165e1a048650975b1bddd29569c35e5bbd79fb5dc6ea9688261f49')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}
@@ -40,11 +44,11 @@ prepare() {
cd desktopvideo-*/usr/src
- # for p in ${srcdir}/*.patch;
- # do
- # echo "Applying ${p}"
- # patch --forward --strip=1 --input="${p}"
- # done
+ for p in ${srcdir}/*.patch;
+ do
+ echo "Applying ${p}"
+ patch --forward --strip=1 --input="${p}"
+ done
}