summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2023-01-01 13:33:27 +0100
committerThéo Le Calvar2023-01-01 13:33:27 +0100
commit83546c2fb26fee115ef81fac375686ebfaa8479e (patch)
tree4d8df645ef6ea256e3c18a8228dadb84fc6e0d99
parent959165fa90cc890a0f1a98fb7d789add42db05cf (diff)
downloadaur-83546c2fb26fee115ef81fac375686ebfaa8479e.tar.gz
add fixes for kernel 6.1+
-rw-r--r--.SRCINFO6
-rw-r--r--01-remove_prandom.patch13
-rw-r--r--02-remove_snd_dma.patch14
-rw-r--r--PKGBUILD18
4 files changed, 43 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e03a4ba35b0d..8feee2a44b3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
pkgver = 12.4.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -10,7 +10,11 @@ pkgbase = decklink
options = !strip
options = staticlibs
source = decklink-12.4.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/14db0fdb95d54778928cec6711ec543e
+ source = 01-remove_prandom.patch
+ source = 02-remove_snd_dma.patch
sha256sums = d5363b15d305e5484fa62af16b1bd11a296746442dc82c4481d5b193bbbabf3e
+ sha256sums = 5f5d649a5fe4a794d12683635b6e4dcbae47d2d109eeb913e10ce4aa823b3dd9
+ sha256sums = b51ea17289a7eb127443fbb28e79f9fd4a6be249980b7efc0a63a18545f20e02
pkgname = decklink
install = decklink.install
diff --git a/01-remove_prandom.patch b/01-remove_prandom.patch
new file mode 100644
index 000000000000..b30d165d9000
--- /dev/null
+++ b/01-remove_prandom.patch
@@ -0,0 +1,13 @@
+--- a/blackmagic-io-12.4.1a15/bm_util.c 2023-01-01 13:26:47.100202432 +0100
++++ b/blackmagic-io-12.4.1a15/bm_util.c 2023-01-01 13:09:53.705229108 +0100
+@@ -902,7 +902,9 @@
+ // Random
+ uint32_t bm_random32(void)
+ {
+-#if KERNEL_VERSION_OR_LATER(3, 8, 0)
++#if KERNEL_VERSION_OR_LATER(6, 1, 0)
++ return get_random_u32();
++#elif KERNEL_VERSION_OR_LATER(3, 8, 0)
+ return prandom_u32();
+ #elif KERNEL_VERSION_OR_LATER(2, 6, 19)
+ return random32(); \ No newline at end of file
diff --git a/02-remove_snd_dma.patch b/02-remove_snd_dma.patch
new file mode 100644
index 000000000000..c012f874e0fd
--- /dev/null
+++ b/02-remove_snd_dma.patch
@@ -0,0 +1,14 @@
+--- a/blackmagic-io-12.4.1a15/bmio_audio.c 2023-01-01 13:28:20.699872928 +0100
++++ b/blackmagic-io-12.4.1a15/bmio_audio.c 2023-01-01 13:09:47.085284412 +0100
+@@ -432,7 +432,11 @@
+
+ snd_pcm_lib_preallocate_pages_for_all(pcm,
+ SNDRV_DMA_TYPE_CONTINUOUS,
+- snd_dma_continuous_data(GFP_KERNEL),
++ #if KERNEL_VERSION_OR_LATER(6, 1, 0)
++ NULL,
++ #else
++ snd_dma_continuous_data(GFP_KERNEL),
++ #endif
+ bmio_audio_hardware.buffer_size,
+ bmio_audio_hardware.buffer_size); \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 9f5fbd96bac9..8f5012280e54 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
pkgver=12.4.1
-pkgrel=1
+pkgrel=2
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
@@ -30,8 +30,12 @@ DLAGENTS=("https::/usr/bin/curl \
)
source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
+ "01-remove_prandom.patch"
+ "02-remove_snd_dma.patch"
)
-sha256sums=('d5363b15d305e5484fa62af16b1bd11a296746442dc82c4481d5b193bbbabf3e')
+sha256sums=('d5363b15d305e5484fa62af16b1bd11a296746442dc82c4481d5b193bbbabf3e'
+ '5f5d649a5fe4a794d12683635b6e4dcbae47d2d109eeb913e10ce4aa823b3dd9'
+ '85c1d58bd49c6f06f077c77ac26cbe8bc58e68f761b8a01d9f01e843fbc6fa9d')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}
@@ -40,11 +44,11 @@ prepare() {
cd desktopvideo-*/usr/src
- # for p in ${srcdir}/*.patch;
- # do
- # echo "Applying ${p}"
- # patch --forward --strip=1 --input="${p}"
- # done
+ for p in ${srcdir}/*.patch;
+ do
+ echo "Applying ${p}"
+ patch --forward --strip=1 --input="${p}"
+ done
}