summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThéo Le Calvar2021-09-11 09:51:31 +0200
committerThéo Le Calvar2021-09-11 09:51:31 +0200
commitd5330392bf5f35794a4247661d2e457b64e40dff (patch)
treef6a0906a36db0c4b87a30fe77fd5d703f600253b
parentd221118b557fd0319e8fef7e3e9a799de537f95f (diff)
downloadaur-d5330392bf5f35794a4247661d2e457b64e40dff.tar.gz
fix compilation error with linux 5.13
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
-rw-r--r--bm_util.c_5.13.4-200.fc34.x86_64.patch18
3 files changed, 36 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acb9f70110a6..248722c53393 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = decklink
pkgdesc = Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards
pkgver = 12.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.blackmagicdesign.com/support/family/capture-and-playback
arch = i686
arch = x86_64
@@ -10,7 +10,9 @@ pkgbase = decklink
options = !strip
options = staticlibs
source = decklink-12.1.tar.gz::https://www.blackmagicdesign.com/api/register/us/download/114f976c4d3642168d24344d5f5b2afc
+ source = bm_util.c_5.13.4-200.fc34.x86_64.patch
sha256sums = 51febf247d22412beea2d637fcc34cc19b1a46df9a5bf0e157d95705bf7c7b73
+ sha256sums = 66e4bd6a55fcabb1c774c326318daba7fbeb6febcf8867f55c54bf00fc113504
pkgname = decklink
install = decklink.install
@@ -24,4 +26,3 @@ pkgname = mediaexpress
depends = qt5-svg
depends = libpng
depends = decklink
-
diff --git a/PKGBUILD b/PKGBUILD
index 61058116faf4..f0e85e4de3d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=decklink
pkgname=(decklink mediaexpress)
_pkgname=decklink
pkgver=12.1
-pkgrel=1
+pkgrel=2
pkgdesc="Drivers for Blackmagic Design DeckLink, Intensity or Multibridge video editing cards"
arch=('i686' 'x86_64')
url="https://www.blackmagicdesign.com/support/family/capture-and-playback"
@@ -29,8 +29,10 @@ DLAGENTS=("https::/usr/bin/curl \
)"
)
-source=("${_pkgsrc_file}"::"${_pkgsrc_url}")
-sha256sums=('51febf247d22412beea2d637fcc34cc19b1a46df9a5bf0e157d95705bf7c7b73')
+source=("${_pkgsrc_file}"::"${_pkgsrc_url}"
+ "bm_util.c_5.13.4-200.fc34.x86_64.patch")
+sha256sums=('51febf247d22412beea2d637fcc34cc19b1a46df9a5bf0e157d95705bf7c7b73'
+ '66e4bd6a55fcabb1c774c326318daba7fbeb6febcf8867f55c54bf00fc113504')
prepare() {
cd $srcdir/Blackmagic_Desktop_Video_Linux_$pkgver/other/${_arch}
@@ -39,11 +41,16 @@ prepare() {
cd desktopvideo-*/usr/src
- # for p in ${srcdir}/*.patch;
- # do
- # echo "Applying ${p}"
- # patch --forward --strip=1 --input="${p}"
- # done
+ for p in ${srcdir}/*.patch;
+ do
+ echo "Applying ${p}"
+ patch --forward --strip=1 --input="${p}"
+ done
+
+
+ # fix error related to "initialization of « unsigned int (*)(struct tty_struct *) » from pointer type « int (*)(struct tty_struct *) »"
+ sed "s:^EXTRA_CFLAGS +=:EXTRA_CFLAGS += -Wno-error=incompatible-pointer-types:" -i blackmagic-io-*/Makefile
+ sed "s:^EXTRA_CFLAGS +=:EXTRA_CFLAGS += -Wno-error=incompatible-pointer-types:" -i blackmagic-[0-9]*/Makefile
}
package_decklink() {
diff --git a/bm_util.c_5.13.4-200.fc34.x86_64.patch b/bm_util.c_5.13.4-200.fc34.x86_64.patch
new file mode 100644
index 000000000000..7ef1c0a4573f
--- /dev/null
+++ b/bm_util.c_5.13.4-200.fc34.x86_64.patch
@@ -0,0 +1,18 @@
+--- a/blackmagic-io-12.1a9/bm_util.old.c 2021-05-17 15:44:36.000000000 +1000
++++ b/blackmagic-io-12.1a9/bm_util.c 2021-07-26 14:46:37.088542000 +1000
+@@ -24,7 +24,6 @@
+ ** DEALINGS IN THE SOFTWARE.
+ ** -LICENSE-END-
+ */
+-#include <asm/io.h>
+ #include <linux/delay.h>
+ #include <linux/hash.h>
+ #include <linux/interrupt.h>
+@@ -41,6 +40,7 @@
+ #include <linux/uaccess.h>
+ #include <linux/vmalloc.h>
+ #include <linux/wait.h>
++#include <asm/io.h>
+ #include "bm_version.h"
+ #if KERNEL_VERSION_OR_LATER(2, 6, 20)
+ #include <linux/freezer.h>