summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Chappelow2022-09-12 22:54:56 -0500
committerJonathan Chappelow2022-09-12 22:54:56 -0500
commita1b2f0e81c4aa4905bc70d20b8137b1f4281ed10 (patch)
tree4f1102d633ffa2cb511236d8d94671c528cc82b5
parent74735773de1644a6b28bd02f5f82797917a849c6 (diff)
downloadaur-decred.tar.gz
unwritable GOPATH/pkg/mod dirs.... rly?
happy to have wasted time discovering and reading https://github.com/golang/go/issues/27161
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fcba80ba6d5e..c3e44737c9a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,15 +23,15 @@ build() {
echo 'Building dcrd...'
cd "$srcdir/dcrd-release-v$pkgver"
- go install -v -trimpath -mod=readonly -v -ldflags "-buildid= -s -w" . ./cmd/...
+ go install -v -trimpath -mod=readonly -modcacherw -v -ldflags "-buildid= -s -w" . ./cmd/...
echo 'Building dcrwallet...'
cd "$srcdir/dcrwallet-release-v$pkgver"
- go install -v -trimpath -mod=readonly -v -ldflags "-buildid= -s -w" .
+ go install -v -trimpath -mod=readonly -modcacherw -v -ldflags "-buildid= -s -w" .
echo 'Building dcrctl...'
cd "$srcdir/dcrctl-release-v$pkgver"
- go install -v -trimpath -mod=readonly -v -ldflags "-buildid= -s -w" .
+ go install -v -trimpath -mod=readonly -modcacherw -v -ldflags "-buildid= -s -w" .
for _bin in $(find "$srcdir/bin" \
-mindepth 1 \