summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2022-03-20 01:07:42 +0800
committerjustforlxz2022-03-20 01:07:42 +0800
commit59ba1d1850884d3dc6cdb38d9dc6014a5c79bc52 (patch)
tree0d0bec3e7403584004d78d287f2cc965ef60cb95
parent871a7003b615d08ea036126439bdb75ae08a8e07 (diff)
downloadaur-deepin-launcher-git.tar.gz
update
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c9940c1bbd2..a3866ae7d736 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,10 @@
pkgbase = deepin-launcher-git
pkgdesc = Deepin desktop-environment - Launcher module
- pkgver = 5.4.11.r30.g6570c818
+ pkgver = 5.5.6.r63.gd5757bab
pkgrel = 1
url = https://github.com/linuxdeepin/dde-launcher
arch = x86_64
+ arch = aarch64
groups = deepin-git
license = GPL3
makedepends = git
@@ -26,7 +27,7 @@ pkgbase = deepin-launcher-git
depends = xdg-user-dirs
provides = deepin-launcher
conflicts = deepin-launcher
- source = deepin-launcher-git::git://github.com/linuxdeepin/dde-launcher.git
+ source = deepin-launcher-git::git+https://github.com/linuxdeepin/dde-launcher.git
sha512sums = SKIP
pkgname = deepin-launcher-git
diff --git a/PKGBUILD b/PKGBUILD
index 724e3162aafe..eec1b310163b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,10 @@
# Maintainer: justforlxz <justforlxz@gmail.com>
pkgname=deepin-launcher-git
-pkgver=5.4.11.r30.g6570c818
+pkgver=5.5.6.r63.gd5757bab
pkgrel=1
pkgdesc='Deepin desktop-environment - Launcher module'
-arch=('x86_64')
+arch=('x86_64' 'aarch64')
url="https://github.com/linuxdeepin/dde-launcher"
license=('GPL3')
depends=('gsettings-qt' 'qt5-svg' 'qt5-x11extras' 'startdde-git' 'deepin-daemon-git' 'deepin-qt-dbus-factory-git' 'xdg-user-dirs')
@@ -12,7 +12,7 @@ makedepends=('git' 'cmake' 'ninja' 'gtest' 'qt5-tools' 'qt5-base' 'qt5-x11extras
conflicts=('deepin-launcher')
provides=('deepin-launcher')
groups=('deepin-git')
-source=("$pkgname::git://github.com/linuxdeepin/dde-launcher.git")
+source=("$pkgname::git+https://github.com/linuxdeepin/dde-launcher.git")
sha512sums=('SKIP')
pkgver() {
@@ -20,6 +20,13 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd $pkgname
+ if [[ ! -z ${sha} ]];then
+ git checkout -b $sha
+ fi
+}
+
build() {
cd $pkgname
cmake . -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DWITHOUT_UNINSTALL_APP=