summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjustforlxz2024-01-19 20:27:50 +0800
committerjustforlxz2024-01-19 20:27:50 +0800
commit6a37f45ac9698ad28ce75cfae26735580d89bd14 (patch)
tree0ae3df2dd38a40cf663ef7a443af453267887a57
downloadaur-deepin-shell-git.tar.gz
init
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD51
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fa7de4c7a4d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = deepin-shell-git
+ pkgdesc = New DDE shell
+ pkgver = 0.0.4.r16.gbfd8c7a
+ pkgrel = 1
+ url = https://github.com/linuxdeepin/dde-shell
+ arch = x86_64
+ arch = aarch64
+ groups = deepin-git
+ license = LGPL3
+ makedepends = git
+ makedepends = qt6-tools
+ makedepends = qt5-tools
+ makedepends = dtk6declarative
+ makedepends = qt5-wayland
+ makedepends = qt6-wayland
+ makedepends = dtkgui
+ makedepends = dtkwidget
+ makedepends = cmake
+ makedepends = ninja
+ depends = dtk6declarative
+ depends = qt5-wayland
+ depends = qt6-wayland
+ depends = dtkgui
+ depends = dtkwidget
+ provides = deepin-shell
+ conflicts = deepin-shell
+ source = git+https://github.com/linuxdeepin/dde-shell.git
+ sha512sums = SKIP
+
+pkgname = deepin-shell-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a75220cb4a5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: justforlxz <justforlxz@gmail.com>
+
+pkgname=deepin-shell-git
+_pkgname=dde-shell
+pkgver=0.0.4.r16.gbfd8c7a
+pkgrel=1
+pkgdesc='New DDE shell'
+arch=('x86_64' 'aarch64')
+url="https://github.com/linuxdeepin/dde-shell"
+license=('LGPL3')
+depends=('dtk6declarative'
+ 'qt5-wayland'
+ 'qt6-wayland'
+ 'dtkgui'
+ 'dtkwidget'
+)
+makedepends=('git'
+ 'qt6-tools'
+ 'qt5-tools'
+ 'dtk6declarative'
+ 'qt5-wayland'
+ 'qt6-wayland'
+ 'dtkgui'
+ 'dtkwidget'
+ 'cmake'
+ 'ninja'
+)
+conflicts=('deepin-shell')
+provides=('deepin-shell')
+groups=('deepin-git')
+source=("git+https://github.com/linuxdeepin/dde-shell.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd $srcdir/$_pkgname
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $srcdir/$_pkgname
+ cmake -B build -GNinja \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
+}
+
+package() {
+ cd $srcdir/$_pkgname/build
+ DESTDIR="$pkgdir" ninja install
+}