summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJunio CalĂș2020-06-11 06:24:45 -0300
committerJunio CalĂș2020-06-11 06:24:45 -0300
commit9f3203353c8fd88813fc5fd423d749037f83c9f3 (patch)
tree7a4fb476dc3ff550c1cb6af2ed13ed270982b9c2
downloadaur-deepin-topbar-git.tar.gz
starting
-rw-r--r--.SRCINFO21
-rwxr-xr-xPKGBUILD34
-rw-r--r--fix_depends.patch64
3 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7998ded52aa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = deepin-topbar-git
+ pkgdesc = This is topbar for Deepin
+ pkgver = 0.6.6
+ pkgrel = 3
+ url = https://github.com/kirigayakazushin/deepin-topbar
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = qt5-tools
+ depends = deepin-network-utils
+ depends = deepin-qt5integration
+ depends = deepin-qt-dbus-factory
+ depends = libdbusmenu-qt5
+ depends = procps-ng
+ source = deepin-topbar-git-0.6.6.tar.gz::https://github.com/kirigayakazushin/deepin-topbar/archive/0.6.6.tar.gz
+ source = fix_depends.patch
+ sha512sums = 415f6e4eadbe78fe1ab4ef61c5f32f8c945fea56556458a88592da7094aeaf1a03cac2f8ac4a2b0f0d3506368ff3f9f3ae19b5683892f5b995024225f06a65dc
+ sha512sums = d39fa0f074d75de8765a31543a51fe3945f2ed87fe0a544d69c44c0a896a58510a25ba0379b025ebb020912a054fb96d8155359e0859cfda713cf7de40682edb
+
+pkgname = deepin-topbar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..fc05fa71d315
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: kirigaya <kirigaya@mkacg.com>
+
+pkgname=deepin-topbar-git
+pkgver=0.6.6
+pkgrel=3
+pkgdesc="This is topbar for Deepin"
+arch=('x86_64')
+url="https://github.com/kirigayakazushin/deepin-topbar"
+license=('GPL')
+depends=('deepin-network-utils' 'deepin-qt5integration' 'deepin-qt-dbus-factory' 'libdbusmenu-qt5'
+ 'procps-ng')
+makedepends=('cmake' 'qt5-tools')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kirigayakazushin/deepin-topbar/archive/$pkgver.tar.gz"
+ "fix_depends.patch")
+sha512sums=('415f6e4eadbe78fe1ab4ef61c5f32f8c945fea56556458a88592da7094aeaf1a03cac2f8ac4a2b0f0d3506368ff3f9f3ae19b5683892f5b995024225f06a65dc'
+ 'd39fa0f074d75de8765a31543a51fe3945f2ed87fe0a544d69c44c0a896a58510a25ba0379b025ebb020912a054fb96d8155359e0859cfda713cf7de40682edb')
+
+
+prepare() {
+ cd deepin-topbar-$pkgver
+ patch -p1 -i ../fix_depends.patch
+}
+
+build() {
+ cd deepin-topbar-$pkgver
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+package() {
+ cd deepin-topbar-$pkgver
+ make DESTDIR="$pkgdir" install
+}
diff --git a/fix_depends.patch b/fix_depends.patch
new file mode 100644
index 000000000000..1e16ffb359ba
--- /dev/null
+++ b/fix_depends.patch
@@ -0,0 +1,64 @@
+diff --git a/src/widgets/itempopupwindow.h b/src/widgets/itempopupwindow.h
+index 73abcfe..d0667bc 100644
+--- a/src/widgets/itempopupwindow.h
++++ b/src/widgets/itempopupwindow.h
+@@ -4,7 +4,9 @@
+ #include <QWidget>
+ #include <darrowrectangle.h>
+ #include <dregionmonitor.h>
++#include <DRegionMonitor>
+
++DGUI_USE_NAMESPACE
+ DWIDGET_USE_NAMESPACE
+
+ class ItemPopupWindow : public DArrowRectangle
+diff --git a/src/widgets/itempopupwindow.cpp b/src/widgets/itempopupwindow2.cpp
+index e6ed86c..90f9e93 100644
+--- a/src/widgets/itempopupwindow.cpp
++++ b/src/widgets/itempopupwindow2.cpp
+@@ -1,4 +1,7 @@
+ #include "itempopupwindow.h"
++#include <DRegionMonitor>
++
++DGUI_USE_NAMESPACE
+
+ ItemPopupWindow::ItemPopupWindow(QWidget *parent)
+ : DArrowRectangle(DArrowRectangle::ArrowTop, parent)
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 301cf95..60daf59 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists2.txt
+@@ -261,6 +261,8 @@ find_package(PkgConfig REQUIRED)
+ find_package(DtkWidget REQUIRED)
+ find_package(Qt5 COMPONENTS Core Gui DBus Svg X11Extras Concurrent REQUIRED)
+
++pkg_check_modules(DtkWidget REQUIRED dtkwidget)
++pkg_check_modules(DtkGui REQUIRED dtkgui)
+ pkg_check_modules(PROCPS REQUIRED libprocps)
+ pkg_check_modules(XCB_LIBS REQUIRED xcb-ewmh xcb xcb-image xcb-composite xtst xcb-icccm dbusmenu-qt5)
+ pkg_check_modules(XCB_EWMH REQUIRED xcb-ewmh x11 xext)
+diff --git a/src/widgets/switchitem.h b/src/widgets/switchitem.h
+index 92dfe74..1c332da 100644
+--- a/src/widgets/switchitem.h
++++ b/src/widgets/switchitem.h
+@@ -15,7 +15,7 @@ public:
+ explicit SwitchItem(QWidget *parent = 0);
+
+ const QString text() const { return m_text->text(); }
+- bool checked() const { return m_switch->checked(); }
++ bool checked() const { return m_switch->isChecked(); }
+ const QString value() const {return m_value; }
+
+ signals:
+diff --git a/src/modules/sound/sounditem.cpp b/src/modules/sound/sounditem.cpp
+index ec91e21..e3305a9 100644
+--- a/src/modules/sound/sounditem.cpp
++++ b/src/modules/sound/sounditem.cpp
+@@ -51,7 +51,6 @@ SoundItem::SoundItem(QWidget *parent)
+ m_tickScrollArea->hide();
+
+ m_tickEffect->setDirection(DTickEffect::RightToLeft);
+- m_tickEffect->setDuration(3000);
+
+ QHBoxLayout *layout = new QHBoxLayout;
+ layout->setMargin(0);