aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCodist2020-02-08 20:22:26 +0800
committerCodist2020-02-08 20:22:26 +0800
commit534ca46beb3074a9dd1f94e0fda128e213abde94 (patch)
treeb6a6ceb5c0c6a0416dc1cbf5ada04a3fee3e3081
parent7874ae6384ef2e4b61e22ac5a2d4e20d135f9368 (diff)
downloadaur-534ca46beb3074a9dd1f94e0fda128e213abde94.tar.gz
Rename WeChat setup file each time.
Signed-off-by: Codist <countstarlight@gmail.com>
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
-rwxr-xr-xrun.sh3
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff7318f374d7..4bfc7313a69c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,12 +20,12 @@ pkgbase = deepin-wine-wechat
depends = lib32-libldap
conflicts = deepin-wechat
source = https://mirrors.ustc.edu.cn/deepin/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_2.6.2.31deepin0_i386.deb
- source = https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
+ source = WeChatSetup-2.8.0.116.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
source = run.sh
source = reg.patch
md5sums = c66a173fe6817afd898e0061d9eaf42e
md5sums = 7de52e7d92f31f31fa0790bf2e14c7d6
- md5sums = fde92b4241744fdef161aef98cf8f28a
+ md5sums = 17451542cf9ca1465a85361dda409d17
md5sums = 35626e820e6790c230718b4dad6482f6
pkgname = deepin-wine-wechat
diff --git a/PKGBUILD b/PKGBUILD
index 148111cbdf3e..cc57538399cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: CountStarlight <countstarlight@gmail.com>
+# Maintainer: Codist <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
pkgver=2.8.0.116
@@ -14,12 +14,12 @@ conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
_mirror="https://mirrors.ustc.edu.cn/deepin"
source=("$_mirror/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_${deepinwechatver}_i386.deb"
- "https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
+ "${wechat_installer}-${pkgver}.exe::https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
"run.sh"
"reg.patch")
md5sums=('c66a173fe6817afd898e0061d9eaf42e'
'7de52e7d92f31f31fa0790bf2e14c7d6'
- 'fde92b4241744fdef161aef98cf8f28a'
+ '17451542cf9ca1465a85361dda409d17'
'35626e820e6790c230718b4dad6482f6')
build() {
@@ -48,7 +48,7 @@ package() {
install -d "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat"
install -m644 "${srcdir}/files.7z" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
install -m755 "${srcdir}/run.sh" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
- install -m644 "${srcdir}/${wechat_installer}.exe" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
+ install -m644 "${srcdir}/${wechat_installer}-${pkgver}.exe" "${pkgdir}/opt/deepinwine/apps/Deepin-WeChat/"
msg "Printing help info ..."
echo -e "\033[0;34m============================提示/INFO==============================="
echo -e "\033[0;34m* 报告问题(Report issue):"
diff --git a/run.sh b/run.sh
index 6f4d69db909c..4c245a6df0d5 100755
--- a/run.sh
+++ b/run.sh
@@ -10,6 +10,7 @@ WINEPREFIX="$HOME/.deepinwine/Deepin-WeChat"
APPDIR="/opt/deepinwine/apps/Deepin-WeChat"
APPVER="2.6.2.31deepin0"
WECHAT_INSTALLER="WeChatSetup"
+WECHAT_VER="2.8.0.116"
APPTAR="files.7z"
PACKAGENAME="com.wechat"
WINE_CMD="wine"
@@ -27,7 +28,7 @@ CallApp()
if [ ! -f "$WINEPREFIX/reinstalled" ]
then
touch $WINEPREFIX/reinstalled
- env WINEDLLOVERRIDES="winemenubuilder.exe=d" WINEPREFIX="$WINEPREFIX" $WINE_CMD $APPDIR/$WECHAT_INSTALLER.exe
+ env WINEDLLOVERRIDES="winemenubuilder.exe=d" WINEPREFIX="$WINEPREFIX" $WINE_CMD $APPDIR/$WECHAT_INSTALLER-$WECHAT_VER.exe
else
#Support use native file dialog
export ATTACH_FILE_DIALOG=1