aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCountStarlight2019-06-02 23:10:13 +0800
committerCountStarlight2019-06-02 23:10:13 +0800
commit81492c3b46e62ac03d7673b667d85aca311df9ad (patch)
treec7b55b592f21948bf2d9880d05e6ae0a94881196
parentacc43b33f39636fb7ea91c70c1005215c0cc1f64 (diff)
downloadaur-81492c3b46e62ac03d7673b667d85aca311df9ad.tar.gz
Upgrade wechat to 2.6.8.52
Signed-off-by: CountStarlight <countstarlight@gmail.com>
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--.travis.yml13
-rw-r--r--PKGBUILD10
-rw-r--r--README.md33
-rwxr-xr-xrun.sh2
6 files changed, 52 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e68f6b354aca..b8024a47eafc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,12 +20,12 @@ pkgbase = deepin-wine-wechat
depends = lib32-libldap
conflicts = deepin-wechat
source = https://mirrors.ustc.edu.cn/deepin/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_2.6.2.31deepin0_i386.deb
- source = https://dlglobal.qq.com/weixin/Windows/WeChat_C1022.exe
+ source = https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
source = run.sh
source = reg.patch
md5sums = c66a173fe6817afd898e0061d9eaf42e
- md5sums = fd1cac1c27a84cdc8c92f5e7b6f149a7
- md5sums = 1470529573bf3f5721e22e91beb0218c
+ md5sums = 06b1072dfeb2eba50027cd9b237accff
+ md5sums = 88abd550ffce483a3f9627d84e4d5e3a
md5sums = 9c9d51ff585ff630473ce827159a8230
pkgname = deepin-wine-wechat
diff --git a/.gitignore b/.gitignore
index 5462788c57b6..db484d761956 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,6 @@
/deepin-wine-wechat-*.tar.xz
/pkg/
/src/
-/WeChat_*
+/WeChat*
/reg_tmp_fixed/
/reg_tmp/
diff --git a/.travis.yml b/.travis.yml
index 5fec4d8c2cae..d229052adbbc 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -26,3 +26,16 @@ arch:
script:
- "curl -s https://raw.githubusercontent.com/mikkeloscar/arch-travis/master/arch-travis.sh | bash"
+
+deploy:
+ provider: releases
+ skip_cleanup: true
+ overwrite: true
+ api_key: $GH_TOKEN
+ file_glob: true
+ file:
+ - "deepin-wine-wechat-*-x86_64.pkg.tar.xz"
+ on:
+ tags: true
+ all_branches: true
+ repo: countstarlight/deepin-wine-wechat-arch
diff --git a/PKGBUILD b/PKGBUILD
index 12ca193eed81..dc1f6eb7ec9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: CountStarlight <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=2.6.8.51
-wechat_installer=WeChat_C1022
+pkgver=2.6.8.52
+wechat_installer=WeChatSetup
deepinwechatver=2.6.2.31deepin0
pkgrel=1
pkgdesc="Tencent WeChat (com.wechat) on Deepin Wine For Archlinux"
@@ -14,12 +14,12 @@ conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
_mirror="https://mirrors.ustc.edu.cn/deepin"
source=("$_mirror/pool/non-free/d/deepin.com.wechat/deepin.com.wechat_${deepinwechatver}_i386.deb"
- "https://dlglobal.qq.com/weixin/Windows/${wechat_installer}.exe"
+ "https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
"run.sh"
"reg.patch")
md5sums=('c66a173fe6817afd898e0061d9eaf42e'
- 'fd1cac1c27a84cdc8c92f5e7b6f149a7'
- '1470529573bf3f5721e22e91beb0218c'
+ 'f4b84e3c21c3bd7f2217b144fdf8ebe0'
+ '88abd550ffce483a3f9627d84e4d5e3a'
'9c9d51ff585ff630473ce827159a8230')
build() {
diff --git a/README.md b/README.md
index 845c0797231c..efbe8c8a1076 100644
--- a/README.md
+++ b/README.md
@@ -1,15 +1,19 @@
-# 在Archlinux及衍生发行版上运行微信(WeChat)
+在Archlinux及衍生发行版上运行微信(WeChat)
+=======
<p align="center">
<a href="https://travis-ci.org/countstarlight/deepin-wine-wechat-arch">
<img src="https://travis-ci.org/countstarlight/deepin-wine-wechat-arch.svg?branch=master" alt="Build Status">
</a>
<a href="https://pc.weixin.qq.com/">
- <img src="https://img.shields.io/badge/WeChat-2.6.8.51-blue.svg" alt="WeChat Version">
+ <img src="https://img.shields.io/badge/WeChat-2.6.8.52-blue.svg" alt="WeChat Version">
</a>
<a href="https://aur.archlinux.org/packages/deepin-wine-wechat/">
<img src="https://img.shields.io/aur/version/deepin-wine-wechat.svg" alt="AUR Version">
</a>
+ <a href="https://github.com/countstarlight/deepin-wine-wechat-arch/releases">
+ <img src="https://img.shields.io/github/downloads/countstarlight/deepin-wine-wechat-arch/total.svg" alt="GitHub Release">
+ </a>
<a href="https://github.com/countstarlight/deepin-wine-wechat-arch/issues">
<img src="https://img.shields.io/github/issues/countstarlight/deepin-wine-wechat-arch.svg" alt="GitHub Issues">
</a>
@@ -17,11 +21,18 @@
Deepin打包的微信(WeChat)容器移植到Archlinux,不依赖`deepin-wine`,包含定制的注册表配置,微信安装包替换为官方最新
+<!-- TOC -->
+
- [安装](#安装)
+ - [从 AUR 安装](#从-aur-安装)
+ - [从 GitHub Release 安装](#从-github-release-安装)
+ - [从源码安装](#从源码安装)
- [常见问题](#常见问题)
- [感谢](#感谢)
- [更新日志](#更新日志)
+<!-- /TOC -->
+
## 安装
`deepin-wine-wechat`依赖`Multilib`仓库中的`wine`,`wine_gecko`和`wine-mono`,Archlinux默认没有开启`Multilib`仓库,需要编辑`/etc/pacman.conf`,取消对应行前面的注释([Archlinux wiki](https://wiki.archlinux.org/index.php/Official_repositories#multilib)):
@@ -39,12 +50,25 @@ Deepin打包的微信(WeChat)容器移植到Archlinux,不依赖`deepin-wine`
+Include = /etc/pacman.d/mirrorlist
```
-* 1.已添加到AUR [deepin-wine-wechat](https://aur.archlinux.org/packages/deepin-wine-wechat/),可使用 `yay` 或 `yaourt` 安装:
+### 从 AUR 安装
+
+已添加到AUR [deepin-wine-wechat](https://aur.archlinux.org/packages/deepin-wine-wechat/),可使用 `yay` 或 `yaourt` 安装:
+
```shell
yay -S deepin-wine-wechat
```
-* 2.手动安装
+### 从 GitHub Release 安装
+
+> 由 [Travis CI](https://travis-ci.org/countstarlight/deepin-wine-wechat-arch) 在 Docker 容器 [mikkeloscar/arch-travis](https://hub.docker.com/r/mikkeloscar/arch-travis) 中自动构建的 ArchLinux 安装包
+
+在[GitHub Release](https://github.com/countstarlight/deepin-wine-wechat-arch/releases)页面下载 `.pkg.tar.xz`后缀的安装包,使用`pacman`安装:
+
+```bash
+sudo pacman -U #下载的包名
+```
+
+### 从源码安装
```shell
git clone https://github.com/countstarlight/deepin-wine-wechat-arch.git
@@ -70,6 +94,7 @@ yay -S deepin-wine-wechat
## 更新日志
+* 2019-06-02 WeChat-2.6.8.52
* 2019-05-29 WeChat-2.6.8.51
* 2019-04-03 WeChat-2.6.7.57
* 2019-01-03 WeChat-2.6.2 \ No newline at end of file
diff --git a/run.sh b/run.sh
index 9084d9041ca3..2cc75f7a1bf4 100755
--- a/run.sh
+++ b/run.sh
@@ -8,7 +8,7 @@
WINEPREFIX="$HOME/.deepinwine/Deepin-WeChat"
APPDIR="/opt/deepinwine/apps/Deepin-WeChat"
APPVER="2.6.2.31deepin0"
-WECHAT_INSTALLER="WeChat_C1022"
+WECHAT_INSTALLER="WeChatSetup"
APPTAR="files.7z"
PACKAGENAME="com.wechat"
WINE_CMD="wine"