aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCodist2021-04-18 21:55:10 +0800
committerCodist2021-04-18 21:55:10 +0800
commit8f20d85fa4675a7373c7681518a308c28cf83ee6 (patch)
treed5b2eace1400abfd31911ac56582da4eabfd0784
parentd622923b812783187e29dfda5e5c50c85aed10b8 (diff)
downloadaur-8f20d85fa4675a7373c7681518a308c28cf83ee6.tar.gz
Upgrade WeChat to 3.2.1.141
Signed-off-by: Codist <countstarlight@gmail.com>
-rw-r--r--.SRCINFO9
-rw-r--r--.travis.yml1
-rw-r--r--PKGBUILD10
-rw-r--r--README.md12
-rwxr-xr-xrun.sh2
5 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 77c23308d447..be841048765b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deepin-wine-wechat
pkgdesc = Tencent WeChat on Deepin Wine(com.qq.weixin.deepin) For Archlinux
- pkgver = 3.2.1.127
+ pkgver = 3.2.1.141
pkgrel = 1
url = https://weixin.qq.com/
install = deepin-wine-wechat.install
@@ -11,6 +11,7 @@ pkgbase = deepin-wine-wechat
depends = wine-mono
depends = wine-gecko
depends = xorg-xwininfo
+ depends = wqy-microhei
depends = lib32-alsa-lib
depends = lib32-alsa-plugins
depends = lib32-libpulse
@@ -19,11 +20,11 @@ pkgbase = deepin-wine-wechat
depends = lib32-libldap
conflicts = deepin-wechat
source = https://cdn-package-store6.deepin.com/appstore/pool/appstore/c/com.qq.weixin.deepin/com.qq.weixin.deepin_2.9.5.41deepin7_i386.deb
- source = WeChatSetup-3.2.1.127.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
+ source = WeChatSetup-3.2.1.141.exe::https://dldir1.qq.com/weixin/Windows/WeChatSetup.exe
source = run.sh
md5sums = 42794ec8f1e61407e670f1382a0d72db
- md5sums = 2abe12331bb9ff7fe01a2d95ad4bd33f
- md5sums = 467c69c9144ceee7f3d3c0e7d161db3f
+ md5sums = 8dc87bd6aebc50fd0ea3319b59666c7a
+ md5sums = a23031cad146556410e95320e6a73aac
pkgname = deepin-wine-wechat
diff --git a/.travis.yml b/.travis.yml
index 296dcc86c57e..6f46b7455621 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -14,6 +14,7 @@ archlinux:
- wine-mono
- wine-gecko
- xorg-xwininfo
+ - wqy-microhei
- lib32-alsa-lib
- lib32-alsa-plugins
- lib32-libpulse
diff --git a/PKGBUILD b/PKGBUILD
index ecb687b8115e..ed706e8fcef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Codist <countstarlight@gmail.com>
pkgname=deepin-wine-wechat
-pkgver=3.2.1.127
+pkgver=3.2.1.141
wechat_installer=WeChatSetup
deepinwechatver=2.9.5.41deepin7
debpkgname="com.qq.weixin.deepin"
@@ -10,7 +10,7 @@ pkgdesc="Tencent WeChat on Deepin Wine(${debpkgname}) For Archlinux"
arch=("x86_64")
url="https://weixin.qq.com/"
license=('custom')
-depends=('p7zip' 'wine' 'wine-mono' 'wine-gecko' 'xorg-xwininfo' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
+depends=('p7zip' 'wine' 'wine-mono' 'wine-gecko' 'xorg-xwininfo' 'wqy-microhei' 'lib32-alsa-lib' 'lib32-alsa-plugins' 'lib32-libpulse' 'lib32-openal' 'lib32-mpg123' 'lib32-libldap')
conflicts=('deepin-wechat')
install="deepin-wine-wechat.install"
_mirror="https://cdn-package-store6.deepin.com"
@@ -18,8 +18,8 @@ source=("$_mirror/appstore/pool/appstore/c/${debpkgname}/${debpkgname}_${deepinw
"${wechat_installer}-${pkgver}.exe::https://dldir1.qq.com/weixin/Windows/${wechat_installer}.exe"
"run.sh")
md5sums=('42794ec8f1e61407e670f1382a0d72db'
- '2abe12331bb9ff7fe01a2d95ad4bd33f'
- '467c69c9144ceee7f3d3c0e7d161db3f')
+ '8dc87bd6aebc50fd0ea3319b59666c7a'
+ 'a23031cad146556410e95320e6a73aac')
build() {
msg "Extracting DPKG package ..."
@@ -32,6 +32,8 @@ build() {
7z x -aoa "${srcdir}/dpkgdir/opt/apps/${debpkgname}/files/files.7z" -o"${srcdir}/deepinwechatdir"
msg "Cleaning up the original package directory ..."
rm -r "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/WeChat"
+ msg "Creating font file link ..."
+ ln -sf "/usr/share/fonts/wenquanyi/wqy-microhei/wqy-microhei.ttc" "${srcdir}/deepinwechatdir/drive_c/windows/Fonts/wqy-microhei.ttc"
msg "Copying latest WeChat installer to ${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/ ..."
install -m644 "${srcdir}/${wechat_installer}-${pkgver}.exe" "${srcdir}/deepinwechatdir/drive_c/Program Files/Tencent/"
#find -L "${srcdir}/deepinwechatdir/dosdevices" -maxdepth 1 -type l -delete
diff --git a/README.md b/README.md
index 34a1e260b401..ec91c12293ba 100644
--- a/README.md
+++ b/README.md
@@ -6,7 +6,7 @@
<img src="https://img.shields.io/travis/countstarlight/deepin-wine-wechat-arch?&logo=travis&style=flat-square" alt="Build Status">
</a>
<a href="https://pc.weixin.qq.com/">
- <img src="https://img.shields.io/badge/WeChat-3.2.1.127-blue?style=flat-square&logo=wechat" alt="WeChat Version">
+ <img src="https://img.shields.io/badge/WeChat-3.2.1.141-blue?style=flat-square&logo=wechat" alt="WeChat Version">
</a>
<a href="https://aur.archlinux.org/packages/deepin-wine-wechat/">
<img src="https://img.shields.io/aur/version/deepin-wine-wechat?label=AUR&logo=arch-linux&style=flat-square" alt="AUR Version">
@@ -122,7 +122,8 @@ dpi,目录映射等可以在 `winecfg` 进行设置,打开 `winecfg` 的命
| 微信 | wine | 兼容性 | 备注 | deepin-wine | 兼容性 | 备注 |
| :-------: | :-----: | :--------: | :----------------------------------------------------------: | :---------: | :----: | :----------------------------------------------------------: |
-| 3.2.1.127 | 6.5 | 部分 | | 5.0.16-1 | 支持 | |
+| 3.2.1.141 | 6.6 | | | 5.0.16-1 | 支持 | |
+| 3.2.1.127 | 6.5 | 部分 | 群聊闪退&截图功能不可用:[#87](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/87) | 5.0.16-1 | 支持 | |
| 3.1.0.72 | 6.0 | 部分 | 截图功能不可用:[#73](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/73) | 5.0.16-1 | 支持 | |
| 3.1.0.41 | 5.22 | 部分 | 截图功能不可用:[#73](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/73) | 5.0.16-1 | 支持 | |
| 3.0.0.57 | 5.22 | **不支持** | 微信安装程序不能启动:[#92](https://github.com/countstarlight/deepin-wine-wechat-arch/issues/92) | 5.0.16-1 | 支持 | |
@@ -187,13 +188,9 @@ sudo pacman -Rns deepin-wine5
```bash
sudo pacman -S lib32-freetype2 #用原版替换lib32-freetype2-infinality-ultimate
-sudo pacman -Rns deepin-wine xsettingsd wqy-microhei
+sudo pacman -Rns deepin-wine xsettingsd
```
-* `wqy-microhei`:从 `v3.0.0.57-2` 开始,`deepin-wine-wechat` 使用原版打包中自带的字体,不再需要安装中文字体
-
-**注意:切换到 `deepin-wine` 后,对 `wine` 的修改,如更改dpi,都改为对 `deepin-wine` 的修改**
-
## 卸载
无论用何种方式安装,卸载都是:
@@ -247,6 +244,7 @@ bash $HOME/.deepinwine/deepin-wine-helper/sendkeys.sh w wechat 4
<details open>
<summary>2021</summary>
+* 2021-04-18 WeChat-3.2.1.141
* 2021-04-02 WeChat-3.2.1.127
* 2021-01-29 WeChat-3.1.0.72
diff --git a/run.sh b/run.sh
index d15e4cae92b4..669003e4d715 100755
--- a/run.sh
+++ b/run.sh
@@ -35,7 +35,7 @@ extract_archive()
BOTTLENAME="Deepin-WeChat"
APPVER="2.9.5.41deepin7"
WINEPREFIX="$HOME/.deepinwine/$BOTTLENAME"
-WECHAT_VER="3.2.1.127"
+WECHAT_VER="3.2.1.141"
EXEC_PATH="c:/Program Files/Tencent/WeChat/WeChat.exe"
START_SHELL_PATH="$HOME/.deepinwine/deepin-wine-helper/run_v3.sh"
WECHAT_INSTALLER="WeChatSetup"