summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:16 +0200
committerMuflone2015-06-13 17:59:16 +0200
commit43a1136d78cb4b94b0355e0cab50d9b1af9c77c4 (patch)
tree9f62884c943caf1a4ad25f891e645257d5e61299
downloadaur-delay.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--add-stdlib_h.patch11
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc9b42b808dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = delay
+ pkgdesc = Execute a command after a specified period of time or until a time has reached
+ pkgver = 1.6
+ pkgrel = 2
+ url = http://onegeek.org/~tom/software/delay/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://onegeek.org/~tom/software/delay/dl/delay-1.6.tar.gz
+ source = add-stdlib_h.patch
+ sha256sums = 3097a25fc0d0091402fc9dbc6aa395fd5141028bcdc99baa5d3438ca04f78ca2
+ sha256sums = a3dc18a07618361e7cdeeea9e15bb50ea70fe1d97ea3402928a1d4ceef712b0b
+
+pkgname = delay
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d514f259cd22
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+# Contributor: Andrew Fuller <qartis@gmail.com>
+
+pkgname=delay
+pkgver=1.6
+pkgrel=2
+pkgdesc="Execute a command after a specified period of time or until a time has reached"
+arch=('i686' 'x86_64')
+url="http://onegeek.org/~tom/software/delay/"
+license=("GPL")
+source=("http://onegeek.org/~tom/software/${pkgname}/dl/${pkgname}-${pkgver}.tar.gz"
+ "add-stdlib_h.patch")
+sha256sums=('3097a25fc0d0091402fc9dbc6aa395fd5141028bcdc99baa5d3438ca04f78ca2'
+ 'a3dc18a07618361e7cdeeea9e15bb50ea70fe1d97ea3402928a1d4ceef712b0b')
+
+prepare() {
+ patch -p0 -i "add-stdlib_h.patch"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ autoconf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/add-stdlib_h.patch b/add-stdlib_h.patch
new file mode 100644
index 000000000000..2f6028860861
--- /dev/null
+++ b/add-stdlib_h.patch
@@ -0,0 +1,11 @@
+diff -Naur delay-1.6.orig/delay.c delay-1.6/delay.c
+--- delay-1.6.orig/delay.c 2002-02-09 16:26:39.000000000 +0100
++++ delay-1.6/delay.c 2015-03-15 18:32:29.980536243 +0100
+@@ -17,6 +17,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <time.h>
+ #include <sys/time.h>
+ #include <unistd.h>