summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-07-15 17:21:26 -0300
committerDaniel Bermond2017-07-15 17:21:26 -0300
commit9beda843cba9392576671a1432725d2fd90ffdd8 (patch)
treee479c852b415b3b3c41fd0aa77a84a6aa29946b7
parent64766861532767d33c81b3e0d79d914789be888d (diff)
downloadaur-9beda843cba9392576671a1432725d2fd90ffdd8.tar.gz
Cosmetic changings
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a3f5051b17ba..c106f5f70bb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat May 13 15:35:07 UTC 2017
+# Sat Jul 15 20:20:50 UTC 2017
pkgbase = deluge-git
pkgdesc = A bittorrent client written with python and pygtk (git version, 'develop' branch)
pkgver = 2.0.0.dev983.g0353b82c0
- pkgrel = 1
+ pkgrel = 2
url = http://deluge-torrent.org/
install = deluge.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 996ed1eab21d..c7438f1f1c87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,11 @@
pkgname=deluge-git
pkgver=2.0.0.dev983.g0353b82c0
-pkgrel=1
+pkgrel=2
pkgdesc="A bittorrent client written with python and pygtk (git version, 'develop' branch)"
arch=('any')
-url="http://deluge-torrent.org/"
+url='http://deluge-torrent.org/'
license=('GPL3')
-provides=('deluge')
-conflicts=('deluge' 'deluge-stable-git')
-install='deluge.install'
depends=(
'desktop-file-utils' 'hicolor-icon-theme' 'libtorrent-rasterbar'
'python2-service-identity' 'python2-chardet' 'python2-pyopenssl'
@@ -31,8 +28,11 @@ optdepends=('python2-pillow'
'python2-mako: needed for web ui'
'python2-notify: libnotify notifications'
'geoip: display peer locations')
-source=("$pkgname"::"git://deluge-torrent.org/deluge.git#branch=develop" # official repository
- #"$pkgname"::"git+https://github.com/deluge-torrent/deluge.git#branch=develop" # mirror
+provides=('deluge')
+conflicts=('deluge' 'deluge-stable-git')
+install='deluge.install'
+source=("$pkgname"::'git://deluge-torrent.org/deluge.git#branch=develop' # official repository
+ #"$pkgname"::'git+https://github.com/deluge-torrent/deluge.git#branch=develop' # mirror
'deluged.service'
'deluge-web.service')
sha256sums=('SKIP'
@@ -49,7 +49,7 @@ pkgver() {
local _internalver="$(python2 version.py)"
local _shorthash="$(git rev-parse --short HEAD)"
- printf "%s.g%s" "$_internalver" "$_shorthash"
+ printf '%s.g%s' "$_internalver" "$_shorthash"
# alternative
#git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^deluge\.//;s/dev[[:digit:]]*\.//'
@@ -63,11 +63,13 @@ build() {
package() {
cd "$pkgname"
- python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
-
- install -d "${pkgdir}/srv"
- install -dm664 "${pkgdir}/srv/deluge"
- install -Dm644 "deluge/ui/data/pixmaps/deluge.svg" "${pkgdir}/usr/share/pixmaps/deluge.svg"
- install -Dm644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
- install -Dm644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"
+ python2 setup.py install --prefix='/usr' --root="$pkgdir" --optimize='1'
+
+ install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
+ install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"
+
+ install -d "${pkgdir}/srv"
+ install -d -m664 "${pkgdir}/srv/deluge"
+
+ install -D -m644 'deluge/ui/data/pixmaps/deluge.svg' "${pkgdir}/usr/share/pixmaps/deluge.svg"
}