summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-13 12:31:32 -0300
committerDaniel Bermond2017-05-13 12:31:32 -0300
commitc8516c7932803a124ce8a08395e1372045a3598e (patch)
treec44d931a664ee5f0b4687ec86380b48dc2a8b61a
parentfb88468e1bc63443da1d1a3d8ab1f74d1d8db9a7 (diff)
downloadaur-c8516c7932803a124ce8a08395e1372045a3598e.tar.gz
Cosmetic changings
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD50
2 files changed, 24 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0e5525da2ce..67bd2f34aaa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Apr 9 18:25:14 UTC 2017
+# Sat May 13 15:30:04 UTC 2017
pkgbase = deluge-git
pkgdesc = A bittorrent client written with python and pygtk (git version, 'develop' branch)
pkgver = 2.0.0.dev979.ga727ee67b
- pkgrel = 1
+ pkgrel = 2
url = http://deluge-torrent.org/
install = deluge.install
arch = any
license = GPL3
+ makedepends = git
makedepends = intltool
makedepends = librsvg
makedepends = pygtk
makedepends = python2-mako
makedepends = python2-setuptools
- makedepends = git
makedepends = python2-jsmin
makedepends = slimit2
depends = desktop-file-utils
diff --git a/PKGBUILD b/PKGBUILD
index 1213b27bfde5..e61f1a05ff07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=deluge-git
pkgver=2.0.0.dev979.ga727ee67b
-pkgrel=1
+pkgrel=2
pkgdesc="A bittorrent client written with python and pygtk (git version, 'develop' branch)"
arch=('any')
url="http://deluge-torrent.org/"
@@ -14,28 +14,20 @@ license=('GPL3')
provides=('deluge')
conflicts=('deluge' 'deluge-stable-git')
install='deluge.install'
-depends=( # binary repositories:
- 'desktop-file-utils'
- 'hicolor-icon-theme'
- #'libtorrent-rasterbar=1.1.2'
- 'python2-service-identity'
- 'python2-chardet'
- 'python2-pyopenssl'
- 'python2-xdg'
- 'python2-twisted'
- 'xdg-utils'
- # AUR:
- 'libtorrent-rasterbar-git=1.1.2.r0.ga42d4390c')
-makedepends=( # binary repositories:
- 'intltool'
- 'librsvg'
- 'pygtk'
- 'python2-mako'
- 'python2-setuptools'
- 'git'
- # AUR:
- 'python2-jsmin'
- 'slimit2')
+depends=(
+ # binary repositories:
+ 'desktop-file-utils' 'hicolor-icon-theme' #'libtorrent-rasterbar=1.1.2'
+ 'python2-service-identity' 'python2-chardet' 'python2-pyopenssl'
+ 'python2-xdg' 'python2-twisted' 'xdg-utils'
+ # AUR:
+ 'libtorrent-rasterbar-git=1.1.2.r0.ga42d4390c'
+)
+makedepends=(
+ # binary repositories:
+ 'git' 'intltool' 'librsvg' 'pygtk' 'python2-mako' 'python2-setuptools'
+ # AUR:
+ 'python2-jsmin' 'slimit2'
+)
optdepends=('python2-pillow'
'librsvg: needed for gtk ui'
'pygtk: needed for gtk ui'
@@ -51,7 +43,7 @@ sha256sums=('SKIP'
'c3f2d6ad5bc9de5ffd9973d92badbe04a9ecf12c0c575e13d505a96add03275a')
prepare() {
- cd "$pkgname/deluge/ui/data/icons"
+ cd "${pkgname}/deluge/ui/data/icons"
ln -sf hicolor/scalable scalable
}
@@ -76,9 +68,9 @@ package() {
cd "$pkgname"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -d "$pkgdir/srv"
- install -dm664 "$pkgdir/srv/deluge"
- install -Dm644 "deluge/ui/data/pixmaps/deluge.svg" "$pkgdir/usr/share/pixmaps/deluge.svg"
- install -Dm644 "$srcdir/deluged.service" "$pkgdir/usr/lib/systemd/system/deluged.service"
- install -Dm644 "$srcdir/deluge-web.service" "$pkgdir/usr/lib/systemd/system/deluge-web.service"
+ install -d "${pkgdir}/srv"
+ install -dm664 "${pkgdir}/srv/deluge"
+ install -Dm644 "deluge/ui/data/pixmaps/deluge.svg" "${pkgdir}/usr/share/pixmaps/deluge.svg"
+ install -Dm644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
+ install -Dm644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"
}