summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2022-03-16 16:16:35 +0000
committerPellegrino Prevete2022-03-16 16:16:35 +0000
commit0f90ba51e845e2fb78205812c37e1dc8914f8f4f (patch)
treedefd76353c87190bd0c0cd5f4c4381e66bf773c9
downloadaur-densha-de-go.tar.gz
initial build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--psx-template.desktop17
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3522e5df507e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = densha-de-go
+ pkgdesc = 1997 train simulator arcade game developed and published by Taito in Japan.
+ pkgver = 1.0
+ pkgrel = 3
+ url = https://en.wikipedia.org/wiki/Densha_de_Go!_(video_game)
+ arch = any
+ license = custom
+ depends = duckstation
+ source = SCPS-45167.bin::https://archive.org/download/redump.psx/Densha%20de%20Go%21%20%28Japan%29.zip/Densha%20de%20Go%21%20%28Japan%29.bin
+ source = SCPS-45167.cue::https://archive.org/download/redump.psx/Densha%20de%20Go%21%20%28Japan%29.zip/Densha%20de%20Go%21%20%28Japan%29.cue
+ source = psx-template.desktop
+ source = jp.co.taito.DenshaDeGo.png::https://psxdatacenter.com/images/covers/J/D/SCPS-45167.jpg
+ sha256sums = 2d39b81014a3505ad6d944c2b1bb26bd180831969080c5ce0fc3b638a37607d7
+ sha256sums = f2194478004413c87ad4c565cf46380cd71cd5d14cb53f5ef35ca105484b5a22
+ sha256sums = fdfbc31089c3e1b63e92ff58618262b72d1f8baba11a1688f0b8ab3a932d70c6
+ sha256sums = 58de1946ff228ca0001582a1a4787039d160b5ad592b332dda5087a5412007f1
+
+pkgname = densha-de-go
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9565efcb6a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+_uuid="SCPS-45167"
+_app_id="jp.co.taito.DenshaDeGo"
+_title="Densha de Go!"
+_rom_filename="${_title} (Japan)"
+pkgname=densha-de-go
+pkgver=1.0
+pkgrel=3
+pkgdesc="1997 train simulator arcade game developed and published by Taito in Japan."
+arch=('any')
+url="https://en.wikipedia.org/wiki/Densha_de_Go!_(video_game)"
+depends=('duckstation')
+license=("custom")
+_dmca_exemption="https://archive.org/about/dmca.php"
+source=("${_uuid}.bin::https://archive.org/download/redump.psx/Densha%20de%20Go%21%20%28Japan%29.zip/Densha%20de%20Go%21%20%28Japan%29.bin"
+ "${_uuid}.cue::https://archive.org/download/redump.psx/Densha%20de%20Go%21%20%28Japan%29.zip/Densha%20de%20Go%21%20%28Japan%29.cue"
+ "psx-template.desktop"
+ "${_app_id}.png::https://psxdatacenter.com/images/covers/J/D/SCPS-45167.jpg")
+sha256sums=("2d39b81014a3505ad6d944c2b1bb26bd180831969080c5ce0fc3b638a37607d7"
+ "f2194478004413c87ad4c565cf46380cd71cd5d14cb53f5ef35ca105484b5a22"
+ "fdfbc31089c3e1b63e92ff58618262b72d1f8baba11a1688f0b8ab3a932d70c6"
+ "58de1946ff228ca0001582a1a4787039d160b5ad592b332dda5087a5412007f1")
+
+prepare() {
+ mv psx-template.desktop "${_app_id}.desktop"
+ sed -i "s/%_title%/${_title}/g" "${_app_id}.desktop"
+ sed -i "s/%pkgdesc%/${pkgdesc}/g" "${_app_id}.desktop"
+ sed -i "s/%_app_id%/${_app_id}/g" "${_app_id}.desktop"
+ sed -i "s/%_uuid%/${_uuid}/g" "${_app_id}.desktop"
+
+ sed -i -e "s/${_rom_filename}/${_uuid}/g" "${_uuid}.cue"
+}
+
+package() {
+ local _game="${pkgdir}/usr/games/${_app_id}"
+ install -Dm644 "${_uuid}.bin" "${_game}/${_uuid}.bin"
+ install -Dm644 "${_uuid}.cue" "${_game}/${_uuid}.cue"
+ install -Dm755 "${_app_id}.desktop" "${pkgdir}/usr/share/applications/${_app_id}.desktop"
+ install -Dm644 "${_app_id}.png" "${pkgdir}/usr/share/icons/${_app_id}.png"
+}
diff --git a/psx-template.desktop b/psx-template.desktop
new file mode 100644
index 000000000000..64cf24f03691
--- /dev/null
+++ b/psx-template.desktop
@@ -0,0 +1,17 @@
+[Desktop Entry]
+Name=%_title% (%_uuid%)
+Comment=%pkgdesc%
+Type=Application
+TryExec=duckstation-qt
+Exec=duckstation-nogui -fullscreen "/usr/games/%_app_id%/%_uuid%.cue"
+Icon=%_app_id%
+Terminal=false
+Categories=Games;
+Keywords=PSX
+Actions=preferences;
+
+[Desktop Action preferences]
+Name=Preferences
+Exec=duckstation-qt
+
+X-Desktop-File-Install-Version=0.26